hostapd: set VARIANT=* for wpa-cli, hostapd-utils
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Wed, 3 Nov 2021 18:58:57 +0000 (15:58 -0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 14 Nov 2021 23:38:46 +0000 (00:38 +0100)
19aae94 [build: avoid rebuilds of unset VARIANT packages] builds
packages defined without a VARIANT only once, using the first VARIANT
defined in the Makefile.

This caused problems with wpa-cli, as it is only built for variants that
include supplicant support, and the first VARIANT defined may not build
it.

The same happens to hostapd-utils, which is not built for
supplicant-only variants.

To circumvent this, set VARIANT=* for both packages so that they get
built for every defined variant.  This should not cause spurious
rebuilds, since tey are not a dependency of any other package defined in
this Makefile.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
package/network/services/hostapd/Makefile

index 4930851780df5d76d13c7cceea78ad14a3a0ea06..d921df7f97c207dbc6f1a0d3223977e58e62166f 100644 (file)
@@ -426,6 +426,7 @@ define Package/hostapd-utils
   TITLE:=IEEE 802.1x Authenticator (utils)
   URL:=http://hostap.epitest.fi/
   DEPENDS:=@$(subst $(space),||,$(foreach pkg,$(HOSTAPD_PROVIDERS),PACKAGE_$(pkg)))
+  VARIANT:=*
 endef
 
 define Package/hostapd-utils/description
@@ -439,6 +440,7 @@ define Package/wpa-cli
   SUBMENU:=WirelessAPD
   DEPENDS:=@$(subst $(space),||,$(foreach pkg,$(SUPPLICANT_PROVIDERS),PACKAGE_$(pkg)))
   TITLE:=WPA Supplicant command line control utility
+  VARIANT:=*
 endef
 
 define Package/eapol-test/Default