ipq806x: disable CONFIG_CMDLINE_OVERRIDE and ASRock G10
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 28 Dec 2020 14:17:57 +0000 (15:17 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 28 Dec 2020 14:17:57 +0000 (15:17 +0100)
After device support for ASRock G10 was added in [1], several
people reported broken ipq806x devices, with one or several of the
following symptoms:

  - Device does not boot
  - Sysupgrade does not work
  - Serial console is broken

The issues appears to be caused by the introduction of the symbol
CONFIG_CMDLINE_OVERRIDE=y in [1].

This patch disables the corresponding symbol again and marks the
ASRock as BROKEN, as it probably won't work properly without it.

Further references:

https://bugs.openwrt.org/index.php?do=details&task_id=3540
https://github.com/openwrt/openwrt/commit/98b86296e67dd2b467212fe1a577656e6d3725da#commitcomment-45455875

[1] 98b86296e67d ("ipq806x: add support for ASRock G10")

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ipq806x/config-5.4
target/linux/ipq806x/image/Makefile

index e6160bd4554d5aa6f429e93c2752e1ce3a5399f5..43d23563160c5f9828a233c814f2ab4169642181 100644 (file)
@@ -78,7 +78,7 @@ CONFIG_CC_HAS_KASAN_GENERIC=y
 CONFIG_CLKDEV_LOOKUP=y
 CONFIG_CLKSRC_QCOM=y
 CONFIG_CLONE_BACKWARDS=y
-CONFIG_CMDLINE_OVERRIDE=y
+# CONFIG_CMDLINE_OVERRIDE is not set
 CONFIG_COMMON_CLK=y
 CONFIG_COMMON_CLK_QCOM=y
 CONFIG_COMPAT_32BIT_TIME=y
index 80bfec5ad9198a69c7fdd8251f8d35285eb4a216..e1a50e752c6133a9bce7aea4c2cfd091a78c0317 100644 (file)
@@ -103,6 +103,7 @@ define Device/asrock_g10
        KERNEL_SIZE := 5332k
        DEVICE_PACKAGES := kmod-i2c-gpio ath10k-firmware-qca99x0-ct
        IMAGE/nand-factory.bin := append-ubi | edimax-header RN67
+       BROKEN := y
 endef
 TARGET_DEVICES += asrock_g10