ath79: rename ubnt,acb-isp to ubnt,aircube-isp
authorRoman Kuzmitskii <damex.pp@icloud.com>
Tue, 6 Oct 2020 12:08:28 +0000 (12:08 +0000)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 6 Oct 2020 13:13:27 +0000 (15:13 +0200)
Use the full model name for this device to make it easier to
recognize for the users and in order to make it consistent with
the other devices.

While at it, fix sorting in 03_gpio_switches.

Signed-off-by: Roman Kuzmitskii <damex.pp@icloud.com>
[commit message facelift]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/dts/qca9533_ubnt_acb-isp.dts [deleted file]
target/linux/ath79/dts/qca9533_ubnt_aircube-isp.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches
target/linux/ath79/image/generic-ubnt.mk

diff --git a/target/linux/ath79/dts/qca9533_ubnt_acb-isp.dts b/target/linux/ath79/dts/qca9533_ubnt_acb-isp.dts
deleted file mode 100644 (file)
index 449e7fe..0000000
+++ /dev/null
@@ -1,98 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "qca953x.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       compatible = "ubnt,acb-isp", "qca,qca9533";
-       model = "Ubiquiti airCube ISP";
-
-       aliases {
-               label-mac-device = &wmac;
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       linux,code = <KEY_RESTART>;
-                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
-                       debounce-interval = <60>;
-               };
-       };
-};
-
-&spi {
-       status = "okay";
-       num-cs = <1>;
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <25000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x000000 0x040000>;
-                               read-only;
-                       };
-
-                       partition@40000 {
-                               label = "u-boot-env";
-                               reg = <0x040000 0x010000>;
-                               read-only;
-                       };
-
-                       partition@50000 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x050000 0xf60000>;
-                       };
-
-                       partition@fb0000 {
-                               label = "cfg";
-                               reg = <0xfb0000 0x040000>;
-                               read-only;
-                       };
-
-                       art: partition@ff0000 {
-                               label = "art";
-                               reg = <0xff0000 0x010000>;
-                               read-only;
-                       };
-               };
-       };
-};
-
-&uart {
-       status = "okay";
-};
-
-&eth0 {
-       status = "okay";
-
-       phy-handle = <&swphy4>;
-
-       mtd-mac-address = <&art 0x0>;
-};
-
-&eth1 {
-       mtd-mac-address = <&art 0x6>;
-
-       gmac-config {
-               device = <&gmac>;
-       };
-};
-
-&wmac {
-       status = "okay";
-       mtd-cal-data = <&art 0x1000>;
-};
diff --git a/target/linux/ath79/dts/qca9533_ubnt_aircube-isp.dts b/target/linux/ath79/dts/qca9533_ubnt_aircube-isp.dts
new file mode 100644 (file)
index 0000000..b74b075
--- /dev/null
@@ -0,0 +1,98 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca953x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "ubnt,aircube-isp", "qca,qca9533";
+       model = "Ubiquiti airCube ISP";
+
+       aliases {
+               label-mac-device = &wmac;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x050000 0xf60000>;
+                       };
+
+                       partition@fb0000 {
+                               label = "cfg";
+                               reg = <0xfb0000 0x040000>;
+                               read-only;
+                       };
+
+                       art: partition@ff0000 {
+                               label = "art";
+                               reg = <0xff0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&swphy4>;
+
+       mtd-mac-address = <&art 0x0>;
+};
+
+&eth1 {
+       mtd-mac-address = <&art 0x6>;
+
+       gmac-config {
+               device = <&gmac>;
+       };
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+};
index bed817e286b133975578b2b5cf66d6664b0100e2..060c0c9e428d124e9b5e18716300c7c2dbf70111 100755 (executable)
@@ -349,7 +349,7 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "9@eth0"
                ;;
-       ubnt,acb-isp)
+       ubnt,aircube-isp)
                ucidef_set_interface_wan "eth1"
                ucidef_add_switch "switch0" \
                        "0@eth0" "2:lan:1" "3:lan:3" "4:lan:2"
index cf30bb405a26f24edcca7684aadc3490a57fa553..d390fdfbe23375da7e65ce15596f6238f05f3b87 100755 (executable)
@@ -73,6 +73,9 @@ tplink,wbs510-v1|\
 tplink,wbs510-v2)
        ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "20"
        ;;
+ubnt,aircube-isp)
+       ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "11"
+       ;;
 ubnt,nanostation-ac)
        ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "3"
        ;;
@@ -82,9 +85,6 @@ ubnt,nanostation-m)
 ubnt,nanostation-m-xw)
        ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "2"
        ;;
-ubnt,acb-isp)
-       ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "11"
-       ;;
 zbtlink,zbt-wd323)
        ucidef_add_gpio_switch "io0" "IO#0" "0"
        ucidef_add_gpio_switch "io1" "IO#1" "1"
index 6939edd25de86a8de1418a16bc444548a85acf52..cd67ea29041df411d5be1def6e4128bf35e22eb4 100644 (file)
@@ -110,7 +110,7 @@ define Device/ubnt-xw
   UBNT_VERSION := 6.0.4
 endef
 
-define Device/ubnt_acb-isp
+define Device/ubnt_aircube-isp
   $(Device/ubnt)
   SOC := qca9533
   DEVICE_MODEL := airCube ISP
@@ -119,8 +119,9 @@ define Device/ubnt_acb-isp
   UBNT_CHIP := qca9533
   UBNT_TYPE := ACB
   UBNT_VERSION := 2.5.0
+  SUPPORTED_DEVICES += ubnt,acb-isp
 endef
-TARGET_DEVICES += ubnt_acb-isp
+TARGET_DEVICES += ubnt_aircube-isp
 
 define Device/ubnt_airrouter
   $(Device/ubnt-xm)