grub2: make grub2-bios-setup as a separate package
author李国 <uxgood.org@gmail.com>
Sat, 25 Jul 2020 04:04:05 +0000 (04:04 +0000)
committerPaul Spooren <mail@aparcar.org>
Sun, 20 Jun 2021 23:23:42 +0000 (13:23 -1000)
The grub2 and grub2-efi packages should only contain boot-related code.
grub-bios-setup is the same as grub-editenv, they are both grub2 tools
and should be placed in a separate package.

Signed-off-by: 李国 <uxgood.org@gmail.com>
[use AUTORELEASE and update to SPDX]
Signed-off-by: Paul Spooren <mail@aparcar.org>
config/Config-images.in
package/boot/grub2/Makefile

index 715ba212844b117b39e1e33c39d32166e30bcc1b..4a7f08824bd7b9c0ced50fa10282c8575cf5286a 100644 (file)
@@ -200,6 +200,7 @@ menu "Target Images"
                depends on TARGET_x86
                depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
                select PACKAGE_grub2
+               select PACKAGE_grub2-bios-setup
                default y
 
        config GRUB_EFI_IMAGES
@@ -208,6 +209,7 @@ menu "Target Images"
                depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
                select PACKAGE_grub2
                select PACKAGE_grub2-efi
+               select PACKAGE_grub2-bios-setup
                select PACKAGE_kmod-fs-vfat
                default y
 
index a57486b91d094ee0a63b86073d18763a076c2bf3..709253a935e5f3dc034549ac55e99f92056d3eda 100644 (file)
@@ -1,9 +1,6 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2006-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2006-2021 OpenWrt.org
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -11,7 +8,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=grub
 PKG_CPE_ID:=cpe:/a:gnu:grub2
 PKG_VERSION:=2.06~rc1
-PKG_RELEASE:=2
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://alpha.gnu.org/gnu/grub
@@ -54,6 +51,20 @@ define Package/grub2-editenv/description
        Edit grub2 environment files.
 endef
 
+define Package/grub2-bios-setup
+  CATEGORY:=Utilities
+  SECTION:=utils
+  SUBMENU:=Boot Loaders
+  TITLE:=Grub2 BIOS boot setup tool
+  URL:=http://www.gnu.org/software/grub/
+  DEPENDS:=@TARGET_x86
+  VARIANT:=pc
+endef
+
+define Package/grub2-bios-setup/description
+       Set up images to bootable.
+endef
+
 HOST_BUILD_PREFIX := $(STAGING_DIR_HOST)
 
 CONFIGURE_VARS += \
@@ -93,8 +104,6 @@ define Host/Configure
 endef
 
 define Package/grub2/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/grub-bios-setup $(1)/usr/sbin/
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)/grub2
        $(CP) $(PKG_BUILD_DIR)/grub-core/boot.img $(STAGING_DIR_IMAGE)/grub2/
        $(CP) $(PKG_BUILD_DIR)/grub-core/cdboot.img $(STAGING_DIR_IMAGE)/grub2/
@@ -152,7 +161,13 @@ define Package/grub2-editenv/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/grub-editenv $(1)/usr/sbin/
 endef
 
+define Package/grub2-bios-setup/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/grub-bios-setup $(1)/usr/sbin/
+endef
+
 $(eval $(call HostBuild))
 $(eval $(call BuildPackage,grub2))
 $(eval $(call BuildPackage,grub2-efi))
 $(eval $(call BuildPackage,grub2-editenv))
+$(eval $(call BuildPackage,grub2-bios-setup))