ath79: Add support for OpenMesh OM2P-HS v4
authorSven Eckelmann <sven@narfation.org>
Mon, 23 Nov 2020 12:41:34 +0000 (13:41 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 28 Dec 2020 18:37:24 +0000 (19:37 +0100)
Device specifications:
======================

* Qualcomm/Atheros QCA9533 v2
* 650/600/217 MHz (CPU/DDR/AHB)
* 64 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 2x 10/100 Mbps Ethernet
* 2T2R 2.4 GHz Wi-Fi
* 6x GPIO-LEDs (3x wifi, 2x ethernet, 1x power)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default)
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 2x fast ethernet
  - eth0
    + 24V passive POE (mode B)
    + used as WAN interface
  - eth1
    + 802.3af POE
    + builtin switch port 1
    + used as LAN interface
* 12-24V 1A DC
* internal antennas

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to
the device via

  scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <sven@narfation.org>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/qca9533_openmesh_om2p-hs-v4.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index 4d2b03e33c8755a872677f18d113ec3687426566..539e65e762ab8a7c85b8d586fa15a41ed19406c5 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2020.04
-PKG_RELEASE:=10
+PKG_RELEASE:=11
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
index ba857e54ed7455e0ea4c2b39a6010245df38656e..a7564bc89e363d5bf7e76fd2c2b4f3583df0bb8c 100644 (file)
@@ -86,6 +86,7 @@ netgear,wndr4300sw)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x40000" "0x20000"
        ;;
 openmesh,om2p-v4|\
+openmesh,om2p-hs-v4|\
 plasmacloud,pa300|\
 plasmacloud,pa300e)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x40000" "0x40000"
diff --git a/target/linux/ath79/dts/qca9533_openmesh_om2p-hs-v4.dts b/target/linux/ath79/dts/qca9533_openmesh_om2p-hs-v4.dts
new file mode 100644 (file)
index 0000000..218117f
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9533_openmesh_om2p-v4.dtsi"
+
+/ {
+       compatible = "openmesh,om2p-hs-v4", "qca,qca9533";
+       model = "OpenMesh OM2P-HS v4";
+};
index 8095712e889296b8755f27bb450c14e48bd687aa..5795e2a0ae290dda597c59d5c2d0ef62e8648124 100755 (executable)
@@ -230,7 +230,8 @@ netgear,wnr2200-16m)
        ucidef_set_led_switch "lan3amber" "LAN3 (amber)" "amber:lan3" "switch0" "0x08" "0x02"
        ucidef_set_led_switch "lan4amber" "LAN4 (amber)" "amber:lan4" "switch0" "0x10" "0x02"
        ;;
-openmesh,om2p-v4)
+openmesh,om2p-v4|\
+openmesh,om2p-hs-v4)
        ucidef_set_led_netdev "wan" "WAN" "blue:wan" "eth0"
        ucidef_set_led_switch "lan" "LAN" "blue:lan" "switch0" "0x02"
        ;;
index fa98b18e59e44f94daf26ffcb0b1a51ae9d051da..f78fdeea9cde037d48ece5a420885cc1d631fca1 100755 (executable)
@@ -153,6 +153,7 @@ ath79_setup_interfaces()
        comfast,cf-e314n-v2|\
        compex,wpj531-16m|\
        openmesh,om2p-v4|\
+       openmesh,om2p-hs-v4|\
        plasmacloud,pa300|\
        plasmacloud,pa300e|\
        tplink,cpe210-v1|\
index 88dac75301dea80d030dc259fd0f66802c4d9967..6f0ab8f8a66709cebf7d8fbd87035bf8d186964c 100644 (file)
@@ -50,7 +50,8 @@ platform_do_upgrade() {
        jjplus,ja76pf2)
                redboot_fis_do_upgrade "$1" linux
                ;;
-       openmesh,om2p-v4)
+       openmesh,om2p-v4|\
+       openmesh,om2p-hs-v4)
                PART_NAME="inactive"
                platform_do_upgrade_openmesh "$1"
                ;;
index 132bde73c4fb0d021b1eafb23f5add64bdb9ceee..66a39e06d21a55c90a5c59350154c99f193686ee 100644 (file)
@@ -1577,6 +1577,15 @@ define Device/openmesh_om2p-v4
 endef
 TARGET_DEVICES += openmesh_om2p-v4
 
+define Device/openmesh_om2p-hs-v4
+  $(Device/openmesh_om2p-common)
+  SOC := qca9533
+  DEVICE_MODEL := OM2P-HS
+  DEVICE_VARIANT := v4
+  SUPPORTED_DEVICES += om2p-hsv4
+endef
+TARGET_DEVICES += openmesh_om2p-hs-v4
+
 define Device/openmesh_om5p-ac-v2
   SOC := qca9558
   DEVICE_VENDOR := OpenMesh