toolchain: glibc: increase min kernel version to 5.15
authorNick Hainke <vincent@systemli.org>
Thu, 4 May 2023 19:34:21 +0000 (21:34 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 12 May 2023 11:02:43 +0000 (13:02 +0200)
The purpose of this is to remove all of the compatibility code that is
normally compiled into glibc for kernels < 5.15 from our build. Only
Linux kernels >= 5.15 will be supported.

Signed-off-by: Nick Hainke <vincent@systemli.org>
toolchain/glibc/common.mk

index ac396531c994c1608c1bb2f1221dff71d7ed3136..33afb2d60a6dd06c42466f2ba4a5e2c7fb880e9a 100644 (file)
@@ -64,7 +64,7 @@ GLIBC_CONFIGURE:= \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),--enable-stack-protector=yes) \
                  $(if $(CONFIG_PKG_CC_STACKPROTECTOR_STRONG),--enable-stack-protector=strong) \
                  $(if $(CONFIG_PKG_RELRO_FULL),--enable-bind-now) \
-               --enable-kernel=5.10.0
+               --enable-kernel=5.15.0
 
 export libc_cv_ssp=no
 export libc_cv_ssp_strong=no