mac80211: fix r21990
authorAlexandros C. Couloumbis <alex@ozo.com>
Wed, 30 Jun 2010 15:21:15 +0000 (15:21 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Wed, 30 Jun 2010 15:21:15 +0000 (15:21 +0000)
SVN-Revision: 21992

package/mac80211/patches/020-wext-fix.patch

index 157b4e4ef159d145eb8b07b1408c431f790b578c..9cbbb4377b7d3ae95a3f3a2b95e01da77dc411bc 100644 (file)
@@ -1,11 +1,15 @@
 --- a/scripts/gen-compat-autoconf.sh
 +++ b/scripts/gen-compat-autoconf.sh
-@@ -192,7 +192,7 @@ if [ -f $KLIB_BUILD/Makefile ]; then
+@@ -191,10 +191,8 @@ if [ -f $KLIB_BUILD/Makefile ]; then
+               echo CONFIG_NETDEVICES_MULTIQUEUE >> $MULT_DEP_FILE
                define_config_multiple_deps CONFIG_MAC80211_QOS y $ALL_DEPS
                rm -f $MULT_DEP_FILE
-               # Kernels >= 2.6.32 can disable WEXT :D
+-              # Kernels >= 2.6.32 can disable WEXT :D
 -              if [ $SUBLEVEL -le 32 ]; then
-+              if [ $SUBLEVEL -le 35 ]; then
-                       define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT
-               fi
+-                      define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT
+-              fi
++              # Up to kernel 2.6.35 we still need the following:
++              define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT
        fi
+ fi
+ echo "#endif /* COMPAT_AUTOCONF_INCLUDED */"