add kismet update from whiterussian, clean up uclibc++ fixes
authorFelix Fietkau <nbd@openwrt.org>
Mon, 4 Jul 2005 19:38:33 +0000 (19:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 4 Jul 2005 19:38:33 +0000 (19:38 +0000)
SVN-Revision: 1338

openwrt/package/kismet/Makefile
openwrt/package/kismet/ipkg/kismet-client.conffiles
openwrt/package/kismet/ipkg/kismet-drone.conffiles
openwrt/package/kismet/ipkg/kismet-server.conffiles
openwrt/package/kismet/patches/110-uclibc++_fixes.patch

index 33082588309a560f905b0642719b3c92eacabfe9..0f9c0cd26edbf4971f271e08bc80fa350ae78baa 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kismet
 PKG_VERSION:=2005-04-R1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_MD5SUM:=19b4f192eb11a418ed3f6bf65c1226af
 
 PKG_SOURCE_URL:=http://www.kismetwireless.net/code
@@ -44,7 +44,7 @@ $(PKG_BUILD_DIR)/.configured:
                  --localstatedir=/var \
                  --mandir=/usr/share/man \
                  --sbindir=/usr/sbin \
-                 --sysconfdir=/etc \
+                 --sysconfdir=/etc/kismet \
                  $(DISABLE_LARGEFILE) \
                  $(DISABLE_NLS) \
                  --enable-syspcap=yes \
@@ -60,29 +60,29 @@ $(PKG_BUILD_DIR)/.built:
        touch $@
 
 $(IPKG_KISMET_CLIENT):
-       install -d -m0755 $(IDIR_KISMET_CLIENT)/etc
-       install -m0644 ./files/ap_manuf $(IDIR_KISMET_CLIENT)/etc/
-       install -m0644 ./files/client_manuf $(IDIR_KISMET_CLIENT)/etc/
-       install -m0644 ./files/kismet.conf $(IDIR_KISMET_CLIENT)/etc/
-       install -m0644 ./files/kismet_ui.conf $(IDIR_KISMET_CLIENT)/etc/
+       install -d -m0755 $(IDIR_KISMET_CLIENT)/etc/kismet/
+       install -m0644 ./files/ap_manuf $(IDIR_KISMET_CLIENT)/etc/kismet/
+       install -m0644 ./files/client_manuf $(IDIR_KISMET_CLIENT)/etc/kismet/
+       install -m0644 ./files/kismet.conf $(IDIR_KISMET_CLIENT)/etc/kismet/
+       install -m0644 ./files/kismet_ui.conf $(IDIR_KISMET_CLIENT)/etc/kismet/
        install -d -m0755 $(IDIR_KISMET_CLIENT)/usr/sbin
        cp -fpR $(PKG_BUILD_DIR)/kismet_client $(IDIR_KISMET_CLIENT)/usr/sbin/
        $(RSTRIP) $(IDIR_KISMET_CLIENT)
        $(IPKG_BUILD) $(IDIR_KISMET_CLIENT) $(PACKAGE_DIR)
 
 $(IPKG_KISMET_DRONE):
-       install -d -m0755 $(IDIR_KISMET_DRONE)/etc
-       install -m0644 ./files/kismet_drone.conf $(IDIR_KISMET_DRONE)/etc/
+       install -d -m0755 $(IDIR_KISMET_DRONE)/etc/kismet/
+       install -m0644 ./files/kismet_drone.conf $(IDIR_KISMET_DRONE)/etc/kismet/
        install -d -m0755 $(IDIR_KISMET_DRONE)/usr/sbin
        cp -fpR $(PKG_BUILD_DIR)/kismet_drone $(IDIR_KISMET_DRONE)/usr/sbin/
        $(RSTRIP) $(IDIR_KISMET_DRONE)
        $(IPKG_BUILD) $(IDIR_KISMET_DRONE) $(PACKAGE_DIR)
 
 $(IPKG_KISMET_SERVER):
-       install -d -m0755 $(IDIR_KISMET_SERVER)/etc
-       install -m0644 ./files/ap_manuf $(IDIR_KISMET_SERVER)/etc/
-       install -m0644 ./files/client_manuf $(IDIR_KISMET_SERVER)/etc/
-       install -m0644 ./files/kismet.conf $(IDIR_KISMET_SERVER)/etc/
+       install -d -m0755 $(IDIR_KISMET_SERVER)/etc/kismet/
+       install -m0644 ./files/ap_manuf $(IDIR_KISMET_SERVER)/etc/kismet/
+       install -m0644 ./files/client_manuf $(IDIR_KISMET_SERVER)/etc/kismet/
+       install -m0644 ./files/kismet.conf $(IDIR_KISMET_SERVER)/etc/kismet/
        mkdir -p $(IDIR_KISMET_SERVER)/usr/sbin
        cp -fpR  $(PKG_BUILD_DIR)/kismet_server $(IDIR_KISMET_SERVER)/usr/sbin/
        $(RSTRIP) $(IDIR_KISMET_SERVER)
index 5973f3401c518d0a3deb4bc46d72d94a540142b8..b849ce1ce3aa563a9386867751e6b274eb30aaca 100644 (file)
@@ -1,4 +1,4 @@
-/etc/ap_manuf
-/etc/client_manuf
-/etc/kismet.conf
-/etc/kismet_ui.conf
\ No newline at end of file
+/etc/kismet/ap_manuf
+/etc/kismet/client_manuf
+/etc/kismet/kismet.conf
+/etc/kismet/kismet_ui.conf
\ No newline at end of file
index 2814f81b7bab86435947c90b65a0dde352ec7f26..744e244732056681b199cab0789fbfdbfda2e4ce 100644 (file)
@@ -1 +1 @@
-/etc/kismet_drone.conf
+/etc/kismet/kismet_drone.conf
index e2c46e536f3f000df784f53540b94036f3ece7fa..0fdf437639c9873db38c2edd1ad2f75105f6ba0c 100644 (file)
@@ -1,3 +1,3 @@
-/etc/ap_manuf
-/etc/client_manuf
-/etc/kismet.conf
+/etc/kismet/ap_manuf
+/etc/kismet/client_manuf
+/etc/kismet/kismet.conf
index d27bca07b3e4bc3f0148916181ff98846fee0773..4cf5a7b5b53a1d7cabfb18365e8d676835c83659 100644 (file)
@@ -27,27 +27,3 @@ diff -urN kismet-2005-04-R1.old/macaddr.h kismet-2005-04-R1.dev/macaddr.h
              return (singleton_itr != op.singleton_itr) || (vector_itr != op.vector_itr);
          }
  
-diff -urN kismet-2005-04-R1.old/tcpserver.cc kismet-2005-04-R1.dev/tcpserver.cc
---- kismet-2005-04-R1.old/tcpserver.cc 2005-04-03 07:33:42.000000000 +0200
-+++ kismet-2005-04-R1.dev/tcpserver.cc 2005-06-08 23:17:34.000000000 +0200
-@@ -373,7 +373,7 @@
-                 return 0;
-             }
-         } else {
--            copt->wrbuf.erase(0, res);
-+            copt->wrbuf = "";
-       }
-     }
-diff -urN kismet-2005-04-R1.old/tcpclient.cc kismet-2005-04-R1.dev/tcpclient.cc
---- kismet-2005-04-R1.old/tcpclient.cc 2005-04-03 07:33:42.000000000 +0200
-+++ kismet-2005-04-R1.dev/tcpclient.cc 2005-07-01 16:42:33.000000000 +0200
-@@ -214,7 +214,7 @@
-                 return(-1);
-             }
-         } else {
--            writebuf.erase(0, res);
-+            writebuf = "";
-         }
-     }