ath79: consolidate testing kernel
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 10 Apr 2021 16:23:46 +0000 (18:23 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 10 Apr 2021 17:28:04 +0000 (19:28 +0200)
All subtargets have the same testing kernel set, so move it to the
target definition.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/Makefile
target/linux/ath79/generic/target.mk
target/linux/ath79/mikrotik/target.mk
target/linux/ath79/nand/target.mk
target/linux/ath79/tiny/target.mk

index 288f0f5cd53d49f4682c16a65554a1ba2ebc7f72..4063867ce3127602cc73e0098d80cd5e5c26a2fa 100644 (file)
@@ -9,6 +9,7 @@ SUBTARGETS:=generic mikrotik nand tiny
 FEATURES:=ramdisk squashfs usbgadget
 
 KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 2ecaab3f3628c5804ad95badb0a1f79fd3988838..4e53c8926053dc1ef9bc3ac6ac56b82d927ae16e 100644 (file)
@@ -2,8 +2,6 @@ BOARDNAME:=Generic
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl
 
-KERNEL_TESTING_PATCHVER:=5.10
-
 define Target/Description
        Build firmware images for generic Atheros AR71xx/AR913x/AR934x based boards.
 endef
index b98f701fdaabe55218586df0ff60808e415651d6..f5df904487506034e82259738045c2916badbe87 100644 (file)
@@ -5,8 +5,6 @@ IMAGES_DIR := ../../..
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl
 
-KERNEL_TESTING_PATCHVER:=5.10
-
 define Target/Description
        Build firmware images for MikroTik devices based on Qualcomm Atheros
        MIPS SoCs (AR71xx, AR72xx, AR91xx, AR93xx, QCA95xx).
index ed3c381093a10607c1f0925da50ba2eefe531573..7ea9b57f45d5fb991a8f76b2236213af25d297e5 100644 (file)
@@ -4,8 +4,6 @@ FEATURES += nand
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl
 
-KERNEL_TESTING_PATCHVER:=5.10
-
 define Target/Description
        Firmware for boards using Qualcomm Atheros, MIPS-based SoCs
        in the ar72xx and subsequent series, with support for NAND flash
index 74b3e966c478d498b28d2385d60fdd6ce1095dec..91f135b56eda4534edfbf68414933cb42a75d1e2 100644 (file)
@@ -3,8 +3,6 @@ FEATURES += small_flash
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl
 
-KERNEL_TESTING_PATCHVER:=5.10
-
 define Target/Description
        Build firmware images for Atheros AR71xx/AR913x/AR934x based boards with small flash
 endef