util-linux: update to 2.39
authorThomas Weißschuh <thomas@t-8ch.de>
Wed, 17 May 2023 14:58:19 +0000 (16:58 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 18 May 2023 14:56:45 +0000 (16:56 +0200)
Release Notes:
https://cdn.kernel.org/pub/linux/utils/util-linux/v2.39/v2.39-ReleaseNotes

Remove upstreamed:
030-meson-don-t-use-run.patch
040-meson-fix-cpu_set_t-test.patch
050-meson-fix-environ-search.patch
060-meson-add-_GNU_SOURCE-for-sighandler_t.patch
070-meson-fix-isnan-check.patch
080-meson-fix-tzname-check.patch
090-meson-libpam.patch
100-meson-make-libcap-ng-dependent-on-setpriv.patch
120-meson-get-the-project-version-from-the-version-gen-s.patch
130-meson-fix-error-in-processing-version-for-pc-files.patch

New:
0001-test_enosys-add-support-for-mips.patch

Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
[Refresh patches]
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
13 files changed:
package/utils/util-linux/Makefile
package/utils/util-linux/patches/0001-test_enosys-add-support-for-mips.patch [new file with mode: 0644]
package/utils/util-linux/patches/030-meson-don-t-use-run.patch [deleted file]
package/utils/util-linux/patches/040-meson-fix-cpu_set_t-test.patch [deleted file]
package/utils/util-linux/patches/050-meson-fix-environ-search.patch [deleted file]
package/utils/util-linux/patches/060-meson-add-_GNU_SOURCE-for-sighandler_t.patch [deleted file]
package/utils/util-linux/patches/070-meson-fix-isnan-check.patch [deleted file]
package/utils/util-linux/patches/080-meson-fix-tzname-check.patch [deleted file]
package/utils/util-linux/patches/090-meson-libpam.patch [deleted file]
package/utils/util-linux/patches/100-meson-make-libcap-ng-dependent-on-setpriv.patch [deleted file]
package/utils/util-linux/patches/120-meson-get-the-project-version-from-the-version-gen-s.patch [deleted file]
package/utils/util-linux/patches/130-meson-fix-error-in-processing-version-for-pc-files.patch [deleted file]
package/utils/util-linux/patches/200-meson-no-po.patch

index 1ae6bb7b2d8609b14662dcd5536b9bcbfbc98df8..e14d816a42b0729ed18776c1b7319fe8668b9960 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
-PKG_VERSION:=2.38.1
-PKG_RELEASE:=2
+PKG_VERSION:=2.39
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.38
-PKG_HASH:=60492a19b44e6cf9a3ddff68325b333b8b52b6c59ce3ebd6a0ecaa4c5117e84f
+PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.39
+PKG_HASH:=32b30a336cda903182ed61feb3e9b908b762a5e66fe14e43efb88d37162075cb
 PKG_CPE_ID:=cpe:/a:kernel:util-linux
 
 PKG_LICENSE:=GPL-2.0-only
diff --git a/package/utils/util-linux/patches/0001-test_enosys-add-support-for-mips.patch b/package/utils/util-linux/patches/0001-test_enosys-add-support-for-mips.patch
new file mode 100644 (file)
index 0000000..602ffe6
--- /dev/null
@@ -0,0 +1,24 @@
+From 2558932c65524d953e4c86d7fda2282a582aa5ec Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thomas=20Wei=C3=9Fschuh?= <thomas@t-8ch.de>
+Date: Wed, 17 May 2023 16:50:47 +0200
+Subject: [PATCH] test_enosys: add support for mips
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
+---
+ tests/helpers/test_enosys.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+--- a/tests/helpers/test_enosys.c
++++ b/tests/helpers/test_enosys.c
+@@ -53,6 +53,8 @@
+ #    else
+ #      define SECCOMP_ARCH_NATIVE AUDIT_ARCH_PPC64LE
+ #    endif
++#elif __mips__
++#      define SECCOMP_ARCH_NATIVE AUDIT_ARCH_MIPS
+ #else
+ #    error Unknown target architecture
+ #endif
diff --git a/package/utils/util-linux/patches/030-meson-don-t-use-run.patch b/package/utils/util-linux/patches/030-meson-don-t-use-run.patch
deleted file mode 100644 (file)
index 7803dd7..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From e25db9169450d3d5fb43656a2eae5c08999310f4 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Fri, 29 Apr 2022 16:56:54 -0700
-Subject: [PATCH 2/7] meson: don't use run
-
-Fixes cross compilation. run is not needed anyway.
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
----
- meson.build | 6 ++----
- 1 file changed, 2 insertions(+), 4 deletions(-)
-
---- a/meson.build
-+++ b/meson.build
-@@ -577,8 +577,7 @@ int main(void) {
-   return tzname ? 0 : 1;
- }
- '''.format(have ? 1 : 0)
--result = cc.run(code, name : 'using tzname[]')
--have = result.compiled() and result.returncode() == 0
-+have = cc.compiles(code, name : 'using tzname[]')
- conf.set('HAVE_TZNAME', have ? 1 : false)
- socket_libs = []
-@@ -641,8 +640,7 @@ int main(void) {
-     return (*__progname != 0);
- }
- '''
--result = cc.run(code, name : 'using __progname')
--have = result.compiled() and result.returncode() == 0
-+have = cc.compiles(code, name : 'using __progname')
- conf.set('HAVE___PROGNAME', have ? 1 : false)
- build_plymouth_support = get_option('build-plymouth-support')
diff --git a/package/utils/util-linux/patches/040-meson-fix-cpu_set_t-test.patch b/package/utils/util-linux/patches/040-meson-fix-cpu_set_t-test.patch
deleted file mode 100644 (file)
index bdbfc4b..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-From 4194bb5b35e9b5f3296bf17b7cabcc5cb1632ba3 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Fri, 29 Apr 2022 16:55:15 -0700
-Subject: [PATCH 3/7] meson: fix cpu_set_t test
-
-_GNU_SOURCE is needed here.
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/meson.build
-+++ b/meson.build
-@@ -379,7 +379,7 @@ endforeach
- have = cc.has_header('sched.h')
- conf.set10('HAVE_DECL_CPU_ALLOC', have)
- # We get -1 if the size cannot be determined
--have_cpu_set_t = cc.sizeof('cpu_set_t', prefix : '#include <sched.h>') > 0
-+have_cpu_set_t = cc.sizeof('cpu_set_t', prefix : '#define _GNU_SOURCE\n#include <sched.h>') > 0
- conf.set('HAVE_CPU_SET_T', have_cpu_set_t ? 1 : false)
- have = cc.has_header_symbol('stdlib.h', 'environ')
diff --git a/package/utils/util-linux/patches/050-meson-fix-environ-search.patch b/package/utils/util-linux/patches/050-meson-fix-environ-search.patch
deleted file mode 100644 (file)
index 2cd02e5..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-From 1e9e2b9fe365cc4a0025d44dc0a9c54bfffe9058 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Fri, 29 Apr 2022 18:16:17 -0700
-Subject: [PATCH 4/7] meson: fix environ search
-
-musl has it defined in unistd.h and hidden behind _GNU_SOURCE.
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/meson.build
-+++ b/meson.build
-@@ -382,7 +382,7 @@ conf.set10('HAVE_DECL_CPU_ALLOC', have)
- have_cpu_set_t = cc.sizeof('cpu_set_t', prefix : '#define _GNU_SOURCE\n#include <sched.h>') > 0
- conf.set('HAVE_CPU_SET_T', have_cpu_set_t ? 1 : false)
--have = cc.has_header_symbol('stdlib.h', 'environ')
-+have = cc.has_header_symbol('unistd.h', 'environ', prefix : '#define _GNU_SOURCE')
- conf.set10('HAVE_ENVIRON_DECL', have)
- have = cc.has_header_symbol('signal.h', 'sighandler_t')
diff --git a/package/utils/util-linux/patches/060-meson-add-_GNU_SOURCE-for-sighandler_t.patch b/package/utils/util-linux/patches/060-meson-add-_GNU_SOURCE-for-sighandler_t.patch
deleted file mode 100644 (file)
index 7f9137f..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-From 5d7557eb3827664b2b78145373907f2a6994bdf9 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Fri, 29 Apr 2022 18:17:52 -0700
-Subject: [PATCH 5/7] meson: add _GNU_SOURCE for sighandler_t
-
-musl requires it.
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/meson.build
-+++ b/meson.build
-@@ -385,7 +385,7 @@ conf.set('HAVE_CPU_SET_T', have_cpu_set_
- have = cc.has_header_symbol('unistd.h', 'environ', prefix : '#define _GNU_SOURCE')
- conf.set10('HAVE_ENVIRON_DECL', have)
--have = cc.has_header_symbol('signal.h', 'sighandler_t')
-+have = cc.has_header_symbol('signal.h', 'sighandler_t', prefix : '#define _GNU_SOURCE')
- conf.set('HAVE_SIGHANDLER_T', have ? 1 : false)
- have = cc.has_header_symbol('string.h', 'strsignal')
diff --git a/package/utils/util-linux/patches/070-meson-fix-isnan-check.patch b/package/utils/util-linux/patches/070-meson-fix-isnan-check.patch
deleted file mode 100644 (file)
index a0b104f..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-From 777652585924034deeba98ae3192f26bc32bb661 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Fri, 29 Apr 2022 18:19:53 -0700
-Subject: [PATCH 6/7] meson: fix isnan check
-
-musl only has isnan as a macro, not as a function. Handle the former
-case.
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/meson.build
-+++ b/meson.build
-@@ -622,7 +622,7 @@ rtas_libs = cc.find_library('rtas', requ
- conf.set('HAVE_LIBRTAS', rtas_libs.found() ? 1 : false)
- math_libs = []
--if not cc.has_function('isnan')
-+if not cc.has_header_symbol('math.h', 'isnan')
-   lib = cc.find_library('m', required : true)
-   if (cc.has_function('isnan', dependencies : lib) and
-       cc.has_function('__isnan', dependencies : lib))
diff --git a/package/utils/util-linux/patches/080-meson-fix-tzname-check.patch b/package/utils/util-linux/patches/080-meson-fix-tzname-check.patch
deleted file mode 100644 (file)
index f5d53c4..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-From 9a6b2618b46a859388139d1eb18f876886786659 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Fri, 29 Apr 2022 19:00:53 -0700
-Subject: [PATCH] meson: fix tzname check
-
-tzname is not a type but a variable. sizeof only works on types.
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/meson.build
-+++ b/meson.build
-@@ -565,7 +565,7 @@ have = cc.has_member('struct tm', 'tm_zo
-                      prefix : '#include <time.h>')
- conf.set('HAVE_STRUCT_TM_TM_ZONE', have ? 1 : false)
--have = cc.sizeof('tzname', prefix : '#include <time.h>') > 0
-+have = cc.has_header_symbol('time.h', 'tzname')
- conf.set('HAVE_DECL_TZNAME', have ? 1 : false)
- code = '''
diff --git a/package/utils/util-linux/patches/090-meson-libpam.patch b/package/utils/util-linux/patches/090-meson-libpam.patch
deleted file mode 100644 (file)
index c9a91b9..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -299,10 +299,14 @@ conf.set('HAVE_LIBUDEV', lib_udev.found(
- lib_crypt = cc.find_library('crypt')
--lib_pam = cc.find_library('pam')
-+req_libpam = not (get_option('build-login').disabled() or get_option('build-chfn-chsh').disabled()
-+  or get_option('build-su').disabled() or get_option('build-runuser').disabled())
-+lib_pam = cc.find_library('pam', required : req_libpam)
- if lib_pam.found()
-   lib_pam_misc = cc.find_library('pam_misc')
-   lib_pam = [lib_pam, lib_pam_misc]
-+else
-+  lib_pam_misc = declare_dependency()
- endif
- lib_cryptsetup = dependency(
diff --git a/package/utils/util-linux/patches/100-meson-make-libcap-ng-dependent-on-setpriv.patch b/package/utils/util-linux/patches/100-meson-make-libcap-ng-dependent-on-setpriv.patch
deleted file mode 100644 (file)
index d8b1199..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From cd23a4336f49ba6a12ade557a09589f2a7c966f4 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Mon, 2 May 2022 16:18:33 -0700
-Subject: [PATCH] meson: make libcap-ng dependent on setpriv
-
-Signed-off-by: Rosen Penev <rosenp@gmail.com>
----
- meson.build | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
---- a/meson.build
-+++ b/meson.build
-@@ -334,7 +334,8 @@ have = cc.has_function(
- conf.set('HAVE_CRYPT_ACTIVATE_BY_SIGNED_KEY', have ? 1 : false)
- lib_cap_ng = dependency(
--  'libcap-ng')
-+  'libcap-ng',
-+  required : get_option('build-setpriv'))
- lib_selinux = dependency(
-   'libselinux',
-@@ -1754,7 +1755,7 @@ if opt and not is_disabler(exe)
-   exes += exe
- endif
--opt = not get_option('build-setpriv').disabled()
-+opt = not get_option('build-setpriv').disabled() and lib_cap_ng.found()
- exe = executable(
-   'setpriv',
-   setpriv_sources,
diff --git a/package/utils/util-linux/patches/120-meson-get-the-project-version-from-the-version-gen-s.patch b/package/utils/util-linux/patches/120-meson-get-the-project-version-from-the-version-gen-s.patch
deleted file mode 100644 (file)
index 8529c82..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-From e0c1a86bf88b568a7afe8ebaea1b9f84afb892c2 Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz@archlinux.org>
-Date: Wed, 4 May 2022 23:52:31 -0400
-Subject: [PATCH] meson: get the project version from the version-gen script
-
-This matches autotools and ensures that the version number is actually
-reliable.
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/meson.build
-+++ b/meson.build
-@@ -1,5 +1,5 @@
- project('util-linux', 'c',
--        version : '2.37',
-+        version : run_command('tools/git-version-gen', check: true).stdout(),
-         license : 'GPLv2+')
- pkgconfig = import('pkgconfig')
diff --git a/package/utils/util-linux/patches/130-meson-fix-error-in-processing-version-for-pc-files.patch b/package/utils/util-linux/patches/130-meson-fix-error-in-processing-version-for-pc-files.patch
deleted file mode 100644 (file)
index 75e8868..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-From dc307e1cbf73f6dbf72bb049c19d332774cdb4e7 Mon Sep 17 00:00:00 2001
-From: Eli Schwartz <eschwartz@archlinux.org>
-Date: Thu, 5 May 2022 00:16:15 -0400
-Subject: [PATCH] meson: fix error in processing version for pc files
-
-This awk command was copied verbatim from configure.ac, which included
-non-awk syntax because configure.ac cannot contain [ literals.
-
-Rewrite these autoconf quadrigraphs as their actual values, for meson.
-
-Fixes always setting the micro version to "0".
----
- meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/meson.build
-+++ b/meson.build
-@@ -41,7 +41,7 @@ conf.set_quoted('PACKAGE_VERSION', meson
- codes = [''' {print $1}  ''',
-          ''' {sub("-.*","",$2); print $2} ''',
--         ''' {sub("-.*","",$3); print $3 ~ /^@<:@0-9@:>@+$/ ? $3 : 0} ''']
-+         ''' {sub("-.*","",$3); print $3 ~ /^[0-9]+$/ ? $3 : 0} ''']
- pc_version = []
- foreach code : codes
-   res = run_command('bash', '-c',
index d626036bb208d506f9fcd7e1f55d5d3fe9ba5028..4d94f6b89ab8608f49814fade40e529ff78edd1a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/meson.build
 +++ b/meson.build
-@@ -774,7 +774,6 @@ subdir('disk-utils')
+@@ -874,7 +874,6 @@ subdir('disk-utils')
  subdir('misc-utils')
  subdir('text-utils')
  subdir('term-utils')