iproute2: update to 6.2
authorNick Hainke <vincent@systemli.org>
Wed, 22 Feb 2023 14:56:25 +0000 (15:56 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 25 Feb 2023 12:32:35 +0000 (13:32 +0100)
Release Notes:
https://lwn.net/Articles/923952/

Refresh patches:
- 110-darwin_fixes.patch
- 115-add-config-xtlibdir.patch
- 140-allow_pfifo_fast.patch
- 140-keep_libmnl_optional.patch
- 145-keep_libelf_optional.patch
- 150-keep_libcap_optional.patch
- 155-keep_tirpc_optional.patch
- 170-ip_tiny.patch
- 175-reduce-dynamic-syms.patch
- 180-drop_FAILED_POLICY.patch
- 190-fix-nls-rpath-link.patch
- 195-build_variant_ip_tc.patch
- 200-drop_libbsd_dependency.patch
- 300-selinux-configurable.patch

Remove upstreamed:
- 320-configure-Remove-include-sys-stat.h.patch

While working on it remove AUTORELEASE.

Signed-off-by: Nick Hainke <vincent@systemli.org>
16 files changed:
package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/110-darwin_fixes.patch
package/network/utils/iproute2/patches/115-add-config-xtlibdir.patch
package/network/utils/iproute2/patches/140-allow_pfifo_fast.patch
package/network/utils/iproute2/patches/140-keep_libmnl_optional.patch
package/network/utils/iproute2/patches/145-keep_libelf_optional.patch
package/network/utils/iproute2/patches/150-keep_libcap_optional.patch
package/network/utils/iproute2/patches/155-keep_tirpc_optional.patch
package/network/utils/iproute2/patches/170-ip_tiny.patch
package/network/utils/iproute2/patches/175-reduce-dynamic-syms.patch
package/network/utils/iproute2/patches/180-drop_FAILED_POLICY.patch
package/network/utils/iproute2/patches/190-fix-nls-rpath-link.patch
package/network/utils/iproute2/patches/195-build_variant_ip_tc.patch
package/network/utils/iproute2/patches/200-drop_libbsd_dependency.patch
package/network/utils/iproute2/patches/300-selinux-configurable.patch
package/network/utils/iproute2/patches/320-configure-Remove-include-sys-stat.h.patch [deleted file]

index 39c94bd6e201f2de77013f82460cae5a63a56f18..302d57bf8b12b2e9ec0e81ef69b3ee2c42845f83 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=6.1.0
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=6.2.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=5ce12a0fec6b212725ef218735941b2dab76244db7e72646a76021b0537b43ab
+PKG_HASH:=4d72730200ec5b2aabaa1a2f20553c6748292f065d9a154c7d5e22559df9fd62
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=iptables
 PKG_LICENSE:=GPL-2.0
index 1f3eb101ea4c6d915b3be4f4c18a06c0147e6d98..06ae59f8b4db3a0ffc2dfad31984a4ed82f375de 100644 (file)
@@ -1,6 +1,6 @@
 --- a/netem/maketable.c
 +++ b/netem/maketable.c
-@@ -10,7 +10,9 @@
+@@ -11,7 +11,9 @@
  #include <stdio.h>
  #include <stdlib.h>
  #include <math.h>
@@ -12,7 +12,7 @@
  #include <sys/stat.h>
 --- a/netem/normal.c
 +++ b/netem/normal.c
-@@ -8,8 +8,12 @@
+@@ -9,8 +9,12 @@
  #include <string.h>
  #include <limits.h>
  
@@ -27,7 +27,7 @@
  #define TABLEFACTOR NETEM_DIST_SCALE
 --- a/netem/pareto.c
 +++ b/netem/pareto.c
-@@ -7,8 +7,12 @@
+@@ -8,8 +8,12 @@
  #include <math.h>
  #include <limits.h>
  
@@ -42,7 +42,7 @@
  #define TABLESIZE     16384
 --- a/netem/paretonormal.c
 +++ b/netem/paretonormal.c
-@@ -14,10 +14,13 @@
+@@ -15,10 +15,13 @@
  #include <string.h>
  #include <math.h>
  #include <limits.h>
index 8702d5fd2d10f0df9db5d2d856e348c9eefab5b5..03df7809f7f0aa68c4e35f182e698db293a028b0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tc/Makefile
 +++ b/tc/Makefile
-@@ -128,6 +128,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
+@@ -127,6 +127,9 @@ CFLAGS += -DCONFIG_GACT -DCONFIG_GACT_PR
  ifneq ($(IPT_LIB_DIR),)
        CFLAGS += -DIPT_LIB_DIR=\"$(IPT_LIB_DIR)\"
  endif
index 13de48f412872cae661b244e9606c6623e53f5db..8f5a7d352e596007f5f144587a8ba1ebc63b8518 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tc/q_fifo.c
 +++ b/tc/q_fifo.c
-@@ -95,5 +95,6 @@ struct qdisc_util pfifo_head_drop_qdisc_
+@@ -90,5 +90,6 @@ struct qdisc_util pfifo_head_drop_qdisc_
  
  struct qdisc_util pfifo_fast_qdisc_util = {
        .id = "pfifo_fast",
index 7f68f43616403588601e34ca0d1888d7336926ae..a8cdd103ba308c2178488bb9e950224741a81741 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -412,7 +412,7 @@ check_tirpc()
+@@ -411,7 +411,7 @@ check_tirpc()
  
  check_mnl()
  {
index 2eaae88198555ffbe393e334c41986e2daf22238..0c5c3f59ed9adc093be2da5001bf97f1a826fedd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -267,7 +267,7 @@ EOF
+@@ -266,7 +266,7 @@ EOF
  
  check_elf()
  {
index c574840fa8ff1d63c0d0cf136631b11f259054d8..4cce2c3ca6802d44b2f74532ee6f7a835431e13b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -470,7 +470,7 @@ EOF
+@@ -469,7 +469,7 @@ EOF
  
  check_cap()
  {
index 4ee6245d3b0374cc815c41997a800c990b196a6d..28ba7e52176d510f4b58350bf2697836f0280873 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -399,7 +399,7 @@ check_selinux()
+@@ -398,7 +398,7 @@ check_selinux()
  
  check_tirpc()
  {
index eef5e38229b8fa44594d012f7bb6fd2aa0c4cc66..71081c36bccb98d2895fc70b68248b004c33152f 100644 (file)
@@ -25,7 +25,7 @@
                sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
 --- a/ip/ip.c
 +++ b/ip/ip.c
-@@ -65,11 +65,17 @@ static void usage(void)
+@@ -61,11 +61,17 @@ static void usage(void)
        fprintf(stderr,
                "Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
                "       ip [ -force ] -batch filename\n"
@@ -43,7 +43,7 @@
                "       OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
                "                    -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
                "                    -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
-@@ -92,37 +98,49 @@ static const struct cmd {
+@@ -88,37 +94,49 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
        { "address",    do_ipaddr },
index c3892e5a0e4b29ddb5b9f7bb1e271a2128248f3f..d0914848d595507a47ae0658f41e8bd822187530 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tc/Makefile
 +++ b/tc/Makefile
-@@ -114,7 +114,7 @@ LDLIBS += -L. -lm
+@@ -113,7 +113,7 @@ LDLIBS += -L. -lm
  
  ifeq ($(SHARED_LIBS),y)
  LDLIBS += -ldl
@@ -9,7 +9,7 @@
  endif
  
  TCLIB := tc_core.o
-@@ -144,7 +144,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
+@@ -143,7 +143,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
  all: tc $(TCSO)
  
  tc: $(TCOBJ) $(LIBNETLINK) libtc.a
@@ -18,7 +18,7 @@
  
  libtc.a: $(TCLIB)
        $(QUIET_AR)$(AR) rcs $@ $^
-@@ -166,6 +166,7 @@ install: all
+@@ -165,6 +165,7 @@ install: all
  clean:
        rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.tab.h; \
        rm -f emp_ematch.tab.*
@@ -26,7 +26,7 @@
  
  q_atm.so: q_atm.c
        $(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm
-@@ -205,4 +206,16 @@ static-syms.h: $(wildcard *.c)
+@@ -204,4 +205,16 @@ static-syms.h: $(wildcard *.c)
                sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
        done > $@
  
index 094ff393a68df8c5dfe4923404de0052374f37d1..9ce7dd9a13e3644af93043c53e772f34d1459629 100644 (file)
@@ -11,7 +11,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
 
 --- a/ip/rtm_map.c
 +++ b/ip/rtm_map.c
-@@ -54,6 +54,8 @@ char *rtnl_rtntype_n2a(int id, char *buf
+@@ -49,6 +49,8 @@ char *rtnl_rtntype_n2a(int id, char *buf
                return "nat";
        case RTN_XRESOLVE:
                return "xresolve";
@@ -20,7 +20,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
        default:
                snprintf(buf, len, "%d", id);
                return buf;
-@@ -89,6 +91,8 @@ int rtnl_rtntype_a2n(int *id, char *arg)
+@@ -84,6 +86,8 @@ int rtnl_rtntype_a2n(int *id, char *arg)
                res = RTN_UNICAST;
        else if (strcmp(arg, "throw") == 0)
                res = RTN_THROW;
index 2f3f90fe1aafbbdfab93700ff1ee41a9330c6e21..c7fceb2e221063243e12e1df0b28597e4b440e3d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -291,7 +291,7 @@ int main(int argc, char **argv) {
+@@ -290,7 +290,7 @@ int main(int argc, char **argv) {
  }
  EOF
  
@@ -9,7 +9,7 @@
      local ret=$?
  
      rm -f $TMPDIR/libbpf_test.c $TMPDIR/libbpf_test
-@@ -309,7 +309,7 @@ int main(int argc, char **argv) {
+@@ -308,7 +308,7 @@ int main(int argc, char **argv) {
  }
  EOF
  
index dc9c0b2969d68d9d2616f1538ccb4ca30150a685..141763460da501ce40f9915170bdd8442cc39a25 100644 (file)
@@ -11,7 +11,7 @@
  
 --- a/tc/Makefile
 +++ b/tc/Makefile
-@@ -141,7 +141,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
+@@ -140,7 +140,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
        $(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic $< -o $@
  
  
index 052bdd84eb2e517c9a3fcb7417f004c08b3a45eb..d1948860e8665cbb2552f329e2da9e29c39b0ca5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -456,14 +456,8 @@ EOF
+@@ -455,14 +455,8 @@ EOF
      if $CC -I$INCLUDE -o $TMPDIR/strtest $TMPDIR/strtest.c >/dev/null 2>&1; then
        echo "no"
      else
index adfa405c7fc11c3a052e001bfae7ada132f72a07..817abf7d17ac0da772a79f322142d9d5bfdec1f9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -386,7 +386,7 @@ check_libbpf()
+@@ -385,7 +385,7 @@ check_libbpf()
  check_selinux()
  # SELinux is a compile time option in the ss utility
  {
diff --git a/package/network/utils/iproute2/patches/320-configure-Remove-include-sys-stat.h.patch b/package/network/utils/iproute2/patches/320-configure-Remove-include-sys-stat.h.patch
deleted file mode 100644 (file)
index 02bb202..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-From 3a3a2f6be704c970938eb8dac4eb0118f1c2fb06 Mon Sep 17 00:00:00 2001
-From: Hauke Mehrtens <hauke@hauke-m.de>
-Date: Wed, 21 Dec 2022 23:26:28 +0100
-Subject: [PATCH iproute2 v2] configure: Remove include <sys/stat.h>
-
-The check_name_to_handle_at() function in the configure script is
-including sys/stat.h. This include fails with glibc 2.36 like this:
-````
-In file included from /linux-5.15.84/include/uapi/linux/stat.h:5,
-                 from /toolchain-x86_64_gcc-12.2.0_glibc/include/bits/statx.h:31,
-                 from /toolchain-x86_64_gcc-12.2.0_glibc/include/sys/stat.h:465,
-                 from config.YExfMc/name_to_handle_at_test.c:3:
-/linux-5.15.84/include/uapi/linux/types.h:10:2: warning: #warning "Attempt to use kernel headers from user space, see https://kernelnewbies.org/KernelHeaders" [-Wcpp]
-   10 | #warning "Attempt to use kernel headers from user space, see https://kernelnewbies.org/KernelHeaders"
-      |  ^~~~~~~
-In file included from /linux-5.15.84/include/uapi/linux/posix_types.h:5,
-                 from /linux-5.15.84/include/uapi/linux/types.h:14:
-/linux-5.15.84/include/uapi/linux/stddef.h:5:10: fatal error: linux/compiler_types.h: No such file or directory
-    5 | #include <linux/compiler_types.h>
-      |          ^~~~~~~~~~~~~~~~~~~~~~~~
-compilation terminated.
-````
-
-Just removing the include works, the manpage of name_to_handle_at() says
-only fcntl.h is needed.
-
-Fixes: c5b72cc56bf8 ("lib/fs: fix issue when {name,open}_to_handle_at() is not implemented")
-Tested-by: Heiko Thiery <heiko.thiery@gmail.com>
-Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
----
- configure | 1 -
- 1 file changed, 1 deletion(-)
-
---- a/configure
-+++ b/configure
-@@ -215,7 +215,6 @@ check_name_to_handle_at()
-     cat >$TMPDIR/name_to_handle_at_test.c <<EOF
- #define _GNU_SOURCE
- #include <sys/types.h>
--#include <sys/stat.h>
- #include <fcntl.h>
- int main(int argc, char **argv)
- {