ath79: add support for ALFA Network N2Q
authorPiotr Dymacz <pepe2k@gmail.com>
Fri, 18 Sep 2020 16:55:23 +0000 (18:55 +0200)
committerPiotr Dymacz <pepe2k@gmail.com>
Sun, 27 Sep 2020 23:28:37 +0000 (01:28 +0200)
ALFA Network N2Q is an outdoor N300 AP/CPE based on Qualcomm/Atheros
QCA9531 v2. This model is a successor of the old N2 which was based
on Atheros AR7240. FCC ID: 2AB8795311.

Specifications:

- Qualcomm/Atheros QCA9531 v2
- 650/400/200 MHz (CPU/DDR/AHB)
- 128 MB of RAM (DDR2)
- 16 MB of flash (SPI NOR)
- 2T2R 2.4 GHz Wi-Fi with ext. PA (Skyworks SE2623L) and LNA
- 2x 10/100 Mbps Ethernet with passive PoE input in one port (24 V)
- PoE pass through in second port (controlled by GPIO)
- support for optional 802.3af/at PoE module
- 1x mini PCIe slot (PCIe bus, extra 4.2 V for high power cards)
- 2x IPEX/U.FL connectors on PCB
- 1x USB 2.0 mini Type-B (power controlled by GPIO)
- 8x LED (7 of them are driven by GPIO)
- 1x button (reset)
- external h/w watchdog (EM6324QYSP5B, enabled by default)
- UART (4-pin, 2.54 mm pitch) header on PCB
- LEDs (2x 5-pin, 2.54 mm pitch) header on PCB

Flash instruction:

You can use sysupgrade image directly in vendor firmware which is based
on LEDE/OpenWrt. Alternatively, you can use web recovery mode in U-Boot:

1. Configure PC with static IP 192.168.1.2/24.
2. Connect PC with one of RJ45 ports, press the reset button, power up
   device, wait for first blink of all LEDs (indicates network setup),
   then keep button for 3 following blinks and release it.
3. Open 192.168.1.1 address in your browser and upload sysupgrade image.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
target/linux/ath79/dts/qca9531_alfa-network_n2q.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9531_alfa-network_r36a.dts
target/linux/ath79/dts/qca9531_alfa-network_r36a.dtsi [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/image/generic.mk

diff --git a/target/linux/ath79/dts/qca9531_alfa-network_n2q.dts b/target/linux/ath79/dts/qca9531_alfa-network_n2q.dts
new file mode 100644 (file)
index 0000000..8dd91ab
--- /dev/null
@@ -0,0 +1,120 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9531_alfa-network_r36a.dtsi"
+
+/ {
+       model = "ALFA Network N2Q";
+       compatible = "alfa-network,n2q", "qca,qca9531";
+
+       aliases {
+               led-boot = &led_usb;
+               led-failsafe = &led_usb;
+               led-upgrade = &led_usb;
+       };
+
+       gpio-export-pcf8574 {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               poe-passthrough {
+                       gpio-export,name = "poe-passthrough";
+                       gpio-export,output = <1>;
+                       gpios = <&pcf8574 0 GPIO_ACTIVE_LOW>;
+               };
+
+               usb-power {
+                       gpio-export,name = "usb-power";
+                       gpio-export,output = <0>;
+                       gpios = <&pcf8574 2 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       i2c {
+               compatible = "i2c-gpio";
+               #address-cells = <1>;
+               #size-cells = <0>;
+
+               sda-gpios = <&gpio 11 (GPIO_ACTIVE_HIGH | GPIO_OPEN_DRAIN)>;
+               scl-gpios = <&gpio  3 (GPIO_ACTIVE_HIGH | GPIO_OPEN_DRAIN)>;
+
+               pcf8574: pcf8574@20 {
+                       compatible = "nxp,pcf8574";
+                       reg = <0x20>;
+                       gpio-controller;
+                       #gpio-cells = <2>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               pinctrl-names = "default";
+               pinctrl-0 = <&enable_gpio4 &enable_gpio16>;
+
+               lan1 {
+                       label = "n2q:orange:lan1";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+
+               lan2 {
+                       label = "n2q:orange:lan2";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+
+               led_usb: usb {
+                       label = "n2q:green:usb";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "usbport";
+                       trigger-sources = <&hub_port0>;
+               };
+
+               minipcie {
+                       label = "n2q:green:minipcie";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "n2q:green:wlan";
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+       };
+
+       leds-pcf8574 {
+               compatible = "gpio-leds";
+
+               poe-passthrough {
+                       label = "n2q:green:poe-passthrough";
+                       gpios = <&pcf8574 1 GPIO_ACTIVE_LOW>;
+               };
+
+               signal1 {
+                       label = "n2q:red:signal1";
+                       gpios = <&pcf8574 3 GPIO_ACTIVE_LOW>;
+               };
+
+               signal2 {
+                       label = "n2q:orange:signal2";
+                       gpios = <&pcf8574 4 GPIO_ACTIVE_LOW>;
+               };
+
+               signal3 {
+                       label = "n2q:green:signal3";
+                       gpios = <&pcf8574 5 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&eth0 {
+       mtd-mac-address = <&art 0x1002>;
+       mtd-mac-address-increment = <(-2)>;
+};
+
+&eth1 {
+       mtd-mac-address = <&art 0x1002>;
+       mtd-mac-address-increment = <(-1)>;
+};
+
+&pcie0 {
+       status = "okay";
+};
index 18aaa85f5c1a69f8a5aa2544946fc5705f80ed03..0405e40839624ba26b29bf722d9dc90d4c40dcdf 100644 (file)
@@ -1,57 +1,18 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 
-#include "qca953x.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
+#include "qca9531_alfa-network_r36a.dtsi"
 
 / {
        model = "ALFA Network R36A";
        compatible = "alfa-network,r36a", "qca,qca9531";
 
        aliases {
-               label-mac-device = &wmac;
                led-boot = &led_status;
                led-failsafe = &led_status;
                led-running = &led_status;
                led-upgrade = &led_status;
        };
 
-       gpio-export {
-               compatible = "gpio-export";
-               #size-cells = <0>;
-
-               usb-power {
-                       gpio-export,name = "usb-power";
-                       gpio-export,output = <1>;
-                       gpios = <&gpio 3 GPIO_ACTIVE_HIGH>;
-               };
-
-               watchdog-enable {
-                       gpio-export,name = "watchdog-enable";
-                       gpio-export,output = <1>;
-                       gpios = <&gpio 1 GPIO_ACTIVE_HIGH>;
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       linux,code = <KEY_RESTART>;
-                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
-                       debounce-interval = <60>;
-               };
-
-               rfkill {
-                       label = "rfkill";
-                       linux,code = <KEY_RFKILL>;
-                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
-                       debounce-interval = <60>;
-               };
-       };
-
        leds {
                compatible = "gpio-leds";
 
                        linux,default-trigger = "phy0tpt";
                };
        };
-
-       watchdog {
-               compatible = "linux,wdt-gpio";
-               gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
-               hw_algo = "toggle";
-               hw_margin_ms = <25000>;
-               always-running;
-       };
 };
 
 &eth0 {
-       status = "okay";
-
-       phy-handle = <&swphy4>;
        mtd-mac-address = <&art 0x0>;
 };
 
        mtd-mac-address = <&art 0x6>;
 };
 
-&pinmux {
-       enable_gpio4: pinmux_enable_gpio4 {
-               pinctrl-single,bits = <0x04 0x0 0xff>;
-       };
-
-       enable_gpio16: pinmux_enable_gpio16 {
-               pinctrl-single,bits = <0x10 0x0 0xff>;
-       };
-};
-
-&spi {
-       status = "okay";
-
-       num-cs = <1>;
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <50000000>;
-               m25p,fast-read;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x000000 0x060000>;
-                               read-only;
-                       };
-
-                       partition@60000 {
-                               label = "u-boot-env";
-                               reg = <0x060000 0x010000>;
-                       };
-
-                       art: partition@70000 {
-                               label = "art";
-                               reg = <0x070000 0x010000>;
-                               read-only;
-                       };
-
-                       partition@80000 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x080000 0xf80000>;
-                       };
-               };
+&gpio_export {
+       usb-power {
+               gpio-export,name = "usb-power";
+               gpio-export,output = <1>;
+               gpios = <&gpio 3 GPIO_ACTIVE_HIGH>;
        };
 };
 
-&uart {
-       status = "okay";
-};
-
-&usb0 {
-       status = "okay";
-
-       #address-cells = <1>;
-       #size-cells = <0>;
-
-       hub_port0: port@1 {
-               reg = <1>;
-               #trigger-source-cells = <0>;
+&keys {
+       rfkill {
+               label = "rfkill";
+               linux,code = <KEY_RFKILL>;
+               gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               debounce-interval = <60>;
        };
 };
-
-&usb_phy {
-       status = "okay";
-};
-
-&wmac {
-       status = "okay";
-
-       mtd-cal-data = <&art 0x1000>;
-};
diff --git a/target/linux/ath79/dts/qca9531_alfa-network_r36a.dtsi b/target/linux/ath79/dts/qca9531_alfa-network_r36a.dtsi
new file mode 100644 (file)
index 0000000..697b20e
--- /dev/null
@@ -0,0 +1,126 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca953x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       aliases {
+               label-mac-device = &wmac;
+       };
+
+       gpio_export: gpio-export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               watchdog-enable {
+                       gpio-export,name = "watchdog-enable";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 1 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       keys: keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       watchdog {
+               compatible = "linux,wdt-gpio";
+               gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+               hw_algo = "toggle";
+               hw_margin_ms = <25000>;
+               always-running;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&swphy4>;
+};
+
+&pinmux {
+       enable_gpio4: pinmux_enable_gpio4 {
+               pinctrl-single,bits = <0x04 0x0 0xff>;
+       };
+
+       enable_gpio16: pinmux_enable_gpio16 {
+               pinctrl-single,bits = <0x10 0x0 0xff>;
+       };
+};
+
+&spi {
+       status = "okay";
+
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <50000000>;
+               m25p,fast-read;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x060000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "u-boot-env";
+                               reg = <0x060000 0x010000>;
+                       };
+
+                       art: partition@70000 {
+                               label = "art";
+                               reg = <0x070000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@80000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x080000 0xf80000>;
+                       };
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&usb0 {
+       status = "okay";
+
+       #address-cells = <1>;
+       #size-cells = <0>;
+
+       hub_port0: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&usb_phy {
+       status = "okay";
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+};
index 6e488949e438dcfc3afc8570c96488914e7a6e8f..0b522910ee4a7f760c992cb80587f8faca22ec89 100755 (executable)
@@ -17,6 +17,14 @@ alfa-network,ap121fe|\
 avm,fritz450e)
        ucidef_set_led_netdev "lan" "LAN" "$boardname:green:lan" "eth0"
        ;;
+alfa-network,n2q)
+       ucidef_set_led_netdev "lan2" "LAN2" "$boardname:orange:lan2" "eth1"
+       ucidef_set_led_switch "lan1" "LAN1" "$boardname:orange:lan1" "switch0" "0x10"
+       ucidef_set_rssimon "wlan0" "200000" "1"
+       ucidef_set_led_rssi "signal1" "SIGNAL1" "$boardname:red:signal1" "wlan0" "1" "100"
+       ucidef_set_led_rssi "signal2" "SIGNAL2" "$boardname:orange:signal2" "wlan0" "33" "100"
+       ucidef_set_led_rssi "signal3" "SIGNAL3" "$boardname:green:signal3" "wlan0" "66" "100"
+       ;;
 alfa-network,r36a)
        ucidef_set_led_netdev "lan" "LAN" "$boardname:blue:lan" "eth0"
        ucidef_set_led_switch "wan" "WAN" "$boardname:blue:wan" "switch0" "0x10"
index d13d714f8854f47ee1520a503851a037337a91a6..160eea523caeb0d0f7d65a21ca5ee9efcb3aad9f 100755 (executable)
@@ -78,6 +78,12 @@ ath79_setup_interfaces()
        alfa-network,ap121fe)
                ucidef_set_interface_lan "eth0 usb0"
                ;;
+       alfa-network,n2q|\
+       devolo,dvl1200e|\
+       devolo,dvl1750e|\
+       ocedo,ursus)
+               ucidef_set_interface_lan "eth0 eth1"
+               ;;
        avm,fritz4020|\
        pcs,cr3000|\
        tplink,archer-c58-v1|\
@@ -147,11 +153,6 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "3:lan" "2:wan"
                ;;
-       devolo,dvl1200e|\
-       devolo,dvl1750e|\
-       ocedo,ursus)
-               ucidef_set_interface_lan "eth0 eth1"
-               ;;
        devolo,magic-2-wifi)
                ucidef_add_switch "switch0" \
                        "0@eth0" "2:wan" "3:lan" "4:lan"
@@ -402,6 +403,7 @@ ath79_setup_macs()
                ;;
        alfa-network,ap121f|\
        alfa-network,ap121fe|\
+       alfa-network,n2q|\
        alfa-network,r36a|\
        engenius,ens202ext-v1)
                label_mac=$(mtd_get_mac_binary art 0x1002)
index 605f66f77fcad3d9ee828ac60ef6d8e29873539a..920e2e5ceed94a628c82b2e141febaa071539152 100644 (file)
@@ -237,6 +237,16 @@ define Device/alfa-network_ap121fe
 endef
 TARGET_DEVICES += alfa-network_ap121fe
 
+define Device/alfa-network_n2q
+  SOC := qca9531
+  DEVICE_VENDOR := ALFA Network
+  DEVICE_MODEL := N2Q
+  DEVICE_PACKAGES := kmod-i2c-gpio kmod-gpio-pcf857x kmod-usb2 \
+       kmod-usb-ledtrig-usbport rssileds
+  IMAGE_SIZE := 15872k
+endef
+TARGET_DEVICES += alfa-network_n2q
+
 define Device/alfa-network_r36a
   SOC := qca9531
   DEVICE_VENDOR := ALFA Network