uboot-layerscape: bump to LSDK-21.08
authorMartin Schiller <ms@dev.tdt.de>
Thu, 7 Oct 2021 06:56:19 +0000 (08:56 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 13 Dec 2021 22:22:29 +0000 (23:22 +0100)
Update layerscape u-boot package to LSDK-21.08 and drop patches which
are no longer needed.

The new env variable 'fsl_bootcmd_mcinitcmd_set' is needed to protect
the configured bootcmd and mc_init values. See [1] for more
informations.

[1] https://source.denx.de/u-boot/u-boot/-/commit/b62c174e861bddc3c7131045ed018556645cecb9

Signed-off-by: Martin Schiller <ms@dev.tdt.de>
21 files changed:
package/boot/uboot-layerscape/Makefile
package/boot/uboot-layerscape/files/fsl_ls1012a-frdm-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1012a-frwy-sdboot-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1012a-rdb-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1021a-iot-sdboot-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1021a-twr-sdboot-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1021a-twr-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1043a-rdb-sdboot-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1043a-rdb-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1046a-frwy-sdboot-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1046a-frwy-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1046a-rdb-sdboot-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1046a-rdb-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1088a-rdb-sdboot-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls1088a-rdb-uEnv.txt
package/boot/uboot-layerscape/files/fsl_ls2088a-rdb-uEnv.txt
package/boot/uboot-layerscape/files/fsl_lx2160a-rdb-sdboot-uEnv.txt
package/boot/uboot-layerscape/files/fsl_lx2160a-rdb-uEnv.txt
package/boot/uboot-layerscape/patches/0001-board-ls1046ardb-force-PCI-device-enumeration.patch [new file with mode: 0644]
package/boot/uboot-layerscape/patches/0002-board-ls1043ardb-force-PCI-device-enumeration.patch [new file with mode: 0644]
package/boot/uboot-layerscape/patches/010-fix_dtc_compilation_on_host_gcc10.patch [deleted file]

index f02356791de6082d1b83048f44bb76a8fb34c6bd..6681f21e2bc988daa79f39b338f87c3127eb952f 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-layerscape
-PKG_VERSION:=LSDK-20.04-update-290520
+PKG_VERSION:=LSDK-21.08
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://source.codeaurora.org/external/qoriq/qoriq-components/u-boot
-PKG_SOURCE_VERSION:=1e55b2f9e7f56b76569089b9e950f49c1579580e
-PKG_MIRROR_HASH:=46aace27e1367f40b424a64215d524a99c3bd62f49057550039e72d5a1ab7edb
+PKG_SOURCE_VERSION:=LSDK-21.08
+PKG_MIRROR_HASH:=874e871755ef84ebbf35cc247f0979ec18ed1946e4dca71006a83463b2899db1
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
index b0923b592249b091a0e76a6eddc72419553ffb70..b5da9971b60dd5449c3169c82c180258e6b60f48 100644 (file)
@@ -6,3 +6,4 @@ qspi_boot=sf probe 0:0;sf read $loadaddr 1000000 2800000;bootm $loadaddr
 bootargs=rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.spi:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(pfe),2m(reserved-2),1m(dtb),-(firmware)
 bootcmd=echo starting OpenWrt ...;pfe stop;run qspi_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index 1fcd769dc96afd0d8ee180c1ad328cb866e125f4..592158955e8002f1612a88e8a0d759f017403f20 100644 (file)
@@ -6,3 +6,4 @@ sd_boot=ext4load mmc 0:1 $loadaddr fitImage;bootm $loadaddr
 bootargs=root=/dev/mmcblk0p2 rw rootwait rootfstype=squashfs,f2fs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200
 bootcmd=echo starting openwrt ...;pfe stop;run sd_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index 1d108a1b03f0c28edd48a579218efd493aa2c2a2..8d57d51ece75c5b45ced095cc8f8a6112f0dd738 100644 (file)
@@ -5,3 +5,4 @@ qspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000
 bootargs=root=/dev/mtdblock8 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.spi:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(pfe),2m(reserved-2),1m(dtb),16m(kernel),32m(rootfs),49m@0xf00000(firmware)
 bootcmd=echo starting openwrt ...;pfe stop;run qspi_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index ed8661bc6efa83d08bb62dd2694241a976949fd4..55620d67257c830bcb135fed3f77f92783063ef2 100644 (file)
@@ -6,3 +6,4 @@ sd_boot=ext4load mmc 0:1 $loadaddr fitImage;bootm $loadaddr
 bootargs=root=/dev/mmcblk0p2 rw rootwait rootfstype=squashfs,f2fs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200
 bootcmd=echo starting openwrt ...;run sd_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index ed8661bc6efa83d08bb62dd2694241a976949fd4..55620d67257c830bcb135fed3f77f92783063ef2 100644 (file)
@@ -6,3 +6,4 @@ sd_boot=ext4load mmc 0:1 $loadaddr fitImage;bootm $loadaddr
 bootargs=root=/dev/mmcblk0p2 rw rootwait rootfstype=squashfs,f2fs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200
 bootcmd=echo starting openwrt ...;run sd_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index 6e39e05525306547b8069a263d9a69d8221d1081..6d4647b1fd6e1c6795f3b4b9a12a81d325a38410 100644 (file)
@@ -5,3 +5,4 @@ nor_boot=cp.b 60f00000 $fdtaddr 100000;cp.b 61000000 $loadaddr 1000000;bootm $lo
 bootargs=root=/dev/mtdblock6 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=60000000.nor:1m(rcw),2m(u-boot),1m(u-boot-env),11m(reserved-1),1m(dtb),16m(kernel),32m(rootfs),49m@0xf00000(firmware) cma=64M@0x0-0xb0000000
 bootcmd=echo starting openwrt ...;run nor_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index 6034033876333bafacd16eb0e5d02ee6d77aa802..3c39c2263de06d50032385f14ebe941083f1bdb1 100644 (file)
@@ -7,3 +7,4 @@ sd_boot=ext4load mmc 0:1 $loadaddr fitImage;bootm $loadaddr
 bootargs=root=/dev/mmcblk0p2 rw rootwait rootfstype=squashfs,f2fs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200
 bootcmd=echo starting openwrt ...;run sd_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index b381bde18fcf4a4569c0b8461ce6e465f5393faf..acb61ca00a32db3832fa7ffe7baab0313d9f4497 100644 (file)
@@ -6,3 +6,4 @@ nor_boot=cp.b 60f00000 $fdtaddr 100000;cp.b 61000000 $loadaddr 1000000;bootm $lo
 bootargs=root=/dev/mtdblock8 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=60000000.nor:1m(bl2),4m(fip),1m(u-boot-env),3m(reserved-1),256k(fman),5888k(reserved-2),1m(dtb),16m(kernel),32m(rootfs),49m@0xf00000(firmware)
 bootcmd=echo starting openwrt ...;run nor_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index ed16dde9843ed85306e4cf0a440bf49c9527ce42..303157cb8004052e27fd2c1f8d6d8836bcaac3e5 100644 (file)
@@ -6,3 +6,4 @@ sd_boot=ext4load mmc 0:1 ${loadaddr} fitImage;bootm ${loadaddr}
 bootargs=root=/dev/mmcblk0p2 rw rootwait rootfstype=squashfs,f2fs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200
 bootcmd=echo starting openwrt ...;run sd_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index 9daba4aedb2e8a85c68fe1b6b12fd12fafd5fa82..5461bba9b667167caecb33948f9ba4c1a50dc3e5 100644 (file)
@@ -6,3 +6,4 @@ qspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000
 bootargs=root=/dev/mtdblock9 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.spi:1m(bl2),4m(fip),1m(u-boot-env),3m(reserved-1),256k(fman),5888k(reserved-2),1m(dtb),16m(kernel),32m(rootfs),49m@0xf00000(firmware)
 bootcmd=echo starting openwrt ...;run qspi_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index 6034033876333bafacd16eb0e5d02ee6d77aa802..3c39c2263de06d50032385f14ebe941083f1bdb1 100644 (file)
@@ -7,3 +7,4 @@ sd_boot=ext4load mmc 0:1 $loadaddr fitImage;bootm $loadaddr
 bootargs=root=/dev/mmcblk0p2 rw rootwait rootfstype=squashfs,f2fs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200
 bootcmd=echo starting openwrt ...;run sd_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index d24f9ec2017a0b6bbf9f15f8528800757d3b7339..e52e48802bc23cc7f9e09a8d6bf86b8cde04a32c 100644 (file)
@@ -6,3 +6,4 @@ qspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000
 bootargs=root=/dev/mtdblock9 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.spi-0:1m(bl2),4m(fip),1m(u-boot-env),3m(reserved-1),256k(fman),5888k(reserved-2),1m(dtb),16m(kernel),32m(rootfs),49m@0xf00000(firmware)
 bootcmd=echo starting openwrt ...;run qspi_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index b25e9c8ee70bed3cb6ce0b072cf30c4cb216c58b..f616cb1398657f558ff9a5e90e3e9eacff510779 100644 (file)
@@ -8,3 +8,4 @@ sd_boot=ext4load mmc 0:1 $loadaddr fitImage;bootm $loadaddr
 bootargs=root=/dev/mmcblk0p2 rw rootwait rootfstype=squashfs,f2fs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200
 bootcmd=echo starting openwrt ...;run mc_init;run sd_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index 6ac6216d647e9d5005e557d45ddf4e5758bd36f7..210c18721df2f264b16556f03ecf3eae8a6d86d8 100644 (file)
@@ -8,3 +8,4 @@ qspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000
 bootargs=root=/dev/mtdblock10 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=20c0000.spi-0:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(mc),1m(dpl),1m(dpc),1m(dtb),16m(kernel),32m(rootfs),49m@0xf00000(firmware)
 bootcmd=echo starting openwrt ...;run mc_init;run qspi_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index eb10a88d77b995125c7cba939f29903c0d8a9c6f..946029d1f16cd2896fcc34b603407ff9629a1ce2 100644 (file)
@@ -8,3 +8,4 @@ nor_boot=cp.b 580f00000 $fdtaddr 100000;cp.b 581000000 $loadaddr 1000000;bootm $
 bootargs=root=/dev/mtdblock9 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS1,115200 mtdparts=580000000.nor:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(mc),1m(dpl),1m(dpc),1m(dtb),16m(kernel),32m(rootfs),49m@0xf00000(firmware)
 bootcmd=echo starting openwrt ...;run mc_init;run nor_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index 6b4e920c9efacd953ac4d813a10992620f04a2d6..d1373199150ae61e06e473226c8ffc3b0ed45dca 100644 (file)
@@ -7,3 +7,4 @@ sd_boot=ext4load mmc 0:1 ${loadaddr} fitImage;bootm ${loadaddr}
 bootargs=root=/dev/mmcblk0p2 rw rootwait rootfstype=squashfs,f2fs noinitrd earlycon=pl011,mmio32,0x21c0000 console=ttyAMA0,115200
 bootcmd=echo starting openwrt ...;run mc_init;run sd_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
index 08757b44606c0049e75a4bf050497f21da845581..41fde35c88c1665645d94cd7658058cf556f1f59 100644 (file)
@@ -7,3 +7,4 @@ xspi_boot=sf probe 0:0;sf read $fdtaddr f00000 100000;sf read $loadaddr 1000000
 bootargs=root=/dev/mtdblock9 rootfstype=squashfs,jffs2 noinitrd earlycon=pl011,mmio32,0x21c0000 console=ttyAMA0,115200 mtdparts=20c0000.spi-0:1m(bl2),4m(fip),1m(u-boot-env),4m(reserved-1),3m(mc),1m(dpl),1m(dpc),1m(dtb),16m(kernel),32m(rootfs),49m@0xf00000(firmware)
 bootcmd=echo starting openwrt ...;run mc_init;run xspi_boot
 bootdelay=3
+fsl_bootcmd_mcinitcmd_set=y
diff --git a/package/boot/uboot-layerscape/patches/0001-board-ls1046ardb-force-PCI-device-enumeration.patch b/package/boot/uboot-layerscape/patches/0001-board-ls1046ardb-force-PCI-device-enumeration.patch
new file mode 100644 (file)
index 0000000..25a6b16
--- /dev/null
@@ -0,0 +1,33 @@
+From 089b90b11008ec95a56da12e31d11e3f31a9bb26 Mon Sep 17 00:00:00 2001
+From: Martin Schiller <ms@dev.tdt.de>
+Date: Wed, 17 Nov 2021 07:29:55 +0100
+Subject: [PATCH] board: ls1046ardb: force PCI device enumeration
+
+Commit 045ecf899252 ("configs: enable DM_ETH support for LS1046ARDB")
+resulted in the PCI bus no longer being implicitly enumerated.
+
+However, this is necessary for the fdt pcie fixups to work.
+
+Therefore, similar to commit 8b6558bd4187 ("board: ls1088ardb:
+transition to DM_ETH"), pci_init() is now called in the board_init()
+routine when CONFIG_DM_ETH is active.
+
+Signed-off-by: Martin Schiller <ms@dev.tdt.de>
+CC: Priyanka Jain <priyanka.jain@nxp.com>
+---
+ board/freescale/ls1046ardb/ls1046ardb.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- a/board/freescale/ls1046ardb/ls1046ardb.c
++++ b/board/freescale/ls1046ardb/ls1046ardb.c
+@@ -88,6 +88,10 @@ int board_init(void)
+       ppa_init();
+ #endif
++#if !defined(CONFIG_SYS_EARLY_PCI_INIT) && defined(CONFIG_DM_ETH)
++      pci_init();
++#endif
++
+       /* invert AQR105 IRQ pins polarity */
+       out_be32(&scfg->intpcr, AQR105_IRQ_MASK);
diff --git a/package/boot/uboot-layerscape/patches/0002-board-ls1043ardb-force-PCI-device-enumeration.patch b/package/boot/uboot-layerscape/patches/0002-board-ls1043ardb-force-PCI-device-enumeration.patch
new file mode 100644 (file)
index 0000000..d38102a
--- /dev/null
@@ -0,0 +1,34 @@
+From 64d2dffa8b51c1beb7e472690dcac965ac0f7ac4 Mon Sep 17 00:00:00 2001
+From: Martin Schiller <ms@dev.tdt.de>
+Date: Tue, 23 Nov 2021 07:24:19 +0100
+Subject: [PATCH] board: ls1043ardb: force PCI device enumeration
+
+Commit eb1986804d1d ("configs: enable DM_ETH support for LS1043ARDB")
+resulted in the PCI bus no longer being implicitly enumerated.
+
+However, this is necessary for the fdt pcie fixups to work.
+
+Therefore, similar to commit 8b6558bd4187 ("board: ls1088ardb:
+transition to DM_ETH"), pci_init() is now called in the board_init()
+routine when CONFIG_DM_ETH is active.
+
+Signed-off-by: Martin Schiller <ms@dev.tdt.de>
+CC: Priyanka Jain <priyanka.jain@nxp.com>
+CC: Camelia Groza <camelia.groza@nxp.com>
+---
+ board/freescale/ls1043ardb/ls1043ardb.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+--- a/board/freescale/ls1043ardb/ls1043ardb.c
++++ b/board/freescale/ls1043ardb/ls1043ardb.c
+@@ -214,6 +214,10 @@ int board_init(void)
+       ppa_init();
+ #endif
++#if !defined(CONFIG_SYS_EARLY_PCI_INIT) && defined(CONFIG_DM_ETH)
++      pci_init();
++#endif
++
+ #ifdef CONFIG_U_QE
+       u_qe_init();
+ #endif
diff --git a/package/boot/uboot-layerscape/patches/010-fix_dtc_compilation_on_host_gcc10.patch b/package/boot/uboot-layerscape/patches/010-fix_dtc_compilation_on_host_gcc10.patch
deleted file mode 100644 (file)
index 6abb151..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-From e33a814e772cdc36436c8c188d8c42d019fda639 Mon Sep 17 00:00:00 2001
-From: Dirk Mueller <dmueller@suse.com>
-Date: Tue, 14 Jan 2020 18:53:41 +0100
-Subject: [PATCH] scripts/dtc: Remove redundant YYLOC global declaration
-
-gcc 10 will default to -fno-common, which causes this error at link
-time:
-
-  (.text+0x0): multiple definition of `yylloc'; dtc-lexer.lex.o (symbol from plugin):(.text+0x0): first defined here
-
-This is because both dtc-lexer as well as dtc-parser define the same
-global symbol yyloc. Before with -fcommon those were merged into one
-defintion. The proper solution would be to to mark this as "extern",
-however that leads to:
-
-  dtc-lexer.l:26:16: error: redundant redeclaration of 'yylloc' [-Werror=redundant-decls]
-   26 | extern YYLTYPE yylloc;
-      |                ^~~~~~
-In file included from dtc-lexer.l:24:
-dtc-parser.tab.h:127:16: note: previous declaration of 'yylloc' was here
-  127 | extern YYLTYPE yylloc;
-      |                ^~~~~~
-cc1: all warnings being treated as errors
-
-which means the declaration is completely redundant and can just be
-dropped.
-
-Signed-off-by: Dirk Mueller <dmueller@suse.com>
-Signed-off-by: David Gibson <david@gibson.dropbear.id.au>
-[robh: cherry-pick from upstream]
-Cc: stable@vger.kernel.org
-Signed-off-by: Rob Herring <robh@kernel.org>
----
- scripts/dtc/dtc-lexer.l | 1 -
- 1 file changed, 1 deletion(-)
-
---- a/scripts/dtc/dtc-lexer.l
-+++ b/scripts/dtc/dtc-lexer.l
-@@ -38,7 +38,6 @@ LINECOMMENT  "//".*\n
- #include "srcpos.h"
- #include "dtc-parser.tab.h"
--YYLTYPE yylloc;
- extern bool treesource_error;
- /* CAUTION: this will stop working if we ever use yyless() or yyunput() */