hostapd: remove unused legacy wireless extension support
authorFelix Fietkau <nbd@nbd.name>
Fri, 26 May 2023 11:32:47 +0000 (13:32 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 26 May 2023 11:33:45 +0000 (13:33 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/network/services/hostapd/Config.in
package/network/services/hostapd/Makefile
package/network/services/hostapd/files/wpa_supplicant-basic.config
package/network/services/hostapd/files/wpa_supplicant-full.config
package/network/services/hostapd/files/wpa_supplicant-mini.config
package/network/services/hostapd/files/wpa_supplicant-p2p.config
package/network/services/hostapd/patches/432-missing-typedef.patch [deleted file]

index 8f28eb2bd4f4ce41e7c96a92bd2b3e8b588bd229..87ad7e093e7da0629e044721f29e43cc4c76b780 100644 (file)
@@ -73,11 +73,6 @@ config WPA_WOLFSSL
        select WOLFSSL_HAS_SESSION_TICKET
        select WOLFSSL_HAS_WPAS
 
-config DRIVER_WEXT_SUPPORT
-       bool
-       select KERNEL_WIRELESS_EXT
-       default n
-
 config DRIVER_11AC_SUPPORT
        bool
        default n
index b8921e84527a237a34a01becdb735c4754a2f294..dc2967048981246bd04d358d84ec2a857a86cdc6 100644 (file)
@@ -27,7 +27,6 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_hostapd-basic \
        CONFIG_PACKAGE_hostapd-mini \
        CONFIG_WPA_RFKILL_SUPPORT \
-       CONFIG_DRIVER_WEXT_SUPPORT \
        CONFIG_DRIVER_11AC_SUPPORT \
        CONFIG_DRIVER_11AX_SUPPORT \
        CONFIG_WPA_ENABLE_WEP
@@ -87,7 +86,6 @@ DRIVER_MAKEOPTS= \
        CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-cfg80211) \
        CONFIG_IEEE80211AC=$(HOSTAPD_IEEE80211AC) \
        CONFIG_IEEE80211AX=$(HOSTAPD_IEEE80211AX) \
-       CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
        CONFIG_MBO=$(CONFIG_WPA_MBO_SUPPORT)
 
 ifeq ($(SSL_VARIANT),openssl)
index 6abd8e2331aa13c8f646065bcef1e8000c7e1c72..944b4d928760021a5e03c71a09330b47f51ab0af 100644 (file)
@@ -26,7 +26,7 @@
 # replacement for WEXT and its use allows wpa_supplicant to properly control
 # the driver to improve existing functionality like roaming and to support new
 # functionality.
-CONFIG_DRIVER_WEXT=y
+#CONFIG_DRIVER_WEXT=y
 
 # Driver interface for Linux drivers using the nl80211 kernel interface
 CONFIG_DRIVER_NL80211=y
index d24fbbb01f17238ca8a9b82e5f03945acf4b7bd4..b39dabca0696b5d45805a72030b93f08a11bf6aa 100644 (file)
@@ -26,7 +26,7 @@
 # replacement for WEXT and its use allows wpa_supplicant to properly control
 # the driver to improve existing functionality like roaming and to support new
 # functionality.
-CONFIG_DRIVER_WEXT=y
+#CONFIG_DRIVER_WEXT=y
 
 # Driver interface for Linux drivers using the nl80211 kernel interface
 CONFIG_DRIVER_NL80211=y
index 9eb1111e523e590b7433c8ea323c451700a2f9e5..2a3f8fb69de3379f3a81bd8fef2ccdeadd453e61 100644 (file)
@@ -26,7 +26,7 @@
 # replacement for WEXT and its use allows wpa_supplicant to properly control
 # the driver to improve existing functionality like roaming and to support new
 # functionality.
-CONFIG_DRIVER_WEXT=y
+#CONFIG_DRIVER_WEXT=y
 
 # Driver interface for Linux drivers using the nl80211 kernel interface
 CONFIG_DRIVER_NL80211=y
index 0dcc88e6486dff7fc1b96e32d7287ec46d1a9ffe..7f5140622cc15a77bf7a409ef1c46d61d7ead900 100644 (file)
@@ -26,7 +26,7 @@
 # replacement for WEXT and its use allows wpa_supplicant to properly control
 # the driver to improve existing functionality like roaming and to support new
 # functionality.
-CONFIG_DRIVER_WEXT=y
+#CONFIG_DRIVER_WEXT=y
 
 # Driver interface for Linux drivers using the nl80211 kernel interface
 CONFIG_DRIVER_NL80211=y
diff --git a/package/network/services/hostapd/patches/432-missing-typedef.patch b/package/network/services/hostapd/patches/432-missing-typedef.patch
deleted file mode 100644 (file)
index 7a100f1..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/drivers/linux_wext.h
-+++ b/src/drivers/linux_wext.h
-@@ -26,6 +26,7 @@ typedef int32_t __s32;
- typedef uint16_t __u16;
- typedef int16_t __s16;
- typedef uint8_t __u8;
-+typedef int8_t __s8;
- #ifndef __user
- #define __user
- #endif /* __user */