sunxi: add support for FriendlyARM Nano PI NEO Air dev board
authorRoman Bazalevsky <rvb@rvb.name>
Thu, 5 Dec 2019 14:21:28 +0000 (17:21 +0300)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 13 Dec 2019 11:20:09 +0000 (12:20 +0100)
Hardware:

  Allwinner H3 upto 1.2GHz
  512MB DDR3 RAM
  8GB on-board eMMC - mountable, can be used as boot with custom boot.scr
  microSD-card slot
  WiFi 802.11n (AP6212A) - working
  Bluetooth (AP6212A) - not working for now
  Micro-USB OTG + 2*USB headers
  UART 3.3V - working
  GPIO/I2C/SPI 2.54mm headers

Standard sunxi SD-card installation procedure - copy image to SD card,
insert in into slot and boot. First time you will need UART adapter to
enable on-board wireless (or just build custom image with enabled WiFi).

To boot from eMMC:

  - boot from SD
  - copy SD image to emmc (dd bs=... if=.... of=/dev/mmcblk2)
  - mount eMMC boot partition and replace boot script on it
  - unmount, reboot

To use i2c, spi and more uarts - replace dtb on boot partition with
fixed one (use dtc or fdt-tools).

Signed-off-by: Roman Bazalevsky <rvb@rvb.name>
[rebase onto device name consolidation patches]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/image/cortex-a7.mk

index ce39fe792d5c2eccea67f53d6dcf95fb71bbc306..eef4c56f532124e7add87b86e17f4cde1aba9628 100644 (file)
@@ -138,6 +138,12 @@ define U-Boot/nanopi_m1_plus
   BUILD_DEVICES:=friendlyarm_nanopi-m1-plus
 endef
 
+define U-Boot/nanopi_neo_air
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=U-Boot for NanoPi NEO Air (H3)
+  BUILD_DEVICES:=friendlyarm_nanopi-neo-air
+endef
+
 define U-Boot/nanopi_neo
   BUILD_SUBTARGET:=cortexa7
   NAME:=U-Boot for NanoPi NEO (H3)
@@ -274,6 +280,7 @@ UBOOT_TARGETS := \
        Lamobo_R1 \
        nanopi_m1_plus \
        nanopi_neo \
+       nanopi_neo_air \
        nanopi_neo_plus2 \
        nanopi_neo2 \
        orangepi_zero \
index 90a355fd3ac58fb58b2f06353ce5ab28c2ebe090..83b313a3781c7a5b22a3dec9b995c4c2e3f5b28d 100644 (file)
@@ -160,6 +160,18 @@ endef
 TARGET_DEVICES += friendlyarm_nanopi-neo
 
 
+define Device/friendlyarm_nanopi-neo-air
+  DEVICE_VENDOR := FriendlyARM
+  DEVICE_MODEL := NanoPi NEO Air
+  DEVICE_PACKAGES := kmod-rtc-sunxi \
+        kmod-leds-gpio kmod-ledtrig-heartbeat \
+        kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
+  SUNXI_SOC := sun8i-h3
+endef
+
+TARGET_DEVICES += friendlyarm_nanopi-neo-air
+
+
 define Device/xunlong_orangepi-one
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi One