hostapd: Activate PIE by default
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Oct 2019 14:01:42 +0000 (15:01 +0100)
committerPetr Štetiar <ynezz@true.cz>
Mon, 13 Jan 2020 14:34:36 +0000 (15:34 +0100)
This activates PIE ASLR support by default when the regular option is
selected.

This increases the binary size by 26% uncompressed and 16% compressed
on MIPS BE.

old:
460,933 /usr/sbin/wpad
283,891 wpad-basic_2019-08-08-ca8c2bd2-1_mips_24kc.ipk

new:
584,508 /usr/sbin/wpad
330,281 wpad-basic_2019-08-08-ca8c2bd2-1_mips_24kc.ipk

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Acked-by: Petr Štetiar <ynezz@true.cz>
package/network/services/hostapd/Makefile

index 408c15390eebccbcf64b8218bbd2e3cc70160866..11d0d7a9ce9b2c2349b30c4c74c9cf3ea3f1d84e 100644 (file)
@@ -20,6 +20,7 @@ PKG_LICENSE:=BSD-3-Clause
 PKG_CPE_ID:=cpe:/a:w1.fi:hostapd
 
 PKG_BUILD_PARALLEL:=1
+PKG_ASLR_PIE_REGULAR:=1
 
 PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_kmod-ath9k \