ramips: use full names for Xiaomi Mi Router devices
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 8 Dec 2020 14:05:47 +0000 (15:05 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 8 Dec 2020 16:18:57 +0000 (17:18 +0100)
This aligns the device/image names of the older Xiaomi Mi Router
devices with their "friendly" model and DEVICE_MODEL properties.

This also reintroduces consistency with the newer devices already
following that scheme.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
13 files changed:
target/linux/ramips/dts/mt7621_xiaomi_mi-router-3-pro.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_xiaomi_mi-router-3g-v2.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_xiaomi_mi-router-3g.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_xiaomi_mir3g-v2.dts [deleted file]
target/linux/ramips/dts/mt7621_xiaomi_mir3g.dts [deleted file]
target/linux/ramips/dts/mt7621_xiaomi_mir3p.dts [deleted file]
target/linux/ramips/dts/mt7628an_xiaomi_mi-router-4a-100m.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7628an_xiaomi_mir4a-100m.dts [deleted file]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/image/mt76x8.mk
target/linux/ramips/mt7621/base-files/etc/board.d/02_network
target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
target/linux/ramips/mt76x8/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7621_xiaomi_mi-router-3-pro.dts b/target/linux/ramips/dts/mt7621_xiaomi_mi-router-3-pro.dts
new file mode 100644 (file)
index 0000000..b9101b7
--- /dev/null
@@ -0,0 +1,212 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "xiaomi,mi-router-3-pro", "mediatek,mt7621-soc";
+       model = "Xiaomi Mi Router 3 Pro";
+
+       aliases {
+               led-boot = &led_status_yellow;
+               led-failsafe = &led_status_red;
+               led-running = &led_status_blue;
+               led-upgrade = &led_status_yellow;
+               label-mac-device = &gmac0;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status_red: status_red {
+                       label = "red:status";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+               };
+
+               led_status_blue: status_blue {
+                       label = "blue:status";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               };
+
+               led_status_yellow: status_yellow {
+                       label = "yellow:status";
+                       gpios = <&gpio 10 GPIO_ACTIVE_LOW>;
+               };
+
+               wan_amber {
+                       label = "amber:wan";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "dsa-0.0:04:1Gbps";
+               };
+
+               lan3_amber {
+                       label = "amber:lan3";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "dsa-0.0:01:1Gbps";
+               };
+
+               lan2_amber {
+                       label = "amber:lan2";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "dsa-0.0:02:1Gbps";
+               };
+
+               lan1_amber {
+                       label = "amber:lan1";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "dsa-0.0:03:1Gbps";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       reg_usb_vbus: regulator {
+               compatible = "regulator-fixed";
+               regulator-name = "usb_vbus";
+               regulator-min-microvolt = <5000000>;
+               regulator-max-microvolt = <5000000>;
+               gpio = <&gpio 12 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+       };
+};
+
+&xhci {
+       vbus-supply = <&reg_usb_vbus>;
+};
+
+&nand {
+       status = "okay";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "Bootloader";
+                       reg = <0x0 0x40000>;
+                       read-only;
+               };
+
+               partition@40000 {
+                       label = "Config";
+                       reg = <0x40000 0x40000>;
+               };
+
+               partition@80000 {
+                       label = "Bdata";
+                       reg = <0x80000 0x40000>;
+                       read-only;
+               };
+
+               factory: partition@c0000 {
+                       label = "factory";
+                       reg = <0x0c0000 0x40000>;
+                       read-only;
+               };
+
+               partition@100000 {
+                       label = "crash";
+                       reg = <0x100000 0x40000>;
+               };
+
+               partition@140000 {
+                       label = "crash_syslog";
+                       reg = <0x140000 0x80000>;
+               };
+
+               partition@1c0000 {
+                       label = "reserved0";
+                       reg = <0x1c0000 0x40000>;
+                       read-only;
+               };
+
+               /* We keep stock xiaomi firmware (kernel0) here */
+               partition@200000 {
+                       label = "kernel_stock";
+                       reg = <0x200000 0x400000>;
+               };
+
+               partition@600000 {
+                       label = "kernel";
+                       reg = <0x600000 0x400000>;
+               };
+
+               partition@a00000 {
+                       label = "ubi";
+                       reg = <0xa00000 0xf580000>;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+               ieee80211-freq-limit = <2400000 2500000>;
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&gmac0 {
+       mtd-mac-address = <&factory 0xe006>;
+};
+
+&switch0 {
+       ports {
+               port@1 {
+                       status = "okay";
+                       label = "lan3";
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan2";
+               };
+
+               port@3 {
+                       status = "okay";
+                       label = "lan1";
+               };
+
+               port@4 {
+                       status = "okay";
+                       label = "wan";
+                       mtd-mac-address = <&factory 0xe000>;
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "jtag", "uart2", "uart3", "wdt";
+               function = "gpio";
+       };
+};
diff --git a/target/linux/ramips/dts/mt7621_xiaomi_mi-router-3g-v2.dts b/target/linux/ramips/dts/mt7621_xiaomi_mi-router-3g-v2.dts
new file mode 100644 (file)
index 0000000..fe03ff1
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_xiaomi_mi-router-4a-3g-v2.dtsi"
+
+/ {
+       compatible = "xiaomi,mi-router-3g-v2", "mediatek,mt7621-soc";
+       model = "Xiaomi Mi Router 3G v2";
+};
diff --git a/target/linux/ramips/dts/mt7621_xiaomi_mi-router-3g.dts b/target/linux/ramips/dts/mt7621_xiaomi_mi-router-3g.dts
new file mode 100644 (file)
index 0000000..479cfc3
--- /dev/null
@@ -0,0 +1,220 @@
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "xiaomi,mi-router-3g", "mediatek,mt7621-soc";
+       model = "Xiaomi Mi Router 3G";
+
+       aliases {
+               led-boot = &led_status_yellow;
+               led-failsafe = &led_status_red;
+               led-running = &led_status_blue;
+               led-upgrade = &led_status_yellow;
+               label-mac-device = &gmac0;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status_red: status_red {
+                       label = "red:status";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+               };
+
+               led_status_blue: status_blue {
+                       label = "blue:status";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               };
+
+               led_status_yellow: status_yellow {
+                       label = "yellow:status";
+                       gpios = <&gpio 10 GPIO_ACTIVE_LOW>;
+               };
+
+               wan_amber {
+                       label = "amber:wan";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "dsa-0.0:01:1Gbps";
+               };
+
+               lan1_amber {
+                       label = "amber:lan1";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "dsa-0.0:03:1Gbps";
+               };
+
+               lan2_amber {
+                       label = "amber:lan2";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "dsa-0.0:02:1Gbps";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       reg_usb_vbus: regulator {
+               compatible = "regulator-fixed";
+               regulator-name = "usb_vbus";
+               regulator-min-microvolt = <5000000>;
+               regulator-max-microvolt = <5000000>;
+               gpio = <&gpio 12 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+       };
+};
+
+&xhci {
+       vbus-supply = <&reg_usb_vbus>;
+};
+
+&nand {
+       status = "okay";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "Bootloader";
+                       reg = <0x0 0x80000>;
+                       read-only;
+               };
+
+               partition@80000 {
+                       label = "Config";
+                       reg = <0x80000 0x40000>;
+               };
+
+               partition@c0000 {
+                       label = "Bdata";
+                       reg = <0xc0000 0x40000>;
+                       read-only;
+               };
+
+               factory: partition@100000 {
+                       label = "factory";
+                       reg = <0x100000 0x40000>;
+                       read-only;
+               };
+
+               partition@140000 {
+                       label = "crash";
+                       reg = <0x140000 0x40000>;
+               };
+
+               partition@180000 {
+                       label = "crash_syslog";
+                       reg = <0x180000 0x40000>;
+               };
+
+               partition@1c0000 {
+                       label = "reserved0";
+                       reg = <0x1c0000 0x40000>;
+                       read-only;
+               };
+
+               /* uboot expects to find kernels at 0x200000 & 0x600000
+                * referred to as system 1 & system 2 respectively.
+                * a kernel is considered suitable for handing control over
+                * if its linux magic number exists & uImage CRC are correct.
+                * If either of those conditions fail, a matching sys'n'_fail flag
+                * is set in uboot env & a restart performed in the hope that the
+                * alternate kernel is okay.
+                * if neither kernel checksums ok and both are marked failed, system 2
+                * is booted anyway.
+                *
+                * Note uboot's tftp flash install writes the transferred
+                * image to both kernel partitions.
+                */
+
+               partition@200000 {
+                       label = "kernel_stock";
+                       reg = <0x200000 0x400000>;
+               };
+
+               partition@600000 {
+                       label = "kernel";
+                       reg = <0x600000 0x400000>;
+               };
+
+               /* ubi partition is the result of squashing
+                * next consecutive stock partitions:
+                * - rootfs0 (rootfs partition for stock kernel0),
+                * - rootfs1 (rootfs partition for stock failsafe kernel1),
+                * - overlay (used as ubi overlay in stock fw)
+                * resulting 117,5MiB space for packages.
+                */
+
+               partition@a00000 {
+                       label = "ubi";
+                       reg = <0xa00000 0x7580000>;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "pci14c3,7603";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+               ieee80211-freq-limit = <2400000 2500000>;
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "pci14c3,7662";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&gmac0 {
+       mtd-mac-address = <&factory 0xe006>;
+};
+
+&switch0 {
+       ports {
+               port@1 {
+                       status = "okay";
+                       label = "wan";
+                       mtd-mac-address = <&factory 0xe000>;
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan2";
+               };
+
+               port@3 {
+                       status = "okay";
+                       label = "lan1";
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "jtag", "uart2", "uart3", "wdt";
+               function = "gpio";
+       };
+};
diff --git a/target/linux/ramips/dts/mt7621_xiaomi_mir3g-v2.dts b/target/linux/ramips/dts/mt7621_xiaomi_mir3g-v2.dts
deleted file mode 100644 (file)
index 50c5a7d..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "mt7621_xiaomi_mi-router-4a-3g-v2.dtsi"
-
-/ {
-       compatible = "xiaomi,mir3g-v2", "mediatek,mt7621-soc";
-       model = "Xiaomi Mi Router 3G v2";
-};
diff --git a/target/linux/ramips/dts/mt7621_xiaomi_mir3g.dts b/target/linux/ramips/dts/mt7621_xiaomi_mir3g.dts
deleted file mode 100644 (file)
index 51f4842..0000000
+++ /dev/null
@@ -1,220 +0,0 @@
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       compatible = "xiaomi,mir3g", "mediatek,mt7621-soc";
-       model = "Xiaomi Mi Router 3G";
-
-       aliases {
-               led-boot = &led_status_yellow;
-               led-failsafe = &led_status_red;
-               led-running = &led_status_blue;
-               led-upgrade = &led_status_yellow;
-               label-mac-device = &gmac0;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,115200n8";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_status_red: status_red {
-                       label = "red:status";
-                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
-               };
-
-               led_status_blue: status_blue {
-                       label = "blue:status";
-                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
-               };
-
-               led_status_yellow: status_yellow {
-                       label = "yellow:status";
-                       gpios = <&gpio 10 GPIO_ACTIVE_LOW>;
-               };
-
-               wan_amber {
-                       label = "amber:wan";
-                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
-                       linux,default-trigger = "dsa-0.0:01:1Gbps";
-               };
-
-               lan1_amber {
-                       label = "amber:lan1";
-                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
-                       linux,default-trigger = "dsa-0.0:03:1Gbps";
-               };
-
-               lan2_amber {
-                       label = "amber:lan2";
-                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
-                       linux,default-trigger = "dsa-0.0:02:1Gbps";
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-
-       reg_usb_vbus: regulator {
-               compatible = "regulator-fixed";
-               regulator-name = "usb_vbus";
-               regulator-min-microvolt = <5000000>;
-               regulator-max-microvolt = <5000000>;
-               gpio = <&gpio 12 GPIO_ACTIVE_HIGH>;
-               enable-active-high;
-       };
-};
-
-&xhci {
-       vbus-supply = <&reg_usb_vbus>;
-};
-
-&nand {
-       status = "okay";
-
-       partitions {
-               compatible = "fixed-partitions";
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partition@0 {
-                       label = "Bootloader";
-                       reg = <0x0 0x80000>;
-                       read-only;
-               };
-
-               partition@80000 {
-                       label = "Config";
-                       reg = <0x80000 0x40000>;
-               };
-
-               partition@c0000 {
-                       label = "Bdata";
-                       reg = <0xc0000 0x40000>;
-                       read-only;
-               };
-
-               factory: partition@100000 {
-                       label = "factory";
-                       reg = <0x100000 0x40000>;
-                       read-only;
-               };
-
-               partition@140000 {
-                       label = "crash";
-                       reg = <0x140000 0x40000>;
-               };
-
-               partition@180000 {
-                       label = "crash_syslog";
-                       reg = <0x180000 0x40000>;
-               };
-
-               partition@1c0000 {
-                       label = "reserved0";
-                       reg = <0x1c0000 0x40000>;
-                       read-only;
-               };
-
-               /* uboot expects to find kernels at 0x200000 & 0x600000
-                * referred to as system 1 & system 2 respectively.
-                * a kernel is considered suitable for handing control over
-                * if its linux magic number exists & uImage CRC are correct.
-                * If either of those conditions fail, a matching sys'n'_fail flag
-                * is set in uboot env & a restart performed in the hope that the
-                * alternate kernel is okay.
-                * if neither kernel checksums ok and both are marked failed, system 2
-                * is booted anyway.
-                *
-                * Note uboot's tftp flash install writes the transferred
-                * image to both kernel partitions.
-                */
-
-               partition@200000 {
-                       label = "kernel_stock";
-                       reg = <0x200000 0x400000>;
-               };
-
-               partition@600000 {
-                       label = "kernel";
-                       reg = <0x600000 0x400000>;
-               };
-
-               /* ubi partition is the result of squashing
-                * next consecutive stock partitions:
-                * - rootfs0 (rootfs partition for stock kernel0),
-                * - rootfs1 (rootfs partition for stock failsafe kernel1),
-                * - overlay (used as ubi overlay in stock fw)
-                * resulting 117,5MiB space for packages.
-                */
-
-               partition@a00000 {
-                       label = "ubi";
-                       reg = <0xa00000 0x7580000>;
-               };
-       };
-};
-
-&pcie {
-       status = "okay";
-};
-
-&pcie0 {
-       wifi@0,0 {
-               compatible = "pci14c3,7603";
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x0000>;
-               ieee80211-freq-limit = <2400000 2500000>;
-       };
-};
-
-&pcie1 {
-       wifi@0,0 {
-               compatible = "pci14c3,7662";
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x8000>;
-               ieee80211-freq-limit = <5000000 6000000>;
-       };
-};
-
-&gmac0 {
-       mtd-mac-address = <&factory 0xe006>;
-};
-
-&switch0 {
-       ports {
-               port@1 {
-                       status = "okay";
-                       label = "wan";
-                       mtd-mac-address = <&factory 0xe000>;
-               };
-
-               port@2 {
-                       status = "okay";
-                       label = "lan2";
-               };
-
-               port@3 {
-                       status = "okay";
-                       label = "lan1";
-               };
-       };
-};
-
-&state_default {
-       gpio {
-               groups = "jtag", "uart2", "uart3", "wdt";
-               function = "gpio";
-       };
-};
diff --git a/target/linux/ramips/dts/mt7621_xiaomi_mir3p.dts b/target/linux/ramips/dts/mt7621_xiaomi_mir3p.dts
deleted file mode 100644 (file)
index 43e61e9..0000000
+++ /dev/null
@@ -1,212 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       compatible = "xiaomi,mir3p", "mediatek,mt7621-soc";
-       model = "Xiaomi Mi Router 3 Pro";
-
-       aliases {
-               led-boot = &led_status_yellow;
-               led-failsafe = &led_status_red;
-               led-running = &led_status_blue;
-               led-upgrade = &led_status_yellow;
-               label-mac-device = &gmac0;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,115200n8";
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_status_red: status_red {
-                       label = "red:status";
-                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
-               };
-
-               led_status_blue: status_blue {
-                       label = "blue:status";
-                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
-               };
-
-               led_status_yellow: status_yellow {
-                       label = "yellow:status";
-                       gpios = <&gpio 10 GPIO_ACTIVE_LOW>;
-               };
-
-               wan_amber {
-                       label = "amber:wan";
-                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
-                       linux,default-trigger = "dsa-0.0:04:1Gbps";
-               };
-
-               lan3_amber {
-                       label = "amber:lan3";
-                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
-                       linux,default-trigger = "dsa-0.0:01:1Gbps";
-               };
-
-               lan2_amber {
-                       label = "amber:lan2";
-                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
-                       linux,default-trigger = "dsa-0.0:02:1Gbps";
-               };
-
-               lan1_amber {
-                       label = "amber:lan1";
-                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
-                       linux,default-trigger = "dsa-0.0:03:1Gbps";
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-
-       reg_usb_vbus: regulator {
-               compatible = "regulator-fixed";
-               regulator-name = "usb_vbus";
-               regulator-min-microvolt = <5000000>;
-               regulator-max-microvolt = <5000000>;
-               gpio = <&gpio 12 GPIO_ACTIVE_HIGH>;
-               enable-active-high;
-       };
-};
-
-&xhci {
-       vbus-supply = <&reg_usb_vbus>;
-};
-
-&nand {
-       status = "okay";
-
-       partitions {
-               compatible = "fixed-partitions";
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partition@0 {
-                       label = "Bootloader";
-                       reg = <0x0 0x40000>;
-                       read-only;
-               };
-
-               partition@40000 {
-                       label = "Config";
-                       reg = <0x40000 0x40000>;
-               };
-
-               partition@80000 {
-                       label = "Bdata";
-                       reg = <0x80000 0x40000>;
-                       read-only;
-               };
-
-               factory: partition@c0000 {
-                       label = "factory";
-                       reg = <0x0c0000 0x40000>;
-                       read-only;
-               };
-
-               partition@100000 {
-                       label = "crash";
-                       reg = <0x100000 0x40000>;
-               };
-
-               partition@140000 {
-                       label = "crash_syslog";
-                       reg = <0x140000 0x80000>;
-               };
-
-               partition@1c0000 {
-                       label = "reserved0";
-                       reg = <0x1c0000 0x40000>;
-                       read-only;
-               };
-
-               /* We keep stock xiaomi firmware (kernel0) here */
-               partition@200000 {
-                       label = "kernel_stock";
-                       reg = <0x200000 0x400000>;
-               };
-
-               partition@600000 {
-                       label = "kernel";
-                       reg = <0x600000 0x400000>;
-               };
-
-               partition@a00000 {
-                       label = "ubi";
-                       reg = <0xa00000 0xf580000>;
-               };
-       };
-};
-
-&pcie {
-       status = "okay";
-};
-
-&pcie0 {
-       wifi@0,0 {
-               compatible = "mediatek,mt76";
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x0000>;
-               ieee80211-freq-limit = <2400000 2500000>;
-       };
-};
-
-&pcie1 {
-       wifi@0,0 {
-               compatible = "mediatek,mt76";
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x8000>;
-               ieee80211-freq-limit = <5000000 6000000>;
-       };
-};
-
-&gmac0 {
-       mtd-mac-address = <&factory 0xe006>;
-};
-
-&switch0 {
-       ports {
-               port@1 {
-                       status = "okay";
-                       label = "lan3";
-               };
-
-               port@2 {
-                       status = "okay";
-                       label = "lan2";
-               };
-
-               port@3 {
-                       status = "okay";
-                       label = "lan1";
-               };
-
-               port@4 {
-                       status = "okay";
-                       label = "wan";
-                       mtd-mac-address = <&factory 0xe000>;
-               };
-       };
-};
-
-&state_default {
-       gpio {
-               groups = "jtag", "uart2", "uart3", "wdt";
-               function = "gpio";
-       };
-};
diff --git a/target/linux/ramips/dts/mt7628an_xiaomi_mi-router-4a-100m.dts b/target/linux/ramips/dts/mt7628an_xiaomi_mi-router-4a-100m.dts
new file mode 100644 (file)
index 0000000..37797fc
--- /dev/null
@@ -0,0 +1,45 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an_xiaomi_mi-router-4.dtsi"
+
+/ {
+       compatible = "xiaomi,mi-router-4a-100m", "mediatek,mt7628an-soc";
+       model = "Xiaomi Mi Router 4A (100M Edition)";
+};
+
+&partitions {
+       partition@60000 {
+               label = "overlay";
+               reg = <0x60000 0x100000>;
+               read-only;
+       };
+
+       partition@160000 {
+               label = "firmware";
+               reg = <0x160000 0xea0000>;
+               compatible = "denx,uimage";
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x4>;
+       mtd-mac-address-increment = <(-1)>;
+};
+
+&esw {
+       mediatek,portmap = <0x3e>;
+       mediatek,portdisable = <0x2a>;
+};
diff --git a/target/linux/ramips/dts/mt7628an_xiaomi_mir4a-100m.dts b/target/linux/ramips/dts/mt7628an_xiaomi_mir4a-100m.dts
deleted file mode 100644 (file)
index a1a7dc7..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "mt7628an_xiaomi_mi-router-4.dtsi"
-
-/ {
-       compatible = "xiaomi,mir4a-100m", "mediatek,mt7628an-soc";
-       model = "Xiaomi Mi Router 4A (100M Edition)";
-};
-
-&partitions {
-       partition@60000 {
-               label = "overlay";
-               reg = <0x60000 0x100000>;
-               read-only;
-       };
-
-       partition@160000 {
-               label = "firmware";
-               reg = <0x160000 0xea0000>;
-               compatible = "denx,uimage";
-       };
-};
-
-&pcie {
-       status = "okay";
-};
-
-&pcie0 {
-       wifi@0,0 {
-               compatible = "mediatek,mt76";
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x8000>;
-               ieee80211-freq-limit = <5000000 6000000>;
-       };
-};
-
-&ethernet {
-       mtd-mac-address = <&factory 0x4>;
-       mtd-mac-address-increment = <(-1)>;
-};
-
-&esw {
-       mediatek,portmap = <0x3e>;
-       mediatek,portdisable = <0x2a>;
-};
index 7b8a73c1bd7b09c7dd0bfc277371a5e613fca6db..fad18552c9be193fe3c330736fc8deb44119aad8 100644 (file)
@@ -1191,13 +1191,7 @@ define Device/xiaomi-ac2100
        uboot-envtools
 endef
 
-define Device/xiaomi_mi-router-ac2100
-  $(Device/xiaomi-ac2100)
-  DEVICE_MODEL := Mi Router AC2100
-endef
-TARGET_DEVICES += xiaomi_mi-router-ac2100
-
-define Device/xiaomi_mir3g
+define Device/xiaomi_mi-router-3g
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)
   BLOCKSIZE := 128k
@@ -1211,14 +1205,13 @@ define Device/xiaomi_mir3g
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   DEVICE_VENDOR := Xiaomi
   DEVICE_MODEL := Mi Router 3G
-  SUPPORTED_DEVICES += R3G
-  SUPPORTED_DEVICES += mir3g
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 \
        kmod-usb-ledtrig-usbport uboot-envtools
+  SUPPORTED_DEVICES += R3G mir3g xiaomi,mir3g
 endef
-TARGET_DEVICES += xiaomi_mir3g
+TARGET_DEVICES += xiaomi_mi-router-3g
 
-define Device/xiaomi_mir3g-v2
+define Device/xiaomi_mi-router-3g-v2
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 14848k
@@ -1226,10 +1219,11 @@ define Device/xiaomi_mir3g-v2
   DEVICE_MODEL := Mi Router 3G
   DEVICE_VARIANT := v2
   DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2
+  SUPPORTED_DEVICES += xiaomi,mir3g-v2
 endef
-TARGET_DEVICES += xiaomi_mir3g-v2
+TARGET_DEVICES += xiaomi_mi-router-3g-v2
 
-define Device/xiaomi_mir3p
+define Device/xiaomi_mi-router-3-pro
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)
   BLOCKSIZE := 128k
@@ -1245,8 +1239,9 @@ define Device/xiaomi_mir3p
        check-size
   DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware kmod-usb3 \
        kmod-usb-ledtrig-usbport uboot-envtools
+  SUPPORTED_DEVICES += xiaomi,mir3p
 endef
-TARGET_DEVICES += xiaomi_mir3p
+TARGET_DEVICES += xiaomi_mi-router-3-pro
 
 define Device/xiaomi_mi-router-4a-gigabit
   $(Device/dsa-migration)
@@ -1259,6 +1254,12 @@ define Device/xiaomi_mi-router-4a-gigabit
 endef
 TARGET_DEVICES += xiaomi_mi-router-4a-gigabit
 
+define Device/xiaomi_mi-router-ac2100
+  $(Device/xiaomi-ac2100)
+  DEVICE_MODEL := Mi Router AC2100
+endef
+TARGET_DEVICES += xiaomi_mi-router-ac2100
+
 define Device/xiaomi_redmi-router-ac2100
   $(Device/xiaomi-ac2100)
   DEVICE_MODEL := Redmi Router AC2100
index edd42a4dd53d4608e6a08576a3f64847317a675d..00593dd6f50650694e8ed30b2795db1dbeffcc31 100644 (file)
@@ -743,14 +743,15 @@ define Device/wrtnode_wrtnode2r
 endef
 TARGET_DEVICES += wrtnode_wrtnode2r
 
-define Device/xiaomi_mir4a-100m
+define Device/xiaomi_mi-router-4a-100m
   IMAGE_SIZE := 14976k
   DEVICE_VENDOR := Xiaomi
   DEVICE_MODEL := Mi Router 4A
   DEVICE_VARIANT := 100M Edition
   DEVICE_PACKAGES := kmod-mt76x2
+  SUPPORTED_DEVICES += xiaomi,mir4a-100m
 endef
-TARGET_DEVICES += xiaomi_mir4a-100m
+TARGET_DEVICES += xiaomi_mi-router-4a-100m
 
 define Device/xiaomi_mi-router-4c
   IMAGE_SIZE := 14976k
index fccd9c6985174f4480c6e8eeb16f1a5d7e7c3424..c5b35145f106eaacf334dd44aa55975747dce783 100755 (executable)
@@ -16,8 +16,8 @@ ramips_setup_interfaces()
        asiarf,ap7621-nv1|\
        lenovo,newifi-d1|\
        mikrotik,routerboard-m33g|\
-       xiaomi,mir3g|\
-       xiaomi,mir3g-v2|\
+       xiaomi,mi-router-3g|\
+       xiaomi,mi-router-3g-v2|\
        xiaomi,mi-router-4a-gigabit)
                ucidef_set_interfaces_lan_wan "lan1 lan2" "wan"
                ;;
@@ -33,8 +33,8 @@ ramips_setup_interfaces()
                ;;
        gehua,ghl-r-001|\
        hiwifi,hc5962|\
+       xiaomi,mi-router-3-pro|\
        xiaomi,mi-router-ac2100|\
-       xiaomi,mir3p|\
        xiaomi,redmi-router-ac2100)
                ucidef_set_interfaces_lan_wan "lan1 lan2 lan3" "wan"
                ;;
index b4d07f8146c394c8d6e5d2c9778ff8b49691a6cd..c68b012d0b6320e9e3276c5677050813743e6908 100755 (executable)
@@ -61,9 +61,9 @@ platform_do_upgrade() {
        netgear,wac104|\
        netgear,wac124|\
        netis,wf2881|\
+       xiaomi,mi-router-3g|\
+       xiaomi,mi-router-3-pro|\
        xiaomi,mi-router-ac2100|\
-       xiaomi,mir3g|\
-       xiaomi,mir3p|\
        xiaomi,redmi-router-ac2100)
                nand_do_upgrade "$1"
                ;;
index 6f0078c70ac4540cacc96b59dc4936026b747df8..fcc2630b3fec00df06e301b92a7fc6b9561ccb4e 100755 (executable)
@@ -133,7 +133,7 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0:wan" "3:lan" "4:lan" "6@eth0"
                ;;
-       xiaomi,mir4a-100m)
+       xiaomi,mi-router-4a-100m)
                ucidef_add_switch "switch0" \
                        "4:lan:1" "2:lan:2" "0:wan" "6@eth0"
                ;;
@@ -238,8 +238,8 @@ ramips_setup_macs()
                label_mac=$(mtd_get_mac_binary factory 0x4)
                wan_mac=$(mtd_get_mac_binary factory 0x28)
                ;;
-       xiaomi,mi-router-4c|\
-       xiaomi,mir4a-100m)
+       xiaomi,mi-router-4a-100m|\
+       xiaomi,mi-router-4c)
                wan_mac=$(mtd_get_mac_binary factory 0x4)
                ;;
        esac