binutils: fix compilation with ccache
authorRosen Penev <rosenp@gmail.com>
Sat, 6 Mar 2021 22:17:45 +0000 (14:17 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 19 Mar 2021 00:25:26 +0000 (01:25 +0100)
For some reason, one of the configure checks results in some infinite
loop and ends up spawning endless gcc processes, causing OOM. Just pass
a configure var to avoid it.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
toolchain/binutils/Makefile

index da867944801410602991292737df1fcd11e8cd63..65d9925f9a57c2feca081e30b4836274679da54c 100644 (file)
@@ -63,6 +63,9 @@ ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
                --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
 endif
 
+HOST_CONFIGURE_VARS += \
+       acx_cv_cc_gcc_supports_ada=false
+
 define Host/Prepare
        $(call Host/Prepare/Default)
        ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)