iproute2: update to 6.7.0
authorNick Hainke <vincent@systemli.org>
Wed, 24 Jan 2024 12:45:27 +0000 (13:45 +0100)
committerNick Hainke <vincent@systemli.org>
Thu, 25 Jan 2024 15:08:25 +0000 (16:08 +0100)
Release Notes:
https://lwn.net/Articles/957171/

Remove patch "100-configure.patch" because support for ATM was dropped [0].

Manually refresh:
- 200-drop_libbsd_dependency.patch

Automatic refresh:
- 130-no_netem_tipc_dcb_man_vdpa.patch
- 140-keep_libmnl_optional.patch
- 145-keep_libelf_optional.patch
- 150-keep_libcap_optional.patch
- 155-keep_tirpc_optional.patch
- 190-fix-nls-rpath-link.patch
- 300-selinux-configurable.patch

[0] - https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=a66a73af6db74fdb64439316c69aa0e35dd02c47

Signed-off-by: Nick Hainke <vincent@systemli.org>
package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/100-configure.patch [deleted file]
package/network/utils/iproute2/patches/130-no_netem_tipc_dcb_man_vdpa.patch
package/network/utils/iproute2/patches/140-keep_libmnl_optional.patch
package/network/utils/iproute2/patches/145-keep_libelf_optional.patch
package/network/utils/iproute2/patches/150-keep_libcap_optional.patch
package/network/utils/iproute2/patches/155-keep_tirpc_optional.patch
package/network/utils/iproute2/patches/190-fix-nls-rpath-link.patch
package/network/utils/iproute2/patches/200-drop_libbsd_dependency.patch
package/network/utils/iproute2/patches/300-selinux-configurable.patch

index c21b78916bc8e6f11a09f6a22d1e278ea4543ebb..2f9d2f2bc98110f9ec831bdf15656f626f2b66b3 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=6.6.0
+PKG_VERSION:=6.7.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=8738c804afd09f0bf756937f0c3de23117832a98d8cbbf50386cf5005cd613ce
+PKG_HASH:=ff942dd9828d7d1f867f61fe72ce433078c31e5d8e4a78e20f02cb5892e8841d
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=iptables
 PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/iproute2/patches/100-configure.patch b/package/network/utils/iproute2/patches/100-configure.patch
deleted file mode 100644 (file)
index 2d4fb7b..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -36,7 +36,8 @@ int main(int argc, char **argv) {
- }
- EOF
--    if $CC -I$INCLUDE -o $TMPDIR/atmtest $TMPDIR/atmtest.c -latm >/dev/null 2>&1; then
-+# OpenWrt: disable ATM support even if present on host system
-+    if [ 1 -eq 0 ]; then
-       echo "TC_CONFIG_ATM:=y" >>$CONFIG
-       echo yes
-     else
index ba6ca4c9b24880ef40c48e8e470bc30ca37eb85f..8c70c14489199d50b54ba0cf6f059e350f7f9463 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -67,9 +67,9 @@ WFLAGS += -Wmissing-declarations -Wold-s
+@@ -68,9 +68,9 @@ WFLAGS += -Wmissing-declarations -Wold-s
  CFLAGS := $(WFLAGS) $(CCOPTS) -I../include -I../include/uapi $(DEFINES) $(CFLAGS)
  YACCFLAGS = -d -t -v
  
index a8cdd103ba308c2178488bb9e950224741a81741..0d228757517fa7fbfc3af7ccbf7904a220e28201 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -411,7 +411,7 @@ check_tirpc()
+@@ -391,7 +391,7 @@ check_tirpc()
  
  check_mnl()
  {
index 0c5c3f59ed9adc093be2da5001bf97f1a826fedd..bffacddb21738d67ac285ae0874f593478473e60 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -266,7 +266,7 @@ EOF
+@@ -246,7 +246,7 @@ EOF
  
  check_elf()
  {
index 4cce2c3ca6802d44b2f74532ee6f7a835431e13b..570e9c7038bc27000cf88f98e4da1a725d4079ed 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -469,7 +469,7 @@ EOF
+@@ -449,7 +449,7 @@ EOF
  
  check_cap()
  {
index 28ba7e52176d510f4b58350bf2697836f0280873..4d7fb76308683e04097949603ffb7167ff6785e1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -398,7 +398,7 @@ check_selinux()
+@@ -378,7 +378,7 @@ check_selinux()
  
  check_tirpc()
  {
index c7fceb2e221063243e12e1df0b28597e4b440e3d..765e4ad2e8726af2fccde801f2dcb4ec3e65954a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -290,7 +290,7 @@ int main(int argc, char **argv) {
+@@ -270,7 +270,7 @@ int main(int argc, char **argv) {
  }
  EOF
  
@@ -9,7 +9,7 @@
      local ret=$?
  
      rm -f $TMPDIR/libbpf_test.c $TMPDIR/libbpf_test
-@@ -308,7 +308,7 @@ int main(int argc, char **argv) {
+@@ -288,7 +288,7 @@ int main(int argc, char **argv) {
  }
  EOF
  
index d1948860e8665cbb2552f329e2da9e29c39b0ca5..92bf5cb66d875d6402ee2954aeeb17e4dac72f5c 100644 (file)
@@ -1,12 +1,12 @@
 --- a/configure
 +++ b/configure
-@@ -455,14 +455,8 @@ EOF
+@@ -435,14 +435,8 @@ EOF
      if $CC -I$INCLUDE -o $TMPDIR/strtest $TMPDIR/strtest.c >/dev/null 2>&1; then
        echo "no"
      else
 -      if ${PKG_CONFIG} libbsd --exists; then
--              echo 'CFLAGS += -DHAVE_LIBBSD' `${PKG_CONFIG} libbsd --cflags` >>$CONFIG
--              echo 'LDLIBS +=' `${PKG_CONFIG} libbsd --libs` >> $CONFIG
+-              echo 'CFLAGS += -DHAVE_LIBBSD' "$(${PKG_CONFIG} libbsd --cflags)" >>$CONFIG
+-              echo 'LDLIBS +=' "$(${PKG_CONFIG} libbsd --libs)" >> $CONFIG
 -              echo "no"
 -      else
 -              echo 'CFLAGS += -DNEED_STRLCPY' >>$CONFIG
index 817abf7d17ac0da772a79f322142d9d5bfdec1f9..a611ba75f0f18d6b3ce953d4ee2c1abd403e57d7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -385,7 +385,7 @@ check_libbpf()
+@@ -365,7 +365,7 @@ check_libbpf()
  check_selinux()
  # SELinux is a compile time option in the ss utility
  {