kernel: move KERNEL_BUILD_DIR under BUILD_DIR to properly fix gcc/libc based dependencies
authorFelix Fietkau <nbd@openwrt.org>
Sun, 2 Dec 2012 15:26:24 +0000 (15:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 2 Dec 2012 15:26:24 +0000 (15:26 +0000)
SVN-Revision: 34450

include/kernel.mk

index 4d3795ed5aaf60092a26cbd4f9b7d43deaf7c5b4..589db024db64ca2bf182c05d190c9f6f83d58691 100644 (file)
@@ -33,7 +33,7 @@ else
     PATCH_DIR ?= ./patches$(if $(wildcard ./patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
     FILES_DIR ?= $(foreach dir,$(wildcard ./files ./files-$(KERNEL_PATCHVER)),"$(dir)")
   endif
-  KERNEL_BUILD_DIR ?= $(BUILD_DIR_BASE)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))$(DIR_SUFFIX)$(if $(BUILD_SUFFIX),_$(BUILD_SUFFIX))
+  KERNEL_BUILD_DIR ?= $(BUILD_DIR)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))
   LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
 
   LINUX_VERMAGIC:=$(strip $(shell cat $(LINUX_DIR)/.vermagic 2>/dev/null))