ath79: enable factory.bin and adjust profile of ECB1750
authorMichael Pratt <mcpratt@pm.me>
Fri, 27 Nov 2020 00:11:15 +0000 (19:11 -0500)
committerPetr Štetiar <ynezz@true.cz>
Tue, 22 Dec 2020 18:11:50 +0000 (19:11 +0100)
factory.bin was not tested for ECB1750...
but it was tested on it's sister board ECB1200

The product ID for the header can be verified by inspecting
the header of OEM images, or in the u-boot environment.

Also:

  - the LAN LED is controlled directly by the AR8035 switch
  - the labelled (first increment) MAC for both is ethaddr (eth0)
  - list packages in alphabetical order
  - use default sysupgrade.bin recipe

Signed-off-by: Michael Pratt <mcpratt@pm.me>
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/image/generic.mk

index a0ed21e31868df0ed5f82b90fb91369d7b3d72f1..084281562f9850110a99e93213a6dcfc081aa9e7 100755 (executable)
@@ -151,7 +151,6 @@ telco,t1)
        ;;
 comfast,cf-wr752ac-v1|\
 engenius,eap300-v2|\
-engenius,ecb1750|\
 enterasys,ws-ap3705i)
        ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
        ;;
index b712154eb1f7542104797cbd8b34863d719c78b9..e42d8898476db32f1f6e31c908328689a32be6ae 100755 (executable)
@@ -504,7 +504,7 @@ ath79_setup_macs()
        engenius,ecb1200|\
        engenius,ecb1750)
                lan_mac=$(mtd_get_mac_ascii u-boot-env ethaddr)
-               label_mac=$(mtd_get_mac_ascii u-boot-env athaddr)
+               label_mac=$lan_mac
                ;;
        engenius,enh202-v1|\
        ubnt,airrouter|\
index 5d5e25b40150d9bdf7dafb464ed825b6d218749a..ebad4e72cd27811c30301fa4255547da3a4087d8 100644 (file)
@@ -40,7 +40,7 @@ case "$FIRMWARE" in
        engenius,ecb1200|\
        engenius,ecb1750)
                caldata_extract "art" 0x1000 0x440
-               ath9k_patch_mac $(macaddr_add $(mtd_get_mac_ascii u-boot-env "athaddr") +1)
+               ath9k_patch_mac $(macaddr_add $(mtd_get_mac_ascii u-boot-env athaddr) +1)
                ;;
        engenius,epg5000|\
        iodata,wn-ac1167dgr|\
index a7f1a76e114b8ba786addfb2ecf772f84a14ffc4..e44e780e8c2527a5e09d5cada46713098b9b1ef5 100644 (file)
@@ -959,13 +959,12 @@ define Device/engenius_ecb1750
   SOC := qca9558
   DEVICE_VENDOR := EnGenius
   DEVICE_MODEL := ECB1750
-  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct
   IMAGE_SIZE := 15680k
+  IMAGES += factory.bin
   IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
        append-rootfs | pad-rootfs | check-size | \
        senao-header -r 0x101 -p 0x6d -t 2
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
 endef
 TARGET_DEVICES += engenius_ecb1750