ath79: add support for OpenMesh OM2P-HS v3
authorSven Eckelmann <sven@narfation.org>
Mon, 23 Nov 2020 12:41:34 +0000 (13:41 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 28 Dec 2020 23:03:26 +0000 (00:03 +0100)
Device specifications:
======================

* Qualcomm/Atheros AR9341 rev 1
* 535/400/200 MHz (CPU/DDR/AHB)
* 64 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 2x 10/100 Mbps Ethernet
* 2T2R 2.4 GHz Wi-Fi
* 6x GPIO-LEDs (3x wifi, 2x ethernet, 1x power)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default)
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 2x fast ethernet
  - eth0
    + 802.3af POE
    + builtin switch port 1
    + used as LAN interface
  - eth1
    + 18-24V passive POE (mode B)
    + used as WAN interface
* 12-24V 1A DC
* internal antennas

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to
the device via

  scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <sven@narfation.org>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v3.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index 85a67c1ac3b5b7ac4d66396aaf700fa3af199bd0..7557984595788977de30284ef777a4fcd8788efc 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2020.04
-PKG_RELEASE:=13
+PKG_RELEASE:=14
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
index 212143f49b8d3f73216ce0b725e34250e0d60f16..2865501f26219026cdeb752a13f425bea60c7024 100644 (file)
@@ -88,6 +88,7 @@ netgear,wndr4300sw)
 openmesh,om2p-v4|\
 openmesh,om2p-hs-v1|\
 openmesh,om2p-hs-v2|\
+openmesh,om2p-hs-v3|\
 openmesh,om2p-hs-v4|\
 plasmacloud,pa300|\
 plasmacloud,pa300e)
diff --git a/target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v3.dts b/target/linux/ath79/dts/ar9341_openmesh_om2p-hs-v3.dts
new file mode 100644 (file)
index 0000000..e3b15b1
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9341_openmesh_om2p-hs.dtsi"
+
+/ {
+       compatible = "openmesh,om2p-hs-v3", "qca,ar9341";
+       model = "OpenMesh OM2P-HS v3";
+};
index 8926ffc0c8c1ecd871b240a84f9a0f120f506d53..3889969ee5108ceb5432c08b456b49dd84df9ab6 100755 (executable)
@@ -147,6 +147,7 @@ comfast,cf-e560ac)
 comfast,cf-ew72|\
 openmesh,om2p-hs-v1|\
 openmesh,om2p-hs-v2|\
+openmesh,om2p-hs-v3|\
 telco,t1)
        ucidef_set_led_switch "lan" "LAN" "blue:lan" "switch0" "0x02"
        ucidef_set_led_netdev "wan" "WAN" "blue:wan" "eth1"
index 73c328173a9a79ebdbaf0d68349784082fb33725..9ff36f1bf511b889ded5ecc428b69d8ceda5201d 100644 (file)
@@ -53,6 +53,7 @@ platform_do_upgrade() {
        openmesh,om2p-v4|\
        openmesh,om2p-hs-v1|\
        openmesh,om2p-hs-v2|\
+       openmesh,om2p-hs-v3|\
        openmesh,om2p-hs-v4)
                PART_NAME="inactive"
                platform_do_upgrade_openmesh "$1"
index 4e80ac840268738e9e95edae5c9de978020c078e..631cc2fd6a54b2366edf13ddb89866cc993cf00f 100644 (file)
@@ -1595,6 +1595,15 @@ define Device/openmesh_om2p-hs-v2
 endef
 TARGET_DEVICES += openmesh_om2p-hs-v2
 
+define Device/openmesh_om2p-hs-v3
+  $(Device/openmesh_om2p-common)
+  SOC := ar9341
+  DEVICE_MODEL := OM2P-HS
+  DEVICE_VARIANT := v3
+  SUPPORTED_DEVICES += om2p-hsv3
+endef
+TARGET_DEVICES += openmesh_om2p-hs-v3
+
 define Device/openmesh_om2p-hs-v4
   $(Device/openmesh_om2p-common)
   SOC := qca9533