toolchain: glibc: Fix build with autoconf 2.71
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 17 May 2023 22:31:21 +0000 (00:31 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 18 May 2023 16:55:27 +0000 (18:55 +0200)
The glibc build was failing with this error message:
  aclocal.m4:6: error: Exactly version 2.69 of Autoconf is required but you have 2.71
  aclocal.m4:6: the top level

The autoconf run on glibc is not needed, just remove it.

Fixes: #12631
Fixes: 030447b8f4c7 ("tools/autoconf: bump to 2.71")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
toolchain/glibc/common.mk

index 4fe5761f45ea5fffea9924e3b8611335e03c54b3..0d880e04df986344caefc020a9f6b6dd0da335b2 100644 (file)
@@ -79,11 +79,6 @@ define Host/SetToolchainInfo
 endef
 
 define Host/Configure
-       [ -f $(HOST_BUILD_DIR)/.autoconf ] || { \
-               cd $(HOST_BUILD_DIR)/; \
-               autoconf --force && \
-               touch $(HOST_BUILD_DIR)/.autoconf; \
-       }
        mkdir -p $(CUR_BUILD_DIR)
        ( cd $(CUR_BUILD_DIR); rm -f config.cache; \
                $(GLIBC_CONFIGURE) \