ramips: improve support for Xiaomi Miwifi Nano
authorChuanhong Guo <gch981213@gmail.com>
Tue, 3 Sep 2019 15:58:07 +0000 (23:58 +0800)
committerChuanhong Guo <gch981213@gmail.com>
Wed, 4 Sep 2019 11:26:01 +0000 (19:26 +0800)
This patch does the following things:
1. mark u-boot-env writable
2. add bootcount support
   Currently, u-boot has a flag_boot_success env variable to reset.
   Also reset it in our firmware to follow the behavior in vendor's
   firmware.
3. disable usb support
   This router doesn't have usb port at all.
4. increase spi clock to 40MHz
5. fix pinmux groups

Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ramips/base-files/etc/init.d/bootcount
target/linux/ramips/dts/mt7628an_xiaomi_miwifi-nano.dts
target/linux/ramips/image/mt76x8.mk

index 807801a34faf53ec16f81096bc8afd1ac1195547..ad3dd97402ea70667d3d40480ce73006241e1ee1 100755 (executable)
@@ -7,5 +7,8 @@ boot() {
        samknows,whitebox-v8)
                fw_setenv bootcount 0
                ;;
+       xiaomi,miwifi-nano)
+               fw_setenv flag_boot_success 1
+               ;;
        esac
 }
index 89a12edb7ebeac95912421db0d7bd044f5bd7242..347ce6489c42cf1aa95244820914c49114955791 100644 (file)
 &pinctrl {
        state_default: pinctrl0 {
                gpio {
-                       ralink,group = "refclk", "wled_an", "gpio";
+                       ralink,group = "gpio", "refclk", "wdt", "wled_an";
                        ralink,function = "gpio";
                };
        };
 };
 
+&ehci {
+       status = "disabled";
+};
+
+&ohci {
+       status = "disabled";
+};
+
 &wmac {
        status = "okay";
        ralink,mtd-eeprom = <&factory 0x4>;
@@ -73,7 +81,7 @@
        m25p80@0 {
                compatible = "jedec,spi-nor";
                reg = <0>;
-               spi-max-frequency = <10000000>;
+               spi-max-frequency = <40000000>;
 
                partitions {
                        compatible = "fixed-partitions";
@@ -89,7 +97,6 @@
                        partition@30000 {
                                label = "u-boot-env";
                                reg = <0x30000 0x10000>;
-                               read-only;
                        };
 
                        factory: partition@40000 {
index 45fed11b54b796aced7b4b091056522a7f5e1ade..a602d9df21036916128cfa5d6c86f66705e90ece 100644 (file)
@@ -560,7 +560,7 @@ define Device/xiaomi_miwifi-nano
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Xiaomi
   DEVICE_MODEL := MiWiFi Nano
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+  DEVICE_PACKAGES := uboot-envtools
   SUPPORTED_DEVICES += miwifi-nano
 endef
 TARGET_DEVICES += xiaomi_miwifi-nano