Fix uninstall-dev: remove gdlib-config too
authorNicolas Thill <nico@openwrt.org>
Tue, 24 May 2005 00:42:36 +0000 (00:42 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 24 May 2005 00:42:36 +0000 (00:42 +0000)
SVN-Revision: 1038

openwrt/package/libgd/Makefile

index 50ca47f801b7dadc6cacd503858bc902ef96c4cd..c180dd81510865869feb84e5f822cb7f9175d7df 100644 (file)
@@ -77,14 +77,16 @@ $(STAGING_DIR)/usr/lib/libgd.so: $(PKG_BUILD_DIR)/.built
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/gd*.h $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
        cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libgd.{a,so*} $(STAGING_DIR)/usr/lib/
+       touch $@
 
 install-dev: $(STAGING_DIR)/usr/lib/libgd.so
 
 uninstall-dev:
        rm -rf \
-         $(STAGING_DIR)/usr/include/entities.h \
-         $(STAGING_DIR)/usr/include/gd*.h \
-         $(STAGING_DIR)/usr/lib/libgd.{a,so*}
+               $(STAGING_DIR)/usr/bin/gdlib-config \
+               $(STAGING_DIR)/usr/include/entities.h \
+               $(STAGING_DIR)/usr/include/gd*.h \
+               $(STAGING_DIR)/usr/lib/libgd.{a,so*} \
 
 compile: install-dev
 clean: uninstall-dev