ath79: add support for TP-Link TL-WPA8630 v1
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 9 Jul 2020 10:49:17 +0000 (12:49 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 13 Aug 2020 18:43:15 +0000 (20:43 +0200)
This ports the TP-Link TL-WPA8630 v1 from ar71xx to ath79.

Specifications:

SoC: QCA9563
CPU: 750 MHz
Flash/RAM: 8 / 128 MiB
Ethernet: 3x 1G ports (QCA8337 switch)
WLAN: 2.4 GHz b/g/n, 5 GHz a/n/ac (ath10k)

Buttons, LEDs and network setup appear to be almost identical
to the v2 revision.

Powerline interface is connected to switch port 5 (Label LAN4).

Installation:

No "fresh" device was available for testing the factory image.

It is not known whether flashing via OEM firmware GUI is possible
or not. A discussion from 2018 [1] about that indicates a few
adjustments are necessary, but it is not clear whether those
are already implemented with the TPLINK_HEADER_VERSION = 2 or not.

Note that for the TL-WPA8630P v1, the TPLINK_HWID needs to be
changed to 0x86310001 to allow factory flashing.

[1] https://forum.openwrt.org/t/solved-tl-wpa8630p-lede-does-not-install/8161/27

Recovery:

Recovery is only possible via serial.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/dts/qca9563_tplink_tl-wpa8630-v1.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9563_tplink_tl-wpa8630.dtsi [new file with mode: 0644]
target/linux/ath79/dts/qca9563_tplink_tl-wpa8630p-v2.dtsi
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
target/linux/ath79/image/generic-tp-link.mk

diff --git a/target/linux/ath79/dts/qca9563_tplink_tl-wpa8630-v1.dts b/target/linux/ath79/dts/qca9563_tplink_tl-wpa8630-v1.dts
new file mode 100644 (file)
index 0000000..8912e2f
--- /dev/null
@@ -0,0 +1,56 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9563_tplink_tl-wpa8630.dtsi"
+
+/ {
+       compatible = "tplink,tl-wpa8630-v1", "qca,qca9563";
+       model = "TP-Link TL-WPA8630 v1";
+
+       aliases {
+               label-mac-device = &eth0;
+       };
+};
+
+&keys {
+       wifi {
+               label = "WiFi button";
+               linux,code = <KEY_RFKILL>;
+               gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               debounce-interval = <60>;
+       };
+};
+
+&partitions {
+       uboot: partition@0 {
+               label = "u-boot";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       partition@10000 {
+               compatible = "tplink,firmware";
+               label = "firmware";
+               reg = <0x010000 0x7d0000>;
+       };
+
+       partition@7e0000 {
+               label = "mib0";
+               reg = <0x7e0000 0x010000>;
+               read-only;
+       };
+
+       art: partition@7f0000 {
+               label = "art";
+               reg = <0x7f0000 0x010000>;
+               read-only;
+       };
+};
+
+&eth0 {
+       mtd-mac-address = <&uboot 0x0fc00>;
+};
+
+&wmac {
+       mtd-mac-address = <&uboot 0x0fc00>;
+};
diff --git a/target/linux/ath79/dts/qca9563_tplink_tl-wpa8630.dtsi b/target/linux/ath79/dts/qca9563_tplink_tl-wpa8630.dtsi
new file mode 100644 (file)
index 0000000..68b455c
--- /dev/null
@@ -0,0 +1,122 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+       aliases {
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+       };
+
+       keys: keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+
+               leds {
+                       label = "LED control button";
+                       linux,code = <BTN_0>;
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+
+               pair {
+                       label = "Pair button";
+                       linux,code = <BTN_1>;
+                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       label = "tp-link:green:power";
+                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+               };
+
+               lan {
+                       label = "tp-link:green:lan";
+                       gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi2g {
+                       label = "tp-link:green:wifi2g";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               wifi5g {
+                       label = "tp-link:green:wifi5g";
+                       gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions: partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&uart {
+       status = "okay";
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <0>;
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+               phy-mode = "sgmii";
+               qca,mib-poll-interval = <500>;
+
+               qca,ar8327-initvals = <
+                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+               >;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&phy0>;
+       phy-mode = "sgmii";
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+};
index 16c055b6d7f28cc825cc141ac962274699eb0676..97eeb45d6572570fc29e7a9be01dce951d7afded 100644 (file)
@@ -1,45 +1,12 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "qca956x.dtsi"
+#include "qca9563_tplink_tl-wpa8630.dtsi"
 
 / {
        aliases {
-               led-boot = &led_power;
-               led-failsafe = &led_power;
-               led-running = &led_power;
-               led-upgrade = &led_power;
                label-mac-device = &eth0;
        };
 
-       leds {
-               compatible = "gpio-leds";
-
-               led_power: power {
-                       label = "tp-link:green:power";
-                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
-               };
-
-               wifi2g {
-                       label = "tp-link:green:wifi2g";
-                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
-                       linux,default-trigger = "phy1tpt";
-               };
-
-               wifi5g {
-                       label = "tp-link:green:wifi5g";
-                       gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
-                       linux,default-trigger = "phy0tpt";
-               };
-
-               lan {
-                       label = "tp-link:green:lan";
-                       gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
-               };
-       };
-
        gpio-export {
                compatible = "gpio-export";
 
                        gpios = <&gpio 14 GPIO_ACTIVE_HIGH>;
                };
        };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "Reset button";
-                       linux,code = <KEY_RESTART>;
-                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
-                       debounce-interval = <60>;
-               };
-
-               pair {
-                       label = "Pair button";
-                       linux,code = <BTN_1>;
-                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
-                       debounce-interval = <60>;
-               };
-
-               leds {
-                       label = "LED control button";
-                       linux,code = <BTN_0>;
-                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
-                       debounce-interval = <60>;
-               };
-
-               wps {
-                       label = "WPS button";
-                       linux,code = <KEY_WPS_BUTTON>;
-                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
-                       debounce-interval = <60>;
-               };
-       };
 };
 
-&spi {
-       status = "okay";
-
-       num-cs = <1>;
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <25000000>;
-
-               partitions: partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "factory-uboot";
-                               reg = <0x000000 0x020000>;
-                               read-only;
-                       };
-
-                       partition@20000 {
-                               label = "u-boot";
-                               reg = <0x020000 0x020000>;
-                               read-only;
-                       };
-
-                       partition@40000 {
-                               compatible = "tplink,firmware";
-                               label = "firmware";
-                               reg = <0x040000 0x5e0000>;
-                       };
-
-                       partition@620000 {
-                               label = "partition-table";
-                               reg = <0x620000 0x010000>;
-                               read-only;
-                       };
-               };
+&keys {
+       wps {
+               label = "WPS button";
+               linux,code = <KEY_WPS_BUTTON>;
+               gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               debounce-interval = <60>;
        };
 };
 
-&pcie {
-       status = "okay";
-};
-
-&uart {
-       status = "okay";
-};
-
-&mdio0 {
-       status = "okay";
+&partitions {
+       partition@0 {
+               label = "factory-uboot";
+               reg = <0x000000 0x020000>;
+               read-only;
+       };
 
-       phy-mask = <0>;
+       partition@20000 {
+               label = "u-boot";
+               reg = <0x020000 0x020000>;
+               read-only;
+       };
 
-       phy0: ethernet-phy@0 {
-               reg = <0>;
-               phy-mode = "sgmii";
-               qca,mib-poll-interval = <500>;
+       partition@40000 {
+               compatible = "tplink,firmware";
+               label = "firmware";
+               reg = <0x040000 0x5e0000>;
+       };
 
-               qca,ar8327-initvals = <
-                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
-                       0x7c 0x0000007e /* PORT0_STATUS */
-               >;
+       partition@620000 {
+               label = "partition-table";
+               reg = <0x620000 0x010000>;
+               read-only;
        };
 };
 
 &eth0 {
-       status = "okay";
-
-       phy-handle = <&phy0>;
-       phy-mode = "sgmii";
        mtd-mac-address = <&mac 0x8>;
 };
 
 &wmac {
-       status = "okay";
-
-       mtd-cal-data = <&art 0x1000>;
        mtd-mac-address = <&mac 0x8>;
 };
index 4f1b76a65a2b77805b827fe16db81bb1905e68b0..32101ed5b0b1bd49c01aa4fb62188b468cd95f8b 100755 (executable)
@@ -297,6 +297,7 @@ tplink,tl-mr6400-v1)
        ucidef_set_led_netdev "wan" "WAN" "tp-link:white:wan" "eth1"
        ucidef_set_led_netdev "4g" "4G" "tp-link:white:4g" "usb0"
        ;;
+tplink,tl-wpa8630-v1|\
 tplink,tl-wpa8630p-v2-eu|\
 tplink,tl-wpa8630p-v2-int)
        ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x3c"
index 01b083ddad91298a39ee66d372fc46d34832681e..4195332ae21773dd035472ed106c4afae8a70de8 100755 (executable)
@@ -294,6 +294,7 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "1:lan:1" "2:lan:3" "3:lan:2"
                ;;
+       tplink,tl-wpa8630-v1|\
        tplink,tl-wpa8630p-v2-eu|\
        tplink,tl-wpa8630p-v2-int)
                # port 5 (internal) is the power-line port
index 37f1792fad6ea109db3432eaa92a839951014333..19e20c7d36073e6d643ad21df668e462e11d8b24 100644 (file)
@@ -129,6 +129,10 @@ case "$FIRMWARE" in
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(macaddr_add $(mtd_get_mac_binary info 0x8) +1)
                ;;
+       tplink,tl-wpa8630-v1)
+               caldata_extract "art" 0x5000 0x844
+               ath10k_patch_mac $(macaddr_add $(mtd_get_mac_binary u-boot 0x0fc00) +1)
+               ;;
        tplink,tl-wr902ac-v1)
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(macaddr_add $(mtd_get_mac_binary tplink 0x8) -1)
index 0f68209c9b0f008e738e3b5909a1af9e57b1b3d8..2dcdf7b0070e987a3e374ea844d4108c2caef5e1 100644 (file)
@@ -45,6 +45,10 @@ tplink,re355-v1)
 tplink,re450-v1)
        migrate_leds "re450:=tp-link:"
        ;;
+tplink,tl-wpa8630-v1)
+       migrate_leds "^tl-wpa8630:=tp-link:" \
+               ':wlan$=:wifi2g' ':wlan5$=:wifi5g'
+       ;;
 wd,mynet-n750)
        migrate_leds "wd:=mynet-n750:"
        ;;
index c2cda6b3df361d23000b2af1a86c89d0656981a9..fdc94b738a833a5bef281ae2e4021bf7164ea5c1 100644 (file)
@@ -500,6 +500,17 @@ define Device/tplink_tl-wdr4900-v2
 endef
 TARGET_DEVICES += tplink_tl-wdr4900-v2
 
+define Device/tplink_tl-wpa8630-v1
+  $(Device/tplink-8mlzma)
+  SOC := qca9563
+  DEVICE_MODEL := TL-WPA8630
+  DEVICE_VARIANT := v1
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  TPLINK_HWID := 0x86300001
+  SUPPORTED_DEVICES += tl-wpa8630
+endef
+TARGET_DEVICES += tplink_tl-wpa8630-v1
+
 define Device/tplink_tl-wpa8630p-v2
   $(Device/tplink-safeloader)
   SOC := qca9563