kernel: netfilter.mk: Explicitly set the order of autoloaded modules
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 2 May 2013 11:25:18 +0000 (11:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 2 May 2013 11:25:18 +0000 (11:25 +0000)
In my machine, the file is created with arptable_filter before
arp_tables. This can't happen because the former depends on the
latter.

So, instead of rely on wildcards (*.ko), set by hand the files to
be loaded in the correct order.

Signed-off-by: Jonh Wendell <jonh.wendell@oiwifi.com.br>
SVN-Revision: 36512

package/kernel/modules/netfilter.mk

index 50180a5f2cdc3ff1eb2f34c4c5c17aeea1094155..4e4c85f45c41a560fdf4e4cad4fac2c3048b8263 100644 (file)
@@ -402,7 +402,7 @@ endef
 
 $(eval $(call KernelPackage,ip6tables))
 
-
+ARP_MODULES = arp_tables arpt_mangle arptable_filter
 define KernelPackage/arptables
   SUBMENU:=$(NF_MENU)
   TITLE:=ARP firewalling modules
@@ -410,7 +410,7 @@ define KernelPackage/arptables
   KCONFIG:=CONFIG_IP_NF_ARPTABLES \
     CONFIG_IP_NF_ARPFILTER \
     CONFIG_IP_NF_ARP_MANGLE
-  AUTOLOAD:=$(call AutoLoad,49,$(notdir $(patsubst %.ko,%,$(wildcard $(LINUX_DIR)/net/ipv4/netfilter/arp*.ko))))
+  AUTOLOAD:=$(call AutoLoad,49,$(ARP_MODULES))
 endef
 
 define KernelPackage/arptables/description