bcm53xx: build a single device per profile
authorRani Hod <rani.hod@gmail.com>
Sat, 30 Sep 2023 19:22:13 +0000 (22:22 +0300)
committerRafał Miłecki <rafal@milecki.pl>
Fri, 13 Oct 2023 05:32:22 +0000 (07:32 +0200)
So far every build of a single bcm53xx Target Profile (it means: when
NOT using CONFIG_TARGET_MULTI_PROFILE) resulted in all target devices
images being built. Now it only builds the one matching selected
profile.

Fixes: #13572
Suggested-by: Jonas Gorski <jonas.gorski@gmail.com>
Signed-off-by: Rani Hod <rani.hod@gmail.com>
[rmilecki: update commit subject + body & move PROFILES line]
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/bcm53xx/image/Makefile

index 39b7efbef789f8428e5b58a07a3554ec953dbf9d..8799f5005799b8c0c804c5623bbb4c3cd3b319e1 100644 (file)
@@ -143,6 +143,7 @@ USB2_PACKAGES += kmod-usb-ledtrig-usbport
 USB3_PACKAGES := $(USB2_PACKAGES) kmod-usb3 kmod-phy-bcm-ns-usb3
 
 define Device/Default
+  PROFILES = Generic $$(DEVICE_NAME)
   # .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
   # extract the full dtb name based on the device info
   DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(subst _,-,$(1)).dtb)))