ipq40xx: add support for Pakedge WR-1
authorTomasz Maciej Nowak <tmn505@gmail.com>
Tue, 6 Sep 2022 13:32:33 +0000 (15:32 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 7 Sep 2022 19:21:38 +0000 (21:21 +0200)
Pakedge WR-1 is a dual-band wireless router.

Specification
SoC: Qualcomm Atheros IPQ4018
RAM: 256 MB DDR3
Flash: 32 MB SPI NOR
WIFI: 2.4 GHz 2T2R integrated
      5 GHz 2T2R integrated
Ethernet: 5x 10/100/1000 Mbps QCA8075
USB: 1x 2.0
LEDS: 8x (3 GPIO controlled, 5 connected to switch)
Buttons: 1x GPIO controlled
UART: pin header J5
      1. 3.3V, 2. GND, 3. TX, 4. RX
      baud: 115200, parity: none, flow control: none

Installation
1. Rename initramfs image to:
   openwrt-ipq806x-qcom-ipq40xx-ap.dk01.1-c1-fit-uImage-initramfs.itb
   and copy it to USB flash drive with FAT32 file system.
2. Connect USB flash drive to the router and apply power while pressing
   reset button. Hold the button, on the lates bootloader version, when
   Power and WiFi-5 LEDs will start blinking release it. For the older
   bootloader holding it for 15 seconds should suffice.
3. Now the router boots the initramfs image, at some point (close to one
   minute) the Power LED will start blinking, when stops, router is fully
   booted.
4. Connect to one of LAN ports and use SSH to open the shell at
   192.168.1.1.
5. ATTENTION! now backup the mtd8 and mtd9 partitions, it's necessary if,
   at some point, You want to go back to original firmware. The firmware
   provided by manufacturer on its site is encrypted and U-Boot accepts
   only decrypted factory images, so there's no way to restore original
   firmware.
6. If the backup is prepared, transfer the sysupgrade image to the router
   and use 'sysupgrade' command to flash it.
7. After successful flashing router will reboot. At some point the Power
   LED will start blinking, wait till it stops, then router is ready for
   configuration.

Additional information
U-Boot command line is password protected. Password is unknown.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
package/boot/uboot-envtools/files/ipq40xx
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts [new file with mode: 0644]
target/linux/ipq40xx/image/generic.mk

index 1937f9d1ce0c99cd76251c33f208928cfdc16bcd..e45e26dcc7f757b661ee036613277b80bd6f098e 100644 (file)
@@ -40,6 +40,7 @@ luma,wrtq-329acn|\
 netgear,wac510|\
 openmesh,a42|\
 openmesh,a62|\
+pakedge,wr-1|\
 plasmacloud,pa1200|\
 plasmacloud,pa2200)
        ubootenv_add_uci_config "/dev/mtd5" "0x0" "0x10000" "0x10000"
index a468c62b3c5c819e4f9164bad705502230dfc851..db58eb9363bfc0662abf79a6ae7b6db356f46b22 100644 (file)
@@ -138,6 +138,11 @@ ipq40xx_setup_interfaces()
                        "0u@eth0" "2:lan" "3:lan" "4:lan"
                ucidef_set_interface_wan "eth1"
                ;;
+       pakedge,wr-1)
+               ucidef_set_interfaces_lan_wan "eth0" "eth1"
+               ucidef_add_switch "switch0" \
+                       "0u@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "0u@eth1" "5:wan"
+               ;;
        qxwlan,e2600ac-c1 |\
        qxwlan,e2600ac-c2)
                ucidef_set_interfaces_lan_wan "eth0" "eth1"
@@ -221,6 +226,8 @@ ipq40xx_setup_macs()
                lan_mac=$(cat /sys/firmware/mikrotik/hard_config/mac_base)
                label_mac="$lan_mac"
                ;;
+       pakedge,wr-1)
+               wan_mac=$(macaddr_add $(get_mac_label) 1)
        esac
 
        [ -n "$lan_mac" ] && ucidef_set_interface_macaddr "lan" $lan_mac
index b488bf5ddb1de70921afbd1298a80471b81d41f3..a0280b7f225a9987c936b0fdddcfac4d00a70f1b 100644 (file)
@@ -134,6 +134,10 @@ case "$FIRMWARE" in
                caldata_extract_mmc "0:ART" 0x1000 0x2f20
                ath10k_patch_mac $(mmc_get_mac_binary ARTMTD 0x0)
                ;;
+       pakedge,wr-1)
+               caldata_extract "0:ART" 0x1000 0x2f20
+               ath10k_patch_mac $(macaddr_add $(get_mac_label) 2)
+               ;;
        zyxel,nbg6617 |\
        zyxel,wre6606)
                caldata_extract "ART" 0x1000 0x2f20
@@ -221,6 +225,10 @@ case "$FIRMWARE" in
                caldata_extract_mmc "0:ART" 0x5000 0x2f20
                ath10k_patch_mac $(mmc_get_mac_binary ARTMTD 0xc)
                ;;
+       pakedge,wr-1)
+               caldata_extract "0:ART" 0x5000 0x2f20
+               ath10k_patch_mac $(macaddr_add $(get_mac_label) 4)
+               ;;
        zyxel,nbg6617 |\
        zyxel,wre6606)
                caldata_extract "ART" 0x5000 0x2f20
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-wr-1.dts
new file mode 100644 (file)
index 0000000..26a8b01
--- /dev/null
@@ -0,0 +1,264 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/leds/common.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "Pakedge WR-1";
+       compatible = "pakedge,wr-1";
+
+       aliases {
+               label-mac-device = &gmac0;
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+               pinctrl-0 = <&key_pins>;
+               pinctrl-names = "default";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 59 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+               pinctrl-0 = <&led_pins>;
+               pinctrl-names = "default";
+
+               led_power: power {
+                       label = "blue:power";
+                       gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_POWER;
+               };
+
+               wlan2g {
+                       label = "blue:wlan2g";
+                       gpios = <&tlmm 1 GPIO_ACTIVE_LOW>;
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_WLAN;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wlan5g {
+                       label = "blue:wlan5g";
+                       gpios = <&tlmm 2 GPIO_ACTIVE_LOW>;
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_WLAN;
+                       linux,default-trigger = "phy1tpt";
+               };
+       };
+
+       soc {
+               ess-psgmii@98000 {
+                       status = "okay";
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               tcsr@194b000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               ess-switch@c000000 {
+                       status = "okay";
+               };
+
+               edma@c080000 {
+                       status = "okay";
+               };
+       };
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       status = "okay";
+
+       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "0:SBL1";
+                               reg = <0x0000000 0x0040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "0:MIBIB";
+                               reg = <0x0040000 0x0020000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "0:QSEE";
+                               reg = <0x0060000 0x0060000>;
+                               read-only;
+                       };
+
+                       partition@c0000 {
+                               label = "0:CDT";
+                               reg = <0x00c0000 0x0010000>;
+                               read-only;
+                       };
+
+                       partition@d0000 {
+                               label = "0:DDRPARAMS";
+                               reg = <0x00d0000 0x0010000>;
+                               read-only;
+                       };
+
+                       partition@e0000 {
+                               label = "0:APPSBLENV";
+                               reg = <0x00e0000 0x0010000>;
+                               read-only;
+                       };
+
+                       partition@f0000 {
+                               label = "0:APPSBL";
+                               reg = <0x00f0000 0x0080000>;
+                               read-only;
+                       };
+
+                       partition@170000 {
+                               label = "0:ART";
+                               reg = <0x0170000 0x0010000>;
+                               read-only;
+                       };
+
+                       partition@180000 {
+                               label = "firmware";
+                               reg = <0x0180000 0x1e80000>;
+                       };
+               };
+       };
+};
+
+&blsp1_uart1 {
+       status = "okay";
+
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+};
+
+&crypto {
+       status = "okay";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&mdio {
+       status = "okay";
+};
+
+&prng {
+       status = "okay";
+};
+
+&tlmm {
+       key_pins: key_pinmux {
+               mux {
+                       function = "gpio";
+                       pins = "gpio59";
+                       bias-pull-up;
+               };
+       };
+
+       led_pins: led_pinmux {
+               mux {
+                       function = "gpio";
+                       pins = "gpio0", "gpio1", "gpio2";
+                       bias-none;
+                       drive-strength = <2>;
+                       output-low;
+               };
+       };
+
+       serial_pins: serial_pinmux {
+               mux {
+                       function = "blsp_uart0";
+                       pins = "gpio60", "gpio61";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               mux {
+                       function = "blsp_spi0";
+                       pins = "gpio55", "gpio56", "gpio57";
+                       bias-disable;
+                       drive-strength = <12>;
+               };
+
+               mux_cs {
+                       function = "gpio";
+                       pins = "gpio54";
+                       bias-disable;
+                       drive-strength = <2>;
+                       output-high;
+               };
+       };
+};
+
+&usb2 {
+       status = "okay";
+};
+
+&usb2_hs_phy {
+       status = "okay";
+};
+
+&watchdog {
+       status = "okay";
+};
+
+&wifi0 {
+       status = "okay";
+};
+
+&wifi1 {
+       status = "okay";
+};
index e8f8fa27b9402792cec02478e08d29050a86aae9..5652bf9414b990fdf6d187bff220153224358442 100644 (file)
@@ -894,6 +894,18 @@ define Device/p2w_r619ac-128m
 endef
 TARGET_DEVICES += p2w_r619ac-128m
 
+define Device/pakedge_wr-1
+       $(call Device/FitImageLzma)
+       DEVICE_VENDOR := Pakedge
+       DEVICE_MODEL := WR-1
+       DEVICE_DTS_CONFIG := config@ap.dk01.1-c1
+       SOC := qcom-ipq4018
+       BLOCKSIZE := 64k
+       IMAGE_SIZE := 31232k
+       IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata
+endef
+TARGET_DEVICES += pakedge_wr-1
+
 define Device/plasmacloud_pa1200
        $(call Device/FitImageLzma)
        DEVICE_VENDOR := Plasma Cloud