kernel: bump 5.4 to 5.4.162
authorJohn Audia <graysky@archlinux.us>
Sat, 27 Nov 2021 20:40:46 +0000 (15:40 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 28 Nov 2021 15:32:45 +0000 (16:32 +0100)
All patches automatically rebased.

Build system: x86_64
Build-tested: ramips/mt7621*

*I am hit with the binutils 2.37 bug so I had to revert 7f1edbd41295dff9f2127b169fbc086c0fb2c14e
in order to downgrade to 2.35.1

Signed-off-by: John Audia <graysky@archlinux.us>
17 files changed:
include/kernel-version.mk
target/linux/bcm63xx/patches-5.4/339-MIPS-BCM63XX-add-support-for-BCM63268.patch
target/linux/bcm63xx/patches-5.4/341-MIPS-BCM63XX-add-support-for-BCM6318.patch
target/linux/bcm63xx/patches-5.4/389-MIPS-BCM63XX-add-clkdev-lookups-for-device-tree.patch
target/linux/bcm63xx/patches-5.4/430-MIPS-BCM63XX-add-nand-clocks.patch
target/linux/generic/backport-5.4/800-v5.5-scsi-core-Add-sysfs-attributes-for-VPD-pages-0h-and-.patch
target/linux/generic/hack-5.4/301-mips_image_cmdline_hack.patch
target/linux/generic/hack-5.4/904-debloat_dma_buf.patch
target/linux/generic/pending-5.4/103-MIPS-select-CPU_MIPS64-for-remaining-MIPS64-CPUs.patch
target/linux/generic/pending-5.4/300-mips_expose_boot_raw.patch
target/linux/layerscape/patches-5.4/302-dts-0011-ARM-dts-accumulated-change.patch
target/linux/layerscape/patches-5.4/302-dts-0046-ARM-dts-Fix-DWC3-IP-VBUS-glitch-issue-on-LS1021A.patch
target/linux/layerscape/patches-5.4/302-dts-0071-arm-dts-ls1021a-replace-ftm0-with-ftm_alarm0-DT-node.patch
target/linux/layerscape/patches-5.4/302-dts-0087-arm-dts-ls1021a-fix-that-FlexTimer-cannot-wakeup-sys.patch
target/linux/layerscape/patches-5.4/302-dts-0098-LF-403-ARM64-dts-fsl-Add-clock-names-mclk0-for-SAI-n.patch
target/linux/ramips/patches-5.4/0122-mips-ralink-enable-zboot-support.patch
target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch

index df4fd84f895794ddbd5b36c490d0eb6294158d0d..73de553a7b02ee4a8dd86f0aa1f2c42bb62deebd 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .161
+LINUX_VERSION-5.4 = .162
 LINUX_VERSION-5.10 = .82
 
-LINUX_KERNEL_HASH-5.4.161 = 3149c6b52a3079218a60bd369a80d18275b574d84908ffee32a0a8f9ddf939a7
+LINUX_KERNEL_HASH-5.4.162 = c12d72ddaac78189305a5e98825295ecb02282970033b052276035e83189e25b
 LINUX_KERNEL_HASH-5.10.82 = d66f7c7eed02f84ae550b3c91a26c70eea13682a6d672432f07bce66ff8ce350
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index b1831026d4cd76b178de3eddb8e53ca80eeda5ae..a61a96f5690459ed1f1127ec3d0fcba18ab1004f 100644 (file)
@@ -107,7 +107,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  }
  
  static struct clk clk_pcie = {
-@@ -536,6 +550,21 @@ static struct clk_lookup bcm6368_clks[]
+@@ -542,6 +556,21 @@ static struct clk_lookup bcm6368_clks[]
        CLKDEV_INIT(NULL, "ipsec", &clk_ipsec),
  };
  
@@ -129,7 +129,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #define HSSPI_PLL_HZ_6328     133333333
  #define HSSPI_PLL_HZ_6362     400000000
  
-@@ -568,6 +597,10 @@ static int __init bcm63xx_clk_init(void)
+@@ -574,6 +603,10 @@ static int __init bcm63xx_clk_init(void)
        case BCM6368_CPU_ID:
                clkdev_add_table(bcm6368_clks, ARRAY_SIZE(bcm6368_clks));
                break;
index c297321b6418f85aaac7e47e11d49bc73d137acb..48b183ac3bc822c45f7d5f166a6e577c15c9712c 100644 (file)
@@ -57,7 +57,7 @@ Subject: [PATCH 51/53] MIPS: BCM63XX: add support for BCM6318
                mask = CKCTL_6328_HSSPI_EN;
        else if (BCMCPU_IS_6362())
                mask = CKCTL_6362_HSSPI_EN;
-@@ -444,6 +446,19 @@ static struct clk_lookup bcm3368_clks[]
+@@ -450,6 +452,19 @@ static struct clk_lookup bcm3368_clks[]
        CLKDEV_INIT("bcm63xx_enet.1", "enet", &clk_enet1),
  };
  
@@ -77,7 +77,7 @@ Subject: [PATCH 51/53] MIPS: BCM63XX: add support for BCM6318
  static struct clk_lookup bcm6328_clks[] = {
        /* fixed rate clocks */
        CLKDEV_INIT(NULL, "periph", &clk_periph),
-@@ -565,6 +580,7 @@ static struct clk_lookup bcm63268_clks[]
+@@ -571,6 +586,7 @@ static struct clk_lookup bcm63268_clks[]
        CLKDEV_INIT(NULL, "pcie", &clk_pcie),
  };
  
@@ -85,7 +85,7 @@ Subject: [PATCH 51/53] MIPS: BCM63XX: add support for BCM6318
  #define HSSPI_PLL_HZ_6328     133333333
  #define HSSPI_PLL_HZ_6362     400000000
  
-@@ -574,6 +590,10 @@ static int __init bcm63xx_clk_init(void)
+@@ -580,6 +596,10 @@ static int __init bcm63xx_clk_init(void)
        case BCM3368_CPU_ID:
                clkdev_add_table(bcm3368_clks, ARRAY_SIZE(bcm3368_clks));
                break;
index fe4dbe3e13b8d8dffa86714dabd61be2aba3781e..45d4b8487cc3cd78131ae2c63c56a11495e72058 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH] MIPS: BCM63XX: add clkdev lookups for device tree
 
 --- a/arch/mips/bcm63xx/clk.c
 +++ b/arch/mips/bcm63xx/clk.c
-@@ -489,6 +489,8 @@ static struct clk_lookup bcm3368_clks[]
+@@ -495,6 +495,8 @@ static struct clk_lookup bcm3368_clks[]
        CLKDEV_INIT(NULL, "periph", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
@@ -18,7 +18,7 @@ Subject: [PATCH] MIPS: BCM63XX: add clkdev lookups for device tree
        /* gated clocks */
        CLKDEV_INIT(NULL, "enet0", &clk_enet0),
        CLKDEV_INIT(NULL, "enet1", &clk_enet1),
-@@ -505,7 +507,9 @@ static struct clk_lookup bcm6318_clks[]
+@@ -511,7 +513,9 @@ static struct clk_lookup bcm6318_clks[]
        /* fixed rate clocks */
        CLKDEV_INIT(NULL, "periph", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
@@ -28,7 +28,7 @@ Subject: [PATCH] MIPS: BCM63XX: add clkdev lookups for device tree
        /* gated clocks */
        CLKDEV_INIT(NULL, "enetsw", &clk_enetsw),
        CLKDEV_INIT(NULL, "usbh", &clk_usbh),
-@@ -519,7 +523,10 @@ static struct clk_lookup bcm6328_clks[]
+@@ -525,7 +529,10 @@ static struct clk_lookup bcm6328_clks[]
        CLKDEV_INIT(NULL, "periph", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
@@ -39,7 +39,7 @@ Subject: [PATCH] MIPS: BCM63XX: add clkdev lookups for device tree
        /* gated clocks */
        CLKDEV_INIT(NULL, "enetsw", &clk_enetsw),
        CLKDEV_INIT(NULL, "usbh", &clk_usbh),
-@@ -532,6 +539,7 @@ static struct clk_lookup bcm6338_clks[]
+@@ -538,6 +545,7 @@ static struct clk_lookup bcm6338_clks[]
        /* fixed rate clocks */
        CLKDEV_INIT(NULL, "periph", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
@@ -47,7 +47,7 @@ Subject: [PATCH] MIPS: BCM63XX: add clkdev lookups for device tree
        /* gated clocks */
        CLKDEV_INIT(NULL, "enet0", &clk_enet0),
        CLKDEV_INIT(NULL, "enet1", &clk_enet1),
-@@ -546,6 +554,7 @@ static struct clk_lookup bcm6345_clks[]
+@@ -552,6 +560,7 @@ static struct clk_lookup bcm6345_clks[]
        /* fixed rate clocks */
        CLKDEV_INIT(NULL, "periph", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
@@ -55,7 +55,7 @@ Subject: [PATCH] MIPS: BCM63XX: add clkdev lookups for device tree
        /* gated clocks */
        CLKDEV_INIT(NULL, "enet0", &clk_enet0),
        CLKDEV_INIT(NULL, "enet1", &clk_enet1),
-@@ -560,6 +569,7 @@ static struct clk_lookup bcm6348_clks[]
+@@ -566,6 +575,7 @@ static struct clk_lookup bcm6348_clks[]
        /* fixed rate clocks */
        CLKDEV_INIT(NULL, "periph", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
@@ -63,7 +63,7 @@ Subject: [PATCH] MIPS: BCM63XX: add clkdev lookups for device tree
        /* gated clocks */
        CLKDEV_INIT(NULL, "enet0", &clk_enet0),
        CLKDEV_INIT(NULL, "enet1", &clk_enet1),
-@@ -576,6 +586,8 @@ static struct clk_lookup bcm6358_clks[]
+@@ -582,6 +592,8 @@ static struct clk_lookup bcm6358_clks[]
        CLKDEV_INIT(NULL, "periph", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
@@ -72,7 +72,7 @@ Subject: [PATCH] MIPS: BCM63XX: add clkdev lookups for device tree
        /* gated clocks */
        CLKDEV_INIT(NULL, "enet0", &clk_enet0),
        CLKDEV_INIT(NULL, "enet1", &clk_enet1),
-@@ -595,7 +607,10 @@ static struct clk_lookup bcm6362_clks[]
+@@ -601,7 +613,10 @@ static struct clk_lookup bcm6362_clks[]
        CLKDEV_INIT(NULL, "periph", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
@@ -83,7 +83,7 @@ Subject: [PATCH] MIPS: BCM63XX: add clkdev lookups for device tree
        /* gated clocks */
        CLKDEV_INIT(NULL, "enetsw", &clk_enetsw),
        CLKDEV_INIT(NULL, "usbh", &clk_usbh),
-@@ -611,6 +626,8 @@ static struct clk_lookup bcm6368_clks[]
+@@ -617,6 +632,8 @@ static struct clk_lookup bcm6368_clks[]
        CLKDEV_INIT(NULL, "periph", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
@@ -92,7 +92,7 @@ Subject: [PATCH] MIPS: BCM63XX: add clkdev lookups for device tree
        /* gated clocks */
        CLKDEV_INIT(NULL, "enetsw", &clk_enetsw),
        CLKDEV_INIT(NULL, "usbh", &clk_usbh),
-@@ -625,7 +642,10 @@ static struct clk_lookup bcm63268_clks[]
+@@ -631,7 +648,10 @@ static struct clk_lookup bcm63268_clks[]
        CLKDEV_INIT(NULL, "periph", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.0", "refclk", &clk_periph),
        CLKDEV_INIT("bcm63xx_uart.1", "refclk", &clk_periph),
index 883f76fe76b3826ca52f2c3736ceedc02d6f816f..a8f70e3db3b277d60a63ca02acd3829f840314b5 100644 (file)
@@ -24,7 +24,7 @@
   * Internal peripheral clock
   */
  static struct clk clk_periph = {
-@@ -612,6 +629,7 @@ static struct clk_lookup bcm6362_clks[]
+@@ -618,6 +635,7 @@ static struct clk_lookup bcm6362_clks[]
        CLKDEV_INIT("bcm63xx-hsspi.0", "pll", &clk_hsspi_pll),
        CLKDEV_INIT("10001000.spi", "pll", &clk_hsspi_pll),
        /* gated clocks */
@@ -32,7 +32,7 @@
        CLKDEV_INIT(NULL, "enetsw", &clk_enetsw),
        CLKDEV_INIT(NULL, "usbh", &clk_usbh),
        CLKDEV_INIT(NULL, "usbd", &clk_usbd),
-@@ -629,6 +647,7 @@ static struct clk_lookup bcm6368_clks[]
+@@ -635,6 +653,7 @@ static struct clk_lookup bcm6368_clks[]
        CLKDEV_INIT("10000100.serial", "refclk", &clk_periph),
        CLKDEV_INIT("10000120.serial", "refclk", &clk_periph),
        /* gated clocks */
@@ -40,7 +40,7 @@
        CLKDEV_INIT(NULL, "enetsw", &clk_enetsw),
        CLKDEV_INIT(NULL, "usbh", &clk_usbh),
        CLKDEV_INIT(NULL, "usbd", &clk_usbd),
-@@ -647,6 +666,7 @@ static struct clk_lookup bcm63268_clks[]
+@@ -653,6 +672,7 @@ static struct clk_lookup bcm63268_clks[]
        CLKDEV_INIT("bcm63xx-hsspi.0", "pll", &clk_hsspi_pll),
        CLKDEV_INIT("10001000.spi", "pll", &clk_hsspi_pll),
        /* gated clocks */
index 8c18d5df6d5c79bfcf3d02de422d9f8a0133d154..2133280e882b46cdb9613ef1398853b895d477f2 100644 (file)
@@ -68,7 +68,7 @@ Signed-off-by: Martin K. Petersen <martin.petersen@oracle.com>
        kfree(sdev->inquiry);
        kfree(sdev);
  
-@@ -883,6 +892,8 @@ static struct bin_attribute dev_attr_vpd
+@@ -891,6 +900,8 @@ static struct bin_attribute dev_attr_vpd
  
  sdev_vpd_pg_attr(pg83);
  sdev_vpd_pg_attr(pg80);
@@ -77,7 +77,7 @@ Signed-off-by: Martin K. Petersen <martin.petersen@oracle.com>
  
  static ssize_t show_inquiry(struct file *filep, struct kobject *kobj,
                            struct bin_attribute *bin_attr,
-@@ -1215,12 +1226,18 @@ static umode_t scsi_sdev_bin_attr_is_vis
+@@ -1223,12 +1234,18 @@ static umode_t scsi_sdev_bin_attr_is_vis
        struct scsi_device *sdev = to_scsi_device(dev);
  
  
@@ -96,7 +96,7 @@ Signed-off-by: Martin K. Petersen <martin.petersen@oracle.com>
        return S_IRUGO;
  }
  
-@@ -1263,8 +1280,10 @@ static struct attribute *scsi_sdev_attrs
+@@ -1271,8 +1288,10 @@ static struct attribute *scsi_sdev_attrs
  };
  
  static struct bin_attribute *scsi_sdev_bin_attrs[] = {
index af6b51aa4f6eb08999f3cce465812a8c27a3eec0..ddae75f6146d052f5c0371e3bbd1a7cd75cfb08e 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1161,6 +1161,10 @@ config SYNC_R4K
+@@ -1164,6 +1164,10 @@ config SYNC_R4K
  config MIPS_MACHINE
        def_bool n
  
index 9ea1afd57ad45edb871b907c6e16601171b23ef3..76032d9b823aebf5dbef5c887b13857abd06edfe 100644 (file)
@@ -54,7 +54,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +MODULE_LICENSE("GPL");
 --- a/kernel/sched/core.c
 +++ b/kernel/sched/core.c
-@@ -2767,6 +2767,7 @@ int wake_up_state(struct task_struct *p,
+@@ -2770,6 +2770,7 @@ int wake_up_state(struct task_struct *p,
  {
        return try_to_wake_up(p, state, 0);
  }
index 4332b17ff9a8bfce0408c50c21bc314c723a5df1..85cd22305315450c5af3303e9094b086454555f5 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2040,7 +2040,8 @@ config CPU_MIPS32
+@@ -2043,7 +2043,8 @@ config CPU_MIPS32
  
  config CPU_MIPS64
        bool
index 02a558f7feef3df5f80fe97963d41265150375af..e16e34f1f9fc35be8f043b4a07b2d3cde954ebca 100644 (file)
@@ -9,7 +9,7 @@ Acked-by: Rob Landley <rob@landley.net>
 ---
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1071,9 +1071,6 @@ config FW_ARC
+@@ -1074,9 +1074,6 @@ config FW_ARC
  config ARCH_MAY_HAVE_PC_FDC
        bool
  
@@ -19,7 +19,7 @@ Acked-by: Rob Landley <rob@landley.net>
  config CEVT_BCM1480
        bool
  
-@@ -3047,6 +3044,18 @@ choice
+@@ -3050,6 +3047,18 @@ choice
                bool "Extend builtin kernel arguments with bootloader arguments"
  endchoice
  
index c49c4db2a70fbfb05e6cda85d53bce35e851175e..6f3181d65aeafc551c0d448d527f6b3a31ee69e6 100644 (file)
@@ -75,7 +75,7 @@ Signed-off-by: Li Yang <leoyang.li@nxp.com>
                        big-endian;
                };
  
-@@ -371,7 +372,7 @@
+@@ -338,7 +339,7 @@
                };
  
                i2c0: i2c@2180000 {
@@ -84,7 +84,7 @@ Signed-off-by: Li Yang <leoyang.li@nxp.com>
                        #address-cells = <1>;
                        #size-cells = <0>;
                        reg = <0x0 0x2180000 0x0 0x10000>;
-@@ -380,11 +381,12 @@
+@@ -347,11 +348,12 @@
                        clocks = <&clockgen 4 1>;
                        dma-names = "tx", "rx";
                        dmas = <&edma0 1 39>, <&edma0 1 38>;
@@ -98,7 +98,7 @@ Signed-off-by: Li Yang <leoyang.li@nxp.com>
                        #address-cells = <1>;
                        #size-cells = <0>;
                        reg = <0x0 0x2190000 0x0 0x10000>;
-@@ -393,6 +395,7 @@
+@@ -360,6 +362,7 @@
                        clocks = <&clockgen 4 1>;
                        dma-names = "tx", "rx";
                        dmas = <&edma0 1 37>, <&edma0 1 36>;
@@ -106,7 +106,7 @@ Signed-off-by: Li Yang <leoyang.li@nxp.com>
                        status = "disabled";
                };
  
-@@ -579,6 +582,16 @@
+@@ -546,6 +549,16 @@
                        status = "disabled";
                };
  
@@ -123,7 +123,7 @@ Signed-off-by: Li Yang <leoyang.li@nxp.com>
                pwm1: pwm@29e0000 {
                        compatible = "fsl,vf610-ftm-pwm";
                        #pwm-cells = <3>;
-@@ -861,6 +874,8 @@
+@@ -828,6 +841,8 @@
                        dr_mode = "host";
                        snps,quirk-frame-length-adjustment = <0x20>;
                        snps,dis_rxdet_inp3_quirk;
@@ -132,7 +132,7 @@ Signed-off-by: Li Yang <leoyang.li@nxp.com>
                        snps,incr-burst-type-adjustment = <1>, <4>, <8>, <16>;
                };
  
-@@ -869,7 +884,9 @@
+@@ -836,7 +851,9 @@
                        reg = <0x00 0x03400000 0x0 0x00010000   /* controller registers */
                               0x40 0x00000000 0x0 0x00002000>; /* configuration space */
                        reg-names = "regs", "config";
@@ -143,7 +143,7 @@ Signed-off-by: Li Yang <leoyang.li@nxp.com>
                        fsl,pcie-scfg = <&scfg 0>;
                        #address-cells = <3>;
                        #size-cells = <2>;
-@@ -893,7 +910,9 @@
+@@ -860,7 +877,9 @@
                        reg = <0x00 0x03500000 0x0 0x00010000   /* controller registers */
                               0x48 0x00000000 0x0 0x00002000>; /* configuration space */
                        reg-names = "regs", "config";
index de9de09913fb0183a93f305e6d21eaa4081789ed..e80fe0a45e090ad626130fc38c4aff600b2f4f6f 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Ran Wang <ran.wang_1@nxp.com>
 
 --- a/arch/arm/boot/dts/ls1021a.dtsi
 +++ b/arch/arm/boot/dts/ls1021a.dtsi
-@@ -877,6 +877,7 @@
+@@ -844,6 +844,7 @@
                        usb3-lpm-capable;
                        snps,dis-u1u2-when-u3-quirk;
                        snps,incr-burst-type-adjustment = <1>, <4>, <8>, <16>;
index d8412c2b50d2d8cbbbe404bdc10f9a8d16b2f1fa..2d63cc0b5538536c70746c8a9fbd17938bb99f18 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        };
  
        cpus {
-@@ -582,16 +583,6 @@
+@@ -549,16 +550,6 @@
                        status = "disabled";
                };
  
@@ -41,7 +41,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
                pwm1: pwm@29e0000 {
                        compatible = "fsl,vf610-ftm-pwm";
                        #pwm-cells = <3>;
-@@ -1003,5 +994,18 @@
+@@ -970,6 +961,19 @@
                        big-endian;
                };
  
@@ -59,4 +59,5 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
 +                      big-endian;
 +              };
        };
- };
+       thermal-zones {
index f677abad87f5c40afca3fe68c8c22ba2a9a1ee6b..cebd74524b53503574c9431e02aa4c9d591714ad 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
 
 --- a/arch/arm/boot/dts/ls1021a.dtsi
 +++ b/arch/arm/boot/dts/ls1021a.dtsi
-@@ -998,6 +998,12 @@
+@@ -965,6 +965,12 @@
                        compatible = "fsl,ls1021a-rcpm", "fsl,qoriq-rcpm-2.1+";
                        reg = <0x0 0x1ee2140 0x0 0x8>;
                        #fsl,rcpm-wakeup-cells = <2>;
index a6611b0b12a5f9627c5eb89e24682ab9eac7cede..2cb3cfd7d88a780993ad97ec791fd86dbe64eb8c 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Alison Wang <alison.wang@nxp.com>
 
 --- a/arch/arm/boot/dts/ls1021a.dtsi
 +++ b/arch/arm/boot/dts/ls1021a.dtsi
-@@ -682,8 +682,9 @@
+@@ -649,8 +649,9 @@
                        reg = <0x0 0x2b50000 0x0 0x10000>;
                        interrupts = <GIC_SPI 132 IRQ_TYPE_LEVEL_HIGH>;
                        clocks = <&clockgen 4 1>, <&clockgen 4 1>,
@@ -27,7 +27,7 @@ Signed-off-by: Alison Wang <alison.wang@nxp.com>
                        dma-names = "tx", "rx";
                        dmas = <&edma0 1 47>,
                               <&edma0 1 46>;
-@@ -696,8 +697,9 @@
+@@ -663,8 +664,9 @@
                        reg = <0x0 0x2b60000 0x0 0x10000>;
                        interrupts = <GIC_SPI 133 IRQ_TYPE_LEVEL_HIGH>;
                        clocks = <&clockgen 4 1>, <&clockgen 4 1>,
index 4ffbb2bebb636d7d46790828b3dceb95b2d1190f..1123cce3a5799eab1e3b297b33dbc0e18b980e07 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Thomas Bogendoerfer <tsbogend@alpha.franken.de>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -628,6 +628,7 @@ config RALINK
+@@ -631,6 +631,7 @@ config RALINK
        select SYS_SUPPORTS_32BIT_KERNEL
        select SYS_SUPPORTS_LITTLE_ENDIAN
        select SYS_SUPPORTS_MIPS16
index c680d5f4a562ed34b0c6db1bae8c12b7b6909f27..b47f6f5ffadc30e27baf335245996aa6d7309967 100644 (file)
@@ -10,7 +10,7 @@
  platforms += sgi-ip27
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -633,6 +633,26 @@ config RALINK
+@@ -636,6 +636,26 @@ config RALINK
        select ARCH_HAS_RESET_CONTROLLER
        select RESET_CONTROLLER