kernel: bump 5.15 to 5.15.124
authorJohn Audia <therealgraysky@proton.me>
Thu, 3 Aug 2023 17:53:47 +0000 (13:53 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 9 Aug 2023 20:06:23 +0000 (22:06 +0200)
Changelog: https://lore.kernel.org/stable/2023080341-curliness-salary-4158@gregkh/

1. Needed to make a change to to package/kernel/linux/modules/netsupport.mk
   due to upstream moving vxlan to its own directory[1].  @john-tho suggested
   using the the 6.1 xvlan FILES to circumvent.
2. All patches automatically rebased.

1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.124&id=77396fa9096abdbfbb87d63e73ad44d5621cf103

Signed-off-by: John Audia <therealgraysky@proton.me>
17 files changed:
include/kernel-5.15
package/kernel/linux/modules/netsupport.mk
target/linux/ath79/patches-5.15/910-unaligned_access_hacks.patch
target/linux/generic/backport-5.15/707-v6.3-net-pcs-add-driver-for-MediaTek-SGMII-PCS.patch
target/linux/generic/backport-5.15/790-v6.4-0011-net-dsa-mt7530-introduce-separate-MDIO-driver.patch
target/linux/generic/backport-5.15/790-v6.4-0013-net-dsa-mt7530-introduce-driver-for-MT7988-built-in-.patch
target/linux/generic/backport-5.15/791-v6.2-01-net-phy-Add-driver-for-Motorcomm-yt8521-gigabit-ethernet.patch
target/linux/generic/backport-5.15/804-v5.18-0009-nvmem-Add-driver-for-OCOTP-in-Sunplus-SP7021.patch
target/linux/generic/backport-5.15/806-v6.0-0001-nvmem-microchip-otpc-add-support.patch
target/linux/generic/hack-5.15/780-usb-net-MeigLink_modem_support.patch
target/linux/generic/pending-5.15/351-irqchip-bcm-6345-l1-request-memory-region.patch
target/linux/layerscape/patches-5.15/701-staging-add-fsl_ppfe-driver.patch
target/linux/mediatek/patches-5.15/730-v6.5-net-phy-add-driver-for-MediaTek-SoC-built-in-GE-PHYs.patch
target/linux/mediatek/patches-5.15/850-v6.0-i2c-move-drivers-from-strlcpy-to-strscpy.patch
target/linux/mvebu/patches-5.15/907-MAINTAINERS-Add-an-entry-for-the-IEI-WT61P803-PUZZLE.patch
target/linux/ramips/patches-5.15/005-v6.5-09-MAINTAINERS-add-Mediatek-MTMIPS-Clock-maintainer.patch
target/linux/realtek/patches-5.15/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch

index 3052c783a955f83bc11dd29a65dcb64c554bc2ef..35c6240132b900f30cd33cfe430fa9511fe789f7 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.15 = .123
-LINUX_KERNEL_HASH-5.15.123 = 2de69544a12e6a059163c58fc901c13bcf22e8cac39c66b56f8fbb633399bf93
+LINUX_VERSION-5.15 = .124
+LINUX_KERNEL_HASH-5.15.124 = 00036a0260ad012aa832a8698a4afcf23b2410091527738ce48ce3fcc23f22ed
index 35e627002eac63e01c3ff0b591c423100cbbaf7a..0187a058258c14f6d3c1b6eba2b3a1b3f915508a 100644 (file)
@@ -93,8 +93,7 @@ define KernelPackage/vxlan
        +IPV6:kmod-udptunnel6
   KCONFIG:=CONFIG_VXLAN
   FILES:= \
-       $(LINUX_DIR)/drivers/net/vxlan.ko@lt5.18 \
-       $(LINUX_DIR)/drivers/net/vxlan/vxlan.ko@ge5.18
+       $(LINUX_DIR)/drivers/net/vxlan/vxlan.ko
   AUTOLOAD:=$(call AutoLoad,13,vxlan)
 endef
 
index f542c32d45d3f24245b224b7d7a8e98a2eda6248..1971b9cd0101855805a5e610d1f9614e3dee4d6b 100644 (file)
@@ -654,7 +654,7 @@ SVN-Revision: 35130
                return false;
  
        return true;
-@@ -750,13 +754,13 @@ static inline void ipv6_addr_set_v4mappe
+@@ -746,13 +750,13 @@ static inline void ipv6_addr_set_v4mappe
   */
  static inline int __ipv6_addr_diff32(const void *token1, const void *token2, int addrlen)
  {
@@ -670,7 +670,7 @@ SVN-Revision: 35130
                if (xb)
                        return i * 32 + 31 - __fls(ntohl(xb));
        }
-@@ -950,17 +954,18 @@ static inline u32 ip6_multipath_hash_fie
+@@ -946,17 +950,18 @@ static inline u32 ip6_multipath_hash_fie
  static inline void ip6_flow_hdr(struct ipv6hdr *hdr, unsigned int tclass,
                                __be32 flowlabel)
  {
index 3668a821ef758f106d5be0d4124afa9ed2183672..1cae648358f8efc4e6b049fd45b465e0bded66f7 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Jakub Kicinski <kuba@kernel.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11782,6 +11782,14 @@ L:    netdev@vger.kernel.org
+@@ -11783,6 +11783,14 @@ L:    netdev@vger.kernel.org
  S:    Maintained
  F:    drivers/net/ethernet/mediatek/
  
index c0e29fa00fbf0eda20f2dbe7230eb9e6738d8042..2cebac1f8c6471b2a5a1ca406864689e08880736 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11894,6 +11894,7 @@ M:     Landen Chao <Landen.Chao@mediatek.com
+@@ -11895,6 +11895,7 @@ M:     Landen Chao <Landen.Chao@mediatek.com
  M:    DENG Qingfang <dqfext@gmail.com>
  L:    netdev@vger.kernel.org
  S:    Maintained
index 89dc30c7dffb7c341aac3ed04b3bc90cbb7050ed..889a13e0149bb416bcb045b44e738c66f82ee576 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11892,9 +11892,11 @@ MEDIATEK SWITCH DRIVER
+@@ -11893,9 +11893,11 @@ MEDIATEK SWITCH DRIVER
  M:    Sean Wang <sean.wang@mediatek.com>
  M:    Landen Chao <Landen.Chao@mediatek.com>
  M:    DENG Qingfang <dqfext@gmail.com>
index eb51b410b544413c2728fbf266f39ab21f6216f6..7eb097f86d02126c887cd07c2f6794f1cf5f92b5 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -12693,6 +12693,7 @@ F:     include/uapi/linux/meye.h
+@@ -12694,6 +12694,7 @@ F:     include/uapi/linux/meye.h
  
  MOTORCOMM PHY DRIVER
  M:    Peter Geis <pgwipeout@gmail.com>
index 6ad9257d60e4e18c26986ca33eed482cf9d094b4..79fd479054ed932cd03185def3537688b8d183a5 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17958,6 +17958,11 @@ L:    netdev@vger.kernel.org
+@@ -17959,6 +17959,11 @@ L:    netdev@vger.kernel.org
  S:    Maintained
  F:    drivers/net/ethernet/dlink/sundance.c
  
index f7ea61626c506971a930800ec9f4522250b8ce14..24beeda0d2254e3889ede9efd8396b707340c0c7 100644 (file)
@@ -57,7 +57,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -12357,6 +12357,14 @@ S:    Supported
+@@ -12358,6 +12358,14 @@ S:    Supported
  F:    Documentation/devicetree/bindings/mtd/atmel-nand.txt
  F:    drivers/mtd/nand/raw/atmel/*
  
index a44a5b6d89c8ca86524d9486f65c67d40f9e7a1e..4f1966db165054db035cfa167fcc8b344a894b67 100644 (file)
@@ -29,7 +29,7 @@ Subject: [PATCH] net/usb/qmi_wwan: add MeigLink modem support
  
  #define QUECTEL_VENDOR_ID                     0x2c7c
  /* These Quectel products use Quectel's vendor ID */
-@@ -1177,6 +1179,11 @@ static const struct usb_device_id option
+@@ -1179,6 +1181,11 @@ static const struct usb_device_id option
          .driver_info = ZLP },
        { USB_DEVICE(QUECTEL_VENDOR_ID, QUECTEL_PRODUCT_BG96),
          .driver_info = RSVD(4) },
index 9fad4f62c61696eaf5948f7448efe6fd02cd6eeb..91654cc294c31f741cca8c16f601071c7a638f34 100644 (file)
@@ -91,7 +91,7 @@ Acked-by: Florian Fainelli <f.fainelli@gmail.com>
 
 --- a/drivers/irqchip/irq-bcm6345-l1.c
 +++ b/drivers/irqchip/irq-bcm6345-l1.c
-@@ -261,6 +261,9 @@ static int __init bcm6345_l1_init_one(st
+@@ -257,6 +257,9 @@ static int __init bcm6345_l1_init_one(st
        if (!cpu->map_base)
                return -ENOMEM;
  
@@ -101,7 +101,7 @@ Acked-by: Florian Fainelli <f.fainelli@gmail.com>
        for (i = 0; i < n_words; i++) {
                cpu->enable_cache[i] = 0;
                __raw_writel(0, cpu->map_base + reg_enable(intc, i));
-@@ -339,8 +342,7 @@ static int __init bcm6345_l1_of_init(str
+@@ -335,8 +338,7 @@ static int __init bcm6345_l1_of_init(str
        for_each_cpu(idx, &intc->cpumask) {
                struct bcm6345_l1_cpu *cpu = intc->cpus[idx];
  
index e8a69153500f8b922d0d142ee0c6b4c8b0a5cedf..445d050a7842d1291508c13817ff5345a89c51ac 100644 (file)
@@ -854,7 +854,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
 +};
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -7519,6 +7519,14 @@ F:      drivers/ptp/ptp_qoriq.c
+@@ -7520,6 +7520,14 @@ F:      drivers/ptp/ptp_qoriq.c
  F:    drivers/ptp/ptp_qoriq_debugfs.c
  F:    include/linux/fsl/ptp_qoriq.h
  
index 26ebcb6733b7aa61278d69eadb6fc33b7227c7bc..9da29755825cd10d467c554a9a04d9c1e85ed477 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11790,6 +11790,15 @@ S:    Maintained
+@@ -11791,6 +11791,15 @@ S:    Maintained
  F:    drivers/net/pcs/pcs-mtk-lynxi.c
  F:    include/linux/pcs/pcs-mtk-lynxi.h
  
index 44d3753b142d250389748b466d980ed1ce4435f2..79444e071e8443ef2dbe5345dfc4dca0810ca76b 100644 (file)
@@ -257,7 +257,7 @@ Signed-off-by: Wolfram Sang <wsa@kernel.org>
  
 --- a/drivers/i2c/busses/i2c-ibm_iic.c
 +++ b/drivers/i2c/busses/i2c-ibm_iic.c
-@@ -738,7 +738,7 @@ static int iic_probe(struct platform_dev
+@@ -736,7 +736,7 @@ static int iic_probe(struct platform_dev
        adap = &dev->adap;
        adap->dev.parent = &ofdev->dev;
        adap->dev.of_node = of_node_get(np);
index 242a6c1e00abba3f45f4e0eb7a1cf2dff74cb338..0b6891343d210655779194f58cdf277dbcdcbd0d 100644 (file)
@@ -16,7 +16,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -9056,6 +9056,22 @@ F:      include/net/nl802154.h
+@@ -9057,6 +9057,22 @@ F:      include/net/nl802154.h
  F:    net/ieee802154/
  F:    net/mac802154/
  
index 3c9a5982af7b1b2d609aa18459f22a44f2a15c38..d05c1954f7f1f911b472767124a753d7dcc620de 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Thomas Bogendoerfer <tsbogend@alpha.franken.de>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -11858,6 +11858,12 @@ S:    Maintained
+@@ -11859,6 +11859,12 @@ S:    Maintained
  F:    Documentation/devicetree/bindings/clock/mediatek,mt7621-sysc.yaml
  F:    drivers/clk/ralink/clk-mt7621.c
  
index dfe7ab28d73b9e3a3940c1d5d3c815dc8df0ec86..60db030647d94f36fffac0dd2e7330792400f60a 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Guenter Roeck <linux@roeck-us.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -15895,6 +15895,13 @@ S:    Maintained
+@@ -15896,6 +15896,13 @@ S:    Maintained
  F:    include/sound/rt*.h
  F:    sound/soc/codecs/rt*