zram-swap: clean up the makefile
authorRui Salvaterra <rsalvaterra@gmail.com>
Thu, 1 Apr 2021 13:36:32 +0000 (14:36 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 3 Apr 2021 16:57:13 +0000 (18:57 +0200)
Break dependencies into separate lines, to improve the readability. Trim
trailing whitespace.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
package/system/zram-swap/Makefile

index 18c6afee96540fc5c6c0206fc9b11f990f97475e..80f87fcdff9068ec772925f9c6638faf65671d67 100644 (file)
@@ -17,14 +17,20 @@ include $(INCLUDE_DIR)/package.mk
 define Package/zram-swap
   SECTION:=utils
   CATEGORY:=Base system
-  DEPENDS:=+kmod-zram +@BUSYBOX_CONFIG_MKSWAP +@BUSYBOX_CONFIG_SWAPON +@BUSYBOX_CONFIG_FEATURE_SWAPON_DISCARD +@BUSYBOX_CONFIG_FEATURE_SWAPON_PRI +@BUSYBOX_CONFIG_SWAPOFF
+  DEPENDS:= \
+       +@BUSYBOX_CONFIG_FEATURE_SWAPON_DISCARD \
+       +@BUSYBOX_CONFIG_FEATURE_SWAPON_PRI \
+       +@BUSYBOX_CONFIG_MKSWAP \
+       +@BUSYBOX_CONFIG_SWAPOFF \
+       +@BUSYBOX_CONFIG_SWAPON \
+       +kmod-zram
   TITLE:=ZRAM swap scripts
   PKGARCH:=all
 endef
 
 define Package/zram-swap/description
- A script to activate swaping on a compressed zram partition. This 
- could be used to increase the available memory, by using compressed 
+ A script to activate swaping on a compressed zram partition. This
+ could be used to increase the available memory, by using compressed
  memory.
 endef