firmware-utils: mkfwimage: enable extra compiler checks and fix them
authorPetr Štetiar <ynezz@true.cz>
Fri, 19 Jul 2019 14:10:35 +0000 (16:10 +0200)
committerPetr Štetiar <ynezz@true.cz>
Fri, 19 Jul 2019 14:15:25 +0000 (16:15 +0200)
Let's enforce additional automatic checks enforced by the compiler in
order to catch possible errors during compilation.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
tools/firmware-utils/Makefile
tools/firmware-utils/src/mkfwimage.c

index bde90f0ecd154beb2a82bbcb16e907c1dac451db..eca4dd7da7b18cf004bc0c485ffea273d930fa0c 100644 (file)
@@ -12,7 +12,13 @@ include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 define cc
-       $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_LDFLAGS) -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) $(foreach src,$(1),src/$(src).c) $(2)
+       $(HOSTCC) \
+               $(HOST_CFLAGS) \
+               -Wno-unused-parameter \
+               -include endian.h $(HOST_LDFLAGS) \
+               -o $(HOST_BUILD_DIR)/bin/$(firstword $(1)) \
+               $(foreach src,$(1),src/$(src).c) \
+               $(2)
 endef
 
 define Host/Compile
@@ -32,7 +38,7 @@ define Host/Compile
        $(call cc,mkzynfw)
        $(call cc,lzma2eva,-lz)
        $(call cc,mkcasfw)
-       $(call cc,mkfwimage,-lz -Wall)
+       $(call cc,mkfwimage,-lz -Wall -Werror -Wextra)
        $(call cc,mkfwimage2,-lz)
        $(call cc,imagetag imagetag_cmdline cyg_crc32)
        $(call cc,add_header)
index 2b84d3db536eb2eba5ec1a9a6d08b7743db4bdd8..c919a2a13145b34c6e3a706540c4ad289e1df552 100644 (file)
@@ -262,7 +262,8 @@ static void usage(const char* progname)
 
 static void print_image_info(const image_info_t* im)
 {
-       int i = 0;
+       unsigned int i = 0;
+
        INFO("Firmware version: '%s'\n"
             "Output file: '%s'\n"
             "Part count: %u\n",
@@ -279,8 +280,6 @@ static void print_image_info(const image_info_t* im)
        }
 }
 
-
-
 static u_int32_t filelength(const char* file)
 {
        FILE *p;
@@ -336,7 +335,7 @@ static int create_image_layout(const char* kernelfile, const char* rootfsfile, c
  */
 static int validate_image_layout(image_info_t* im)
 {
-       int i;
+       unsigned int i;
 
        if (im->part_count == 0 || im->part_count > MAX_SECTIONS)
        {
@@ -383,7 +382,7 @@ static int build_image(image_info_t* im)
        char* ptr;
        u_int32_t mem_size;
        FILE* f;
-       int i;
+       unsigned int i;
 
        // build in-memory buffer
        mem_size = sizeof(header_t);