armvirt: 64: add Allwinner A3/A83T/A64 (sun8i family) Ethernet
authorMathew McBride <matt@traverse.com.au>
Mon, 20 Mar 2023 02:53:31 +0000 (02:53 +0000)
committerPetr Štetiar <ynezz@true.cz>
Fri, 2 Jun 2023 09:36:32 +0000 (11:36 +0200)
Add support for the dwmac (stmmac) variant used by Allwinner
Arm64 boards.

Signed-off-by: Mathew McBride <matt@traverse.com.au>
target/linux/armvirt/image/Makefile
target/linux/armvirt/modules.mk

index f1d0acd0138b0f3fb472ccb8ca7401bf302c40ad..533a17b52297693fa13eefb0ac240be7012e67c4 100644 (file)
@@ -109,8 +109,8 @@ define Device/generic
        kmod-i2c-mux-pca954x kmod-gpio-pca953x partx-utils kmod-wdt-sp805 \
        kmod-mvneta kmod-mvpp2 kmod-fsl-dpaa1-net kmod-fsl-dpaa2-net \
        kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
-       kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell kmod-sfp \
-       kmod-phy-marvell-10g kmod-atlantic
+       kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell \
+       kmod-sfp kmod-phy-marvell-10g kmod-atlantic
 endef
 TARGET_DEVICES += generic
 
index 1531e91bde0b07a53958591464fc49e84892f7e4..5c863824d373f79707b965721e7b0095d0e12278 100644 (file)
@@ -234,6 +234,17 @@ endef
 
 $(eval $(call KernelPackage,dwmac-imx))
 
+define KernelPackage/dwmac-sun8i
+  SUBMENU=$(NETWORK_DEVICES_MENU)
+  TITLE:=Allwinner H3/A83T/A64 (sun8i) Ethernet
+  DEPENDS:=+kmod-stmmac-core +kmod-mdio-bus-mux
+  KCONFIG:=CONFIG_DWMAC_SUN8I
+  FILES=$(LINUX_DIR)/drivers/net/ethernet/stmicro/stmmac/dwmac-sun8i.ko
+  AUTOLOAD=$(call AutoLoad,45,dwmac-sun8i)
+endef
+
+$(eval $(call KernelPackage,dwmac-sun8i))
+
 define KernelPackage/thunderx-net
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=Marvell (Cavium) ThunderX/2 network drivers