add matrixtunnel package (thanks to Lorenz Schori).
authorNicolas Thill <nico@openwrt.org>
Mon, 15 May 2006 07:14:09 +0000 (07:14 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 15 May 2006 07:14:09 +0000 (07:14 +0000)
SVN-Revision: 3779

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/depend.mk
openwrt/package/matrixtunnel/Config.in [new file with mode: 0644]
openwrt/package/matrixtunnel/Makefile [new file with mode: 0644]
openwrt/package/matrixtunnel/ipkg/matrixtunnel.control [new file with mode: 0644]

index 3d250ce916e20264bd961ee26e601dd525f0569f..8863994bd8605f7ad6bd5c0582c43344e01abfce 100644 (file)
@@ -113,6 +113,7 @@ source "package/lighttpd/Config.in"
 source "package/linux-atm/Config.in"
 source "package/macchanger/Config.in"
 source "package/maradns/Config.in"
+source "package/matrixtunnel/Config.in"
 source "package/miau/Config.in"
 source "package/mini_httpd/Config.in"
 source "package/mini_sendmail/Config.in"
index 7782afc570106d8b02bd3e2e205042416b11534e..89e0bab9ea30f2b0f3f97d1e074292793c5778b2 100644 (file)
@@ -140,6 +140,7 @@ package-$(BR2_PACKAGE_MACCHANGER) += macchanger
 package-$(BR2_PACKAGE_MADPLAY) += madplay
 package-$(BR2_PACKAGE_MARADNS) += maradns
 package-$(BR2_COMPILE_MATRIXSSL) += matrixssl
+package-$(BR2_PACKAGE_MATRIXTUNNEL) += matrixtunnel
 package-$(BR2_PACKAGE_MGETTY) += mgetty
 package-$(BR2_PACKAGE_MIAU) += miau
 package-$(BR2_PACKAGE_MIAX) += miax
index 1903616e104e8abd8febfbc42a3bd2ab67c304ef..35e81b18bf2167d5b1670bf8c4c24edf3fed88bd 100644 (file)
@@ -46,6 +46,7 @@ libxslt-compile: libxml2-compile
 lighttpd-compile: openssl-compile pcre-compile libxml2-compile sqlite-compile
 logrotate-compile: popt-compile
 madplay-compile: libid3tag-compile libmad-compile
+matrixtunnel-compile: matrixssl-compile
 miax-compile: bluez-libs-compile
 miredo-compile: uclibc++-compile
 monit-compile: openssl-compile
diff --git a/openwrt/package/matrixtunnel/Config.in b/openwrt/package/matrixtunnel/Config.in
new file mode 100644 (file)
index 0000000..1738ce3
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_MATRIXTUNNEL
+       prompt "matrixtunnel...................... stunnel based on matrixssl"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBMATRIXSSL
+       help
+               matrixtunnel is a stripped down version of stunnel
+               based on matrixssl library
+               
+               Depends: libmatrixssl
diff --git a/openwrt/package/matrixtunnel/Makefile b/openwrt/package/matrixtunnel/Makefile
new file mode 100644 (file)
index 0000000..ea42b1e
--- /dev/null
@@ -0,0 +1,69 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=matrixtunnel
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=ffbbe0c50cc1863f6080aca302f7e2c8
+
+PKG_SOURCE_URL:=http://znerol.ch/files
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MATRIXTUNNEL,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/sbin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --without-libiconv-prefix \
+                       --without-libintl-prefix \
+                       --with-matrixssl-src=$(BUILD_DIR)/matrixssl \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR)/src \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_MATRIXTUNNEL):
+       install -d -m0755 $(IDIR_MATRIXTUNNEL)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/matrixtunnel $(IDIR_MATRIXTUNNEL)/usr/sbin/
+       $(RSTRIP) $(IDIR_MATRIXTUNNEL)
+       $(IPKG_BUILD) $(IDIR_MATRIXTUNNEL) $(PACKAGE_DIR)
+
+mostlyclean:
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm -f $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/matrixtunnel/ipkg/matrixtunnel.control b/openwrt/package/matrixtunnel/ipkg/matrixtunnel.control
new file mode 100644 (file)
index 0000000..2d022e9
--- /dev/null
@@ -0,0 +1,5 @@
+Package: matrixtunnel
+Priority: optional
+Section: net
+Description: stunnel based on matrixssl
+Depends: libmatrixssl