lantiq: enable second VPE on Fritz!Box 7412
authorDavid Bauer <mail@david-bauer.net>
Fri, 9 Aug 2019 21:45:56 +0000 (23:45 +0200)
committerDavid Bauer <mail@david-bauer.net>
Fri, 9 Aug 2019 22:48:01 +0000 (00:48 +0200)
The AVM Fritz!Box 7412 does not use the VMMC part of the Lantiq chip but
rather a proprietary solution based on the DECT chip for the FXS ports.

Therefore, the second VPE can be enabled for use with OpenWrt.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/lantiq/files/arch/mips/boot/dts/FRITZ7412.dts
target/linux/lantiq/image/Makefile

index 97817595e9ad89ba7b0c65ea56cf43e5d2a0e0f3..111ef1b3208ee950571c4a506347edba91ee1526 100644 (file)
@@ -11,7 +11,7 @@
        model = "AVM FRITZ!Box 7412";
 
        chosen {
-               bootargs = "console=ttyLTQ0,115200 mem=126M vpe1_load_addr=0x87e00000 vpe1_mem=2M maxvpes=1 maxtcs=1 nosmp";
+               bootargs = "console=ttyLTQ0,115200";
        };
 
        aliases {
index 2352cb6b5e42eeb8dd7752bd31da90cda6ca79e2..f71a262c8249f7527ef7ea6537f5b4b44695db85 100644 (file)
@@ -673,7 +673,7 @@ define Device/avm_fritz7412
   KERNEL_SIZE := 4096k
   IMAGE_SIZE := 49152k
   DEVICE_TITLE := AVM FRITZ!Box 7412
-  DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic kmod-ltq-tapi kmod-ltq-vmmc fritz-tffs-nand fritz-caldata
+  DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic fritz-tffs-nand fritz-caldata
 endef
 TARGET_DEVICES += avm_fritz7412