realtek: fix build issues
authorBirger Koblitz <mail@birger-koblitz.de>
Tue, 5 Jan 2021 19:40:52 +0000 (20:40 +0100)
committerPetr Štetiar <ynezz@true.cz>
Tue, 5 Jan 2021 21:43:40 +0000 (22:43 +0100)
This fixes the build problems for the REALTEK target by adding a proper
configuration option for the phy module.

Signed-off-by: Birger Koblitz <mail@birger-koblitz.de>
target/linux/realtek/config-5.4
target/linux/realtek/patches-5.4/705-add-rtl-phy.patch

index 170bcb7632a5dbaae9b8595adc58ecbae7b303de..2176a2cf500c1da34a642d09e2420f9b8840f115 100644 (file)
@@ -71,6 +71,7 @@ CONFIG_GENERIC_TIME_VSYSCALL=y
 CONFIG_GPIOLIB=y
 CONFIG_GPIO_RTL8231=y
 CONFIG_GPIO_RTL838X=y
+CONFIG_REALTEK_SOC_PHY=y
 CONFIG_GRO_CELLS=y
 CONFIG_HANDLE_DOMAIN_IRQ=y
 CONFIG_HARDWARE_WATCHPOINTS=y
index 826891abe115cca32f74d7f36841e41514fd7a20..ea0d48861d59f129fd1980ef4f1d534ed5a13736 100644 (file)
@@ -1,11 +1,25 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -454,6 +454,12 @@
+       ---help---
+         Supports the Realtek 821x PHY.
+
++config REALTEK_SOC_PHY
++      tristate "Realtek SoC PHYs"
++      depends on RTL838X
++      ---help---
++        Supports the PHYs found in combination with Realtek Switch SoCs
++
+ config RENESAS_PHY
+       tristate "Driver for Renesas PHYs"
+       ---help---
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -101,7 +101,7 @@ obj-$(CONFIG_MICROSEMI_PHY)        += mscc.o
- obj-$(CONFIG_NATIONAL_PHY)    += national.o
+@@ -87,6 +87,7 @@
  obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
  obj-$(CONFIG_QSEMI_PHY)               += qsemi.o
--obj-$(CONFIG_REALTEK_PHY)     += realtek.o
-+obj-$(CONFIG_REALTEK_PHY)     += realtek.o rtl83xx-phy.o
+ obj-$(CONFIG_REALTEK_PHY)     += realtek.o
++obj-$(CONFIG_REALTEK_SOC_PHY)   += rtl83xx-phy.o
  obj-$(CONFIG_RENESAS_PHY)     += uPD60620.o
  obj-$(CONFIG_ROCKCHIP_PHY)    += rockchip.o
  obj-$(CONFIG_SMSC_PHY)                += smsc.o