tools/automake: clean up build recipes
authorMichael Pratt <mcpratt@pm.me>
Wed, 7 Sep 2022 14:45:43 +0000 (10:45 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 13 Mar 2023 21:53:41 +0000 (22:53 +0100)
The configure option datarootdir
defaults to PREFIX/share.

The Host/Clean define should be Host/Uninstall
otherwise it is removing the build directory
before there is a chance to try "make uninstall"
in that directory.
Host/Clean/Default is no longer defined.

Consolidate the install stage with Host/Uninstall,
since it is essentially uninstalling before installing.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
tools/automake/Makefile

index 85ccc0ded4d0f173a3849281a2e55c25a65e50c9..3a05cc90f8e306971f9c3e14a11d0b1d164f8dac 100644 (file)
@@ -17,7 +17,6 @@ PKG_HASH:=af6ba39142220687c500f79b4aa2f181d9b24e4f8d8ec497cea4ba26c64bedaf
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += \
-       --datarootdir=$(STAGING_DIR_HOST)/share \
        --disable-silent-rules
 
 HOST_CONFIGURE_VARS += \
@@ -31,9 +30,8 @@ endef
 
 define Host/Install
        # remove old automake resources to avoid version conflicts
-       rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*
-       rm -rf $(STAGING_DIR_HOST)/share/automake-[0-9]*
-       $(MAKE) -C $(HOST_BUILD_DIR) install
+       $(call Host/Uninstall)
+       $(call Host/Compile/Default,install)
        mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
        $(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
        ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.9
@@ -45,6 +43,8 @@ endef
 
 define Host/Uninstall
        -$(call Host/Compile/Default,uninstall)
+       rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*
+       rm -rf $(STAGING_DIR_HOST)/share/automake-[0-9]*
 endef
 
 $(eval $(call HostBuild))