ath79: add support for ELECOM WAB-S1167-PS
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Thu, 22 Feb 2024 10:00:57 +0000 (19:00 +0900)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 2 Mar 2024 13:08:08 +0000 (14:08 +0100)
ELECOM WAB-S1167-PS is a 2.4/5 GHz band 11ac (Wi-Fi 5) access point,
based on QCA9557.

Specification:

- SoC              : Qualcomm Atheros QCA9557
- RAM              : DDR2 128 MiB (2x Winbond W9751G6KB251)
- Flash            : SPI-NOR 16 MiB (Macronix MX25L12835FMI-10G)
- WLAN             : 2.4/5 GHz 2T2R
  - 2.4 GHz        : Qualcomm Atheros QCA9557 (SoC)
  - 5 GHz          : Qualcomm Atheros QCA9882
- Ethernet         : 2x 10/100/1000 Mbps
  - phy ("PD")     : Atheros AR8035
  - phy ("PSE")    : Atheros AR8033
- LEDs/keys (GPIO) : 3x/3x
- UART             : 1x RJ-45 port
  - "SERVICE"      : TTL (3.3V)
    - port         : ttyS0
    - assignment   : 1:3.3V, 2:GND, 3:TX, 4:RX
    - settings     : 115200n8
    - note         : no compatibility with "Cisco console cable"
- Buzzer           : 1x GPIO-controlled
- USB              : 1x USB 2.0 Type-A
- Power            : DC jack or PoE
  - DC jack        : 12 VDC, 1 A (device only, rating)
  - PoE            : 802.3af/at, 48 VDC, 0.25 A (device only, rating)
  - note           : supports 802.3af supply on PSE (downstream) port
                     when powered by DC adapter or 802.3at PoE

Flash instruction using factory.bin image:

1. Boot WAB-S1167-PS without no upstream connection (or PoE connection
   without DHCP)
2. Access to the WebUI ("http://192.168.3.1") on the device and open
   firmware update page
   ("ツールボックス" -> "ファームウェア更新")
3. Select the OpenWrt factory.bin image and click update
   ("アップデート") button
4. Wait ~120 seconds to complete flashing

Revert to OEM firmware:

1. Download the latest OEM firmware
2. Remove 128 bytes(0x80) header from firmware image
3. Decode by xor with a pattern "8844a2d168b45a2d" (hex val)
4. Upload the decoded firmware to the device
5. Flash to "firmware" partition by mtd command
6. Reboot

Notes:

- To use the "SERVICE" port, the connection of 3.3V line is also
  required to enable console output.
  The uart line of "SERVICE" is branched out from the internal pin
  header with 74HC126D and 3.3V line is connected to OE pin on it.

- The same PCB is used with WAB-S600-PS.

- To supply 802.3af PoE on "PSE" port when powered by DC adapter, 12 VDC
  3.5 A adapter is recommended. (official: WAB-EX-ADP1)

MAC addresses:

Ethernet (PD, PSE): 00:90:FE:xx:xx:04 (Config, ethaddr (text))
2.4GHz            : 00:90:FE:xx:xx:04 (Config, ethaddr (text))
5GHz              : 00:90:FE:xx:xx:05

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
target/linux/ath79/dts/qca9557_elecom_wab-s1167-ps.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
target/linux/ath79/image/generic.mk

diff --git a/target/linux/ath79/dts/qca9557_elecom_wab-s1167-ps.dts b/target/linux/ath79/dts/qca9557_elecom_wab-s1167-ps.dts
new file mode 100644 (file)
index 0000000..facead9
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca955x_elecom_wab.dtsi"
+
+/ {
+       compatible = "elecom,wab-s1167-ps", "qca,qca9557";
+       model = "ELECOM WAB-S1167-PS";
+};
index 56ef7dd51fbf9fe48b36cc78fe20828e9586ed9d..fd7feb1ae57e9dd21c17769eaf041d6f136a9ba0 100644 (file)
@@ -144,6 +144,7 @@ ath79_setup_interfaces()
        alfa-network,n5q|\
        devolo,dvl1200e|\
        devolo,dvl1750e|\
+       elecom,wab-s1167-ps|\
        elecom,wab-s600-ps|\
        engenius,enstationac-v1|\
        engenius,ews511ap|\
@@ -703,6 +704,7 @@ ath79_setup_macs()
                lan_mac=$(mtd_get_mac_ascii devdata "lanmac")
                wan_mac=$(mtd_get_mac_ascii devdata "wanmac")
                ;;
+       elecom,wab-s1167-ps|\
        elecom,wab-s600-ps|\
        engenius,ecb1200|\
        engenius,ecb1750)
index 3d24a4f31a8c3bbf69c284ec53e1fb5d3c2fc50c..b238fc081e38377d0eb4ef2b89cd58a613356eb9 100644 (file)
@@ -41,6 +41,7 @@ case "$board" in
                [ "$PHYNBR" -eq 1 ] && \
                        mtd_get_mac_ascii bdcfg "wlanmac" > /sys${DEVPATH}/macaddress
                ;;
+       elecom,wab-s1167-ps|\
        elecom,wab-s600-ps)
                # set the 5G MAC address (= ethaddr + 1)
                [ "$PHYNBR" -eq 0 ] && \
index 16ef4fdca3836a0c14e36deb909ade07bbf520a4..7a2b54ddfb6f024461d8b5883207c4ca823853c9 100644 (file)
@@ -1327,6 +1327,14 @@ define Device/elecom_wab
        kmod-usb2 kmod-usb-ledtrig-usbport
 endef
 
+define Device/elecom_wab-s1167-ps
+  $(Device/elecom_wab)
+  SOC := qca9557
+  DEVICE_MODEL := WAB-S1167-PS
+  ELECOM_HWID := 0107000c
+endef
+TARGET_DEVICES += elecom_wab-s1167-ps
+
 define Device/elecom_wab-s600-ps
   $(Device/elecom_wab)
   SOC := qca9557