iproute2: update to 6.1.0
authorNick Hainke <vincent@systemli.org>
Tue, 13 Dec 2022 19:17:58 +0000 (20:17 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 18 Dec 2022 15:33:16 +0000 (16:33 +0100)
Announcement:
https://lore.kernel.org/netdev/20221214094130.7b11ec2e@hermes.local/T/#t

Refresh patch:
- 170-ip_tiny.patch

Signed-off-by: Nick Hainke <vincent@systemli.org>
package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/170-ip_tiny.patch

index 6ef0b1a96ace7ce2eba473db4dc80d8a03afd1df..39c94bd6e201f2de77013f82460cae5a63a56f18 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=6.0.0
+PKG_VERSION:=6.1.0
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=523139e9e72aec996374fa2de74be4c53d2dd05589488934d21ff97bae19580a
+PKG_HASH:=5ce12a0fec6b212725ef218735941b2dab76244db7e72646a76021b0537b43ab
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=iptables
 PKG_LICENSE:=GPL-2.0
index 9e95bcc2d629688b8498a8afbe34d9169dff5ca5..eef5e38229b8fa44594d012f7bb6fd2aa0c4cc66 100644 (file)
@@ -25,7 +25,7 @@
                sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
 --- a/ip/ip.c
 +++ b/ip/ip.c
-@@ -64,11 +64,17 @@ static void usage(void)
+@@ -65,11 +65,17 @@ static void usage(void)
        fprintf(stderr,
                "Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
                "       ip [ -force ] -batch filename\n"
@@ -43,7 +43,7 @@
                "       OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
                "                    -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
                "                    -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
-@@ -91,37 +97,49 @@ static const struct cmd {
+@@ -92,37 +98,49 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
        { "address",    do_ipaddr },