unetd: update to the latest version
authorFelix Fietkau <nbd@nbd.name>
Thu, 1 Sep 2022 18:41:42 +0000 (20:41 +0200)
committerFelix Fietkau <nbd@nbd.name>
Thu, 1 Sep 2022 18:42:08 +0000 (20:42 +0200)
f5d02c32f811 pex: add support for sending endpoint notification from the wg port via raw socket
c3b1127236a0 ubus: add support for querying active networks
8ad119715168 ubus: add support for adding auth_connect hosts at runtime
26dc52789d41 network: add support for configuring extra peers via a separate json file
d7fb9e5b065b ubus: add reload command

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/network/services/unetd/Makefile
package/network/services/unetd/files/unetd.sh

index f692f26974dc9eef1347b997dcb46ee782f0a422..06e95b3326f0a68c47da577bed664bab6e1b0f14 100644 (file)
@@ -10,9 +10,9 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=unetd
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/unetd.git
-PKG_SOURCE_DATE:=2022-08-29
-PKG_SOURCE_VERSION:=0041fcacb62492653a1054098ec7d811d8eaacbf
-PKG_MIRROR_HASH:=1aad05af0c4015dc7c07936e504a2c03ceacf676c5c15902c2049a63fab60428
+PKG_SOURCE_DATE:=2022-09-01
+PKG_SOURCE_VERSION:=d7fb9e5b065bf9eecb5bcbcf741b5f89695c5dcc
+PKG_MIRROR_HASH:=a693c2b4b4bda5e1e44b493019e8e6e6d39c4048f417b581c801a9931e6b9b39
 
 PKG_LICENSE:=GPL-2.0
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
index 581eeb95fa147c91a0d6c9ab569cf1820e1026da..70a28f64826c8de8da4d6e48eb6dac4e33039e31 100644 (file)
@@ -18,6 +18,7 @@ proto_unet_init_config() {
        proto_config_add_string domain
        proto_config_add_array "tunnels:list(string)"
        proto_config_add_array "connect:list(string)"
+       proto_config_add_array "peer_data:list(string)"
        no_device=1
        available=1
        no_proto_task=1
@@ -30,6 +31,7 @@ proto_unet_setup() {
        json_get_vars device type auth_key key file keepalive domain
        json_get_values tunnels tunnels
        json_get_values connect connect
+       json_get_values peer_data peer_data
        device="${device:-$config}"
 
        [ -n "$auth_key" ] && type="${type:-dynamic}"
@@ -60,6 +62,12 @@ proto_unet_setup() {
        done
        json_close_array
 
+       json_add_array peer_data
+       for c in $peer_data; do
+               json_add_string "" "$c"
+       done
+       json_close_array
+
        ip link del dev "$device" >/dev/null 2>&1
        ip link add dev "$device" type wireguard || {
                echo "Could not create wireguard device $device"