Fix download URL of the 4.x kernel.
authorMichael Büsch <mb@bu3sch.de>
Sun, 1 Mar 2015 20:44:33 +0000 (20:44 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sun, 1 Mar 2015 20:44:33 +0000 (20:44 +0000)
SVN-Revision: 44589

include/kernel.mk

index e21d53abb14fe657a98f3ca49e57e7bf308ff125..9c3a04b635f4b59fc0023ba28001fccc42c170bc 100644 (file)
@@ -52,7 +52,7 @@ else
   LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.xz
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE))$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
-      LINUX_SITE:=@KERNEL/linux/kernel/v3.x$(TESTING)
+      LINUX_SITE:=@KERNEL/linux/kernel/v$(word 1,$(subst ., ,$(KERNEL_BASE))).x$(TESTING)
   endif
 
   ifneq ($(TARGET_BUILD),1)