ipq806x: replace ${} with $()
authorSungbo Eo <mans0n@gorani.run>
Tue, 10 Mar 2020 04:43:18 +0000 (13:43 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 11 Mar 2020 18:24:49 +0000 (19:24 +0100)
${} and $() are exactly the same. Follow the convention of using $().

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
target/linux/ipq806x/image/Makefile

index 33f68b7a60f3550316b8bd0e60bbfe91cc662372..6f529aca0616fdeccd088977dd298469180d62c9 100644 (file)
@@ -73,11 +73,11 @@ DEVICE_VARS += TPLINK_BOARD_ID
 
 define Device/ZyXELImage
        KERNEL_SUFFIX := -uImage
-       KERNEL = kernel-bin | append-dtb | uImage none | pad-to $${KERNEL_SIZE}
+       KERNEL = kernel-bin | append-dtb | uImage none | pad-to $$(KERNEL_SIZE)
        KERNEL_NAME := zImage
        IMAGES := factory.bin sysupgrade.bin
        IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to $$$$(BLOCKSIZE) | zyxel-ras-image separate-kernel
-       IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to $$$${BLOCKSIZE} | sysupgrade-tar rootfs=$$$$@ | append-metadata
+       IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to $$$$(BLOCKSIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
 endef
 
 define Device/buffalo_wxr-2533dhp
@@ -121,7 +121,7 @@ define Device/linksys_ea8500
        SUPPORTED_DEVICES += ea8500
        UBINIZE_OPTS := -E 5
        IMAGES := factory.bin sysupgrade.bin
-       IMAGE/factory.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-ubi
+       IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
        DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
 endef
 TARGET_DEVICES += linksys_ea8500
@@ -295,7 +295,7 @@ define Device/tplink_vr2600v
        SUPPORTED_DEVICES += vr2600v
        DEVICE_PACKAGES := ath10k-firmware-qca99x0-ct
        IMAGES := sysupgrade.bin
-       IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
+       IMAGE/sysupgrade.bin := pad-extra 512 | append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata
 endef
 TARGET_DEVICES += tplink_vr2600v