ath79: rename Ubiquiti PowerBeam M (XW) to PowerBeam M5 (XW)
authorRussell Senior <russell@personaltelco.net>
Fri, 13 Aug 2021 05:57:39 +0000 (22:57 -0700)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 22 Aug 2021 20:41:41 +0000 (22:41 +0200)
The commit [1] added support for Ubiquiti PowerBeam M (XW), tested
on the PBE-M5-400. But, it turns out the PBE-M2-400 has a different
ethernet configuration, so make the support specific to the m5 version
in anticipation of adding specific support for the m2 in a separate
commit.

[1] 12eb5b2384a6 ("ath79: add support for Ubiquiti PowerBeam M (XW)")

Signed-off-by: Russell Senior <russell@personaltelco.net>
[fix model name in DTS, format commit reference in commit message]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/dts/ar9342_ubnt_powerbeam-m-xw.dts [deleted file]
target/linux/ath79/dts/ar9342_ubnt_powerbeam-m5-xw.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/image/generic-ubnt.mk

diff --git a/target/linux/ath79/dts/ar9342_ubnt_powerbeam-m-xw.dts b/target/linux/ath79/dts/ar9342_ubnt_powerbeam-m-xw.dts
deleted file mode 100644 (file)
index 6db058f..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "ar9342_ubnt_xw.dtsi"
-
-/ {
-       compatible = "ubnt,powerbeam-m-xw", "ubnt,xw", "qca,ar9342";
-       model = "Ubiquiti PowerBeam M (XW)";
-};
-
-&mdio0 {
-       status = "okay";
-
-       phy-mask = <4>;
-
-       phy4: ethernet-phy@4 {
-               reg = <4>;
-       };
-};
-
-&eth0 {
-       status = "okay";
-
-       /* default for ar934x, except for 1000M and 10M */
-       pll-data = <0x02000000 0x00000101 0x00001313>;
-
-       phy-mode = "rgmii-id";
-       phy-handle = <&phy4>;
-
-       gmac-config {
-               device = <&gmac>;
-               rxd-delay = <3>;
-               rxdv-delay = <3>;
-       };
-};
diff --git a/target/linux/ath79/dts/ar9342_ubnt_powerbeam-m5-xw.dts b/target/linux/ath79/dts/ar9342_ubnt_powerbeam-m5-xw.dts
new file mode 100644 (file)
index 0000000..e5a9af3
--- /dev/null
@@ -0,0 +1,34 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9342_ubnt_xw.dtsi"
+
+/ {
+       compatible = "ubnt,powerbeam-m5-xw", "ubnt,xw", "qca,ar9342";
+       model = "Ubiquiti PowerBeam M5 (XW)";
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <4>;
+
+       phy4: ethernet-phy@4 {
+               reg = <4>;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       /* default for ar934x, except for 1000M and 10M */
+       pll-data = <0x02000000 0x00000101 0x00001313>;
+
+       phy-mode = "rgmii-id";
+       phy-handle = <&phy4>;
+
+       gmac-config {
+               device = <&gmac>;
+               rxd-delay = <3>;
+               rxdv-delay = <3>;
+       };
+};
index 7a07b0ce6d3f64b4bded633fdc94df1b1f77f1bd..5707bbac4ee3b5194b79399e9d9470544733eb0f 100644 (file)
@@ -406,7 +406,7 @@ ubnt,nanostation-loco-m-xw|\
 ubnt,nanostation-m|\
 ubnt,nanostation-m-xw|\
 ubnt,picostation-m|\
-ubnt,powerbeam-m-xw|\
+ubnt,powerbeam-m5-xw|\
 ubnt,powerbridge-m|\
 ubnt,rocket-m)
        ucidef_set_rssimon "wlan0" "200000" "1"
index 4fe7fbc027d9ebe5a48f0b083191ee4bfc471a6e..780068790c3d3c4d147f8e440278bfab7565a1fb 100644 (file)
@@ -86,7 +86,7 @@ ath79_setup_interfaces()
        ubnt,picostation-m|\
        ubnt,powerbeam-5ac-500|\
        ubnt,powerbeam-5ac-gen2|\
-       ubnt,powerbeam-m-xw|\
+       ubnt,powerbeam-m5-xw|\
        ubnt,powerbridge-m|\
        ubnt,rocket-5ac-lite|\
        ubnt,rocket-m|\
index 01e8533fd6a258047b7d1540d3d22b74184da0df..547af632f62bc0a071aa2fad67c6a063e26eddac 100644 (file)
@@ -328,13 +328,13 @@ define Device/ubnt_powerbeam-5ac-gen2
 endef
 TARGET_DEVICES += ubnt_powerbeam-5ac-gen2
 
-define Device/ubnt_powerbeam-m-xw
+define Device/ubnt_powerbeam-m5-xw
   $(Device/ubnt-xw)
-  DEVICE_MODEL := PowerBeam M
+  DEVICE_MODEL := PowerBeam M5
   DEVICE_PACKAGES += rssileds
   SUPPORTED_DEVICES += loco-m-xw
 endef
-TARGET_DEVICES += ubnt_powerbeam-m-xw
+TARGET_DEVICES += ubnt_powerbeam-m5-xw
 
 define Device/ubnt_powerbridge-m
   $(Device/ubnt-xm)