ar71xx: add kernel support for GL-Inet V1 boards/routers
authorGabor Juhos <juhosg@openwrt.org>
Sun, 13 Jul 2014 18:21:04 +0000 (18:21 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 13 Jul 2014 18:21:04 +0000 (18:21 +0000)
The GL-Connect GL.iNet v1 router is basically a TP-Link TL-WR703N with
more DRAM/Flash, 2x Ethernet ports and console/GPIO header in the same
small form-factor:
<http://www.gl-inet.com/w/?lang=en>

Moreover, the manufacturer is promoting the OpenWrt usage to replace
the original firmware and proposing patches against both AA and trunk:
<http://www.gl-inet.com/w/?p=398&lang=en>

This is a clean up of the original manufacturer GPLv2 patch by alzhao,
proposed to the list by Mark Janssen.

Signed-off-by: Michel Stempin <michel.stempin@wanadoo.fr>
Signed-off-by: Mark Janssen <mark@sig-io.nl>
Signed-off-by: alzhao <alzhao@gmail.com>
Patchwork: http://patchwork.openwrt.org/patch/5273/
[juhosg:
  - remove user-space and image generation support, will be included
    from other patches,
  - fix coding style and drop superfluous comment in mach-gl-inet.c,
  - rename and refresh kernel patch,
  - adjust subject]
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 41618

target/linux/ar71xx/config-3.10
target/linux/ar71xx/files/arch/mips/ath79/mach-gl-inet.c [new file with mode: 0644]
target/linux/ar71xx/patches-3.10/717-MIPS-ath79-add-gl-inet-v1-support.patch [new file with mode: 0644]

index 36beb415136b6465ddf422ec8f4fd543440d81c5..367878efad53898191a65e9656a6563b2dd5f29a 100644 (file)
@@ -50,6 +50,7 @@ CONFIG_ATH79_MACH_EAP7660D=y
 CONFIG_ATH79_MACH_EL_M150=y
 CONFIG_ATH79_MACH_EL_MINI=y
 CONFIG_ATH79_MACH_EW_DORIN=y
+CONFIG_ATH79_MACH_GL_INET=y
 CONFIG_ATH79_MACH_GS_OOLITE=y
 CONFIG_ATH79_MACH_HIWIFI_HC6361=y
 CONFIG_ATH79_MACH_HORNET_UB=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-gl-inet.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-gl-inet.c
new file mode 100644 (file)
index 0000000..ef1b54f
--- /dev/null
@@ -0,0 +1,104 @@
+/*
+ *  GL-CONNECT iNet board support
+ *
+ *  Copyright (C) 2011 dongyuqi <729650915@qq.com>
+ *  Copyright (C) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2013 alzhao <alzhao@gmail.com>
+ *  Copyright (C) 2014 Michel Stempin <michel.stempin@wanadoo.fr>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+
+#include <asm/mach-ath79/ath79.h>
+
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define GL_INET_GPIO_LED_WLAN          0
+#define GL_INET_GPIO_LED_LAN           13
+#define GL_INET_GPIO_BTN_RESET         11
+
+#define GL_INET_KEYS_POLL_INTERVAL     20      /* msecs */
+#define GL_INET_KEYS_DEBOUNCE_INTERVAL (3 * GL_INET_KEYS_POLL_INTERVAL)
+
+static const char * gl_inet_part_probes[] = {
+       "tp-link", /* dont change, this will use tplink parser */
+       NULL ,
+};
+
+static struct flash_platform_data gl_inet_flash_data = {
+       .part_probes = gl_inet_part_probes,
+};
+
+static struct gpio_led gl_inet_leds_gpio[] __initdata = {
+       {
+               .name = "gl-connect:red:wireless",
+               .gpio = GL_INET_GPIO_LED_WLAN,
+               .active_low = 0,
+       },
+       {
+               .name = "gl-connect:green:lan",
+               .gpio = GL_INET_GPIO_LED_LAN,
+               .active_low = 0,
+               .default_state = 1,
+       },
+};
+
+static struct gpio_keys_button gl_inet_gpio_keys[] __initdata = {
+       {
+               .desc = "reset",
+               .type = EV_KEY,
+               .code = KEY_RESTART,
+               .debounce_interval = GL_INET_KEYS_DEBOUNCE_INTERVAL,
+               .gpio = GL_INET_GPIO_BTN_RESET,
+               .active_low = 0,
+       }
+};
+
+static void __init gl_inet_setup(void)
+{
+       /* get the mac address which is stored in the 1st 64k uboot MTD */
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+
+       /* get the art address, which is the last 64K. By using
+          0x1fff1000, it doesn't matter it is 4M, 8M or 16M flash */
+       u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+       /* disable PHY_SWAP and PHY_ADDR_SWAP bits */
+       ath79_setup_ar933x_phy4_switch(false, false);
+
+       /* register flash. MTD will use tp-link parser to parser MTD */
+       ath79_register_m25p80(&gl_inet_flash_data);
+
+       /* register gpio LEDs and keys */
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(gl_inet_leds_gpio),
+                                gl_inet_leds_gpio);
+       ath79_register_gpio_keys_polled(-1, GL_INET_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(gl_inet_gpio_keys),
+                                       gl_inet_gpio_keys);
+
+       /* enable usb */
+       ath79_register_usb();
+
+       /* register eth0 as WAN, eth1 as LAN */
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+       ath79_register_mdio(0, 0x0);
+       ath79_register_eth(0);
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, 0);
+       ath79_register_eth(1);
+
+       /* register wireless mac with cal data */
+       ath79_register_wmac(ee, mac);
+}
+
+MIPS_MACHINE(ATH79_MACH_GL_INET, "GL-INET", "GL-CONNECT INET v1",
+            gl_inet_setup);
diff --git a/target/linux/ar71xx/patches-3.10/717-MIPS-ath79-add-gl-inet-v1-support.patch b/target/linux/ar71xx/patches-3.10/717-MIPS-ath79-add-gl-inet-v1-support.patch
new file mode 100644 (file)
index 0000000..d85ad23
--- /dev/null
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -357,6 +357,16 @@ config ATH79_MACH_EL_MINI
+       select ATH79_DEV_USB
+       select ATH79_DEV_WMAC
++config ATH79_MACH_GL_INET
++      bool "GL-INET support"
++      select SOC_AR933X
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_USB
++      select ATH79_DEV_WMAC
++
+ config ATH79_MACH_GS_OOLITE
+        bool "GS Oolite V1 support"
+        select SOC_AR933X
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -52,6 +52,7 @@ enum ath79_mach_type {
+       ATH79_MACH_EAP7660D,            /* Senao EAP7660D */
+       ATH79_MACH_EL_M150,             /* EasyLink EL-M150 */
+       ATH79_MACH_EL_MINI,             /* EasyLink EL-MINI */
++      ATH79_MACH_GL_INET,             /* GL-CONNECT GL-INET */
+       ATH79_MACH_GS_OOLITE,           /* GS OOLITE V1.0 */
+       ATH79_MACH_HIWIFI_HC6361,       /* HiWiFi HC6361 */
+       ATH79_MACH_JA76PF,              /* jjPlus JA76PF */
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -64,6 +64,7 @@ obj-$(CONFIG_ATH79_MACH_EW_DORIN)    += mac
+ obj-$(CONFIG_ATH79_MACH_EAP7660D)     += mach-eap7660d.o
+ obj-$(CONFIG_ATH79_MACH_EL_M150)      += mach-el-m150.o
+ obj-$(CONFIG_ATH79_MACH_EL_MINI)      += mach-el-mini.o
++obj-$(CONFIG_ATH79_MACH_GL_INET)      += mach-gl-inet.o
+ obj-$(CONFIG_ATH79_MACH_GS_OOLITE)    += mach-gs-oolite.o
+ obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361)        += mach-hiwifi-hc6361.o
+ obj-$(CONFIG_ATH79_MACH_JA76PF)               += mach-ja76pf.o