realtek: rename hpe,1920-8g-poe to match hardware
authorKevin Jilissen <info@kevinjilissen.nl>
Sun, 8 Oct 2023 14:56:40 +0000 (16:56 +0200)
committerSander Vanheule <sander@svanheule.net>
Mon, 9 Oct 2023 17:27:50 +0000 (19:27 +0200)
There are two hardware models of the HPE 1920-8g-poe switch. The version
currently in the repository is the model with a PoE budget of 180W. In
preparation of the addition of the 65W model, the existing model is
renamed to clarify the hardware version it targets.

As suggested by Pawel, the 'SUPPORTED_DEVICES' includes the old target
name to enable an upgrade path of builds with the old name.

Suggested-by: Pawel Dembicki <paweldembicki@gmail.com>
Signed-off-by: Kevin Jilissen <info@kevinjilissen.nl>
target/linux/realtek/base-files/etc/board.d/02_network
target/linux/realtek/base-files/etc/board.d/03_gpio_switches
target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe-180w.dts [new file with mode: 0644]
target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe.dts [deleted file]
target/linux/realtek/image/rtl838x.mk

index 90b45abf94baede094bbd2e7f6a2846d77f135bd..84d3e68e48f3186a8a3ac3db5d92bfffd79211a7 100644 (file)
@@ -31,7 +31,7 @@ lan_mac_end=""
 label_mac=""
 case $board in
 hpe,1920-8g|\
-hpe,1920-8g-poe|\
+hpe,1920-8g-poe-180w|\
 hpe,1920-16g|\
 hpe,1920-24g)
        label_mac=$(mtd_get_mac_binary factory 0x68)
@@ -67,7 +67,7 @@ done
 [ -n "$label_mac" ] && ucidef_set_label_macaddr $label_mac
 
 case $board in
-hpe,1920-8g-poe)
+hpe,1920-8g-poe-180w)
        ucidef_set_poe 180 "$lan_list_rev" "lan9 lan10"
        ;;
 netgear,gs110tpp-v1)
index abfcb8e5924014b8c855958ec5261e2da97de880..1e49d89c64a2414fe2f44c07c3aa24549c73d9f6 100644 (file)
@@ -6,7 +6,7 @@ board_config_update
 board=$(board_name)
 
 case "$board" in
-hpe,1920-8g-poe)
+hpe,1920-8g-poe-180w)
        ucidef_add_gpio_switch "fan_ctrl" "Fan control" "456" "0"
        ;;
 esac
diff --git a/target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe-180w.dts b/target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe-180w.dts
new file mode 100644 (file)
index 0000000..6398e6d
--- /dev/null
@@ -0,0 +1,12 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "rtl8380_hpe_1920-8g.dtsi"
+
+/ {
+       compatible = "hpe,1920-8g-poe-180w", "realtek,rtl838x-soc";
+       model = "HPE 1920-8G-PoE+ 180W (JG922A)";
+};
+
+&uart1 {
+       status = "okay";
+};
diff --git a/target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe.dts b/target/linux/realtek/dts-5.15/rtl8380_hpe_1920-8g-poe.dts
deleted file mode 100644 (file)
index 3b00c31..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "rtl8380_hpe_1920-8g.dtsi"
-
-/ {
-       compatible = "hpe,1920-8g-poe", "realtek,rtl838x-soc";
-       model = "HPE 1920-8G-PoE+ (JG922A)";
-};
-
-&uart1 {
-       status = "okay";
-};
index 73930f4d6f41a4db3aaa0e4bdd4865d3e0987922..c0b9c70bb6f7c23190704c9f706dc83999c00582 100644 (file)
@@ -99,13 +99,14 @@ define Device/hpe_1920-8g
 endef
 TARGET_DEVICES += hpe_1920-8g
 
-define Device/hpe_1920-8g-poe
+define Device/hpe_1920-8g-poe-180w
   $(Device/hpe_1920)
   SOC := rtl8380
-  DEVICE_MODEL := 1920-8G-PoE+ (JG922A)
+  DEVICE_MODEL := 1920-8G-PoE+ 180W (JG922A)
   H3C_DEVICE_ID := 0x00010025
+  SUPPORTED_DEVICES += hpe_1920-8g-poe
 endef
-TARGET_DEVICES += hpe_1920-8g-poe
+TARGET_DEVICES += hpe_1920-8g-poe-180w
 
 define Device/hpe_1920-16g
   $(Device/hpe_1920)