build: move xor-image into image-commands
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Wed, 12 Dec 2018 12:12:27 +0000 (21:12 +0900)
committerChristian Lamparter <chunkeey@gmail.com>
Mon, 24 Dec 2018 18:18:07 +0000 (19:18 +0100)
I moved xor-image into image-commands.mk to use it in ath79 target.

It required for NEC WG800HP.

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
include/image-commands.mk
target/linux/brcm63xx/image/Makefile

index 5e24c5e3aac39f63041b20f0d19ace1b20e39bea..65fa36d2beb1c82a4fc757450f67a68185f3dc11 100644 (file)
@@ -242,6 +242,11 @@ define Build/pad-offset
        mv $@.new $@
 endef
 
+define Build/xor-image
+       $(STAGING_DIR_HOST)/bin/xorimage -i $@ -o $@.xor $(1)
+       mv $@.xor $@
+endef
+
 define Build/check-size
        @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -ge "$$(stat -c%s $@)" ] || { \
                echo "WARNING: Image file $@ is too big" >&2; \
index 21fc69e24efb29ebaa6e2d01a6ddef709e2891b9..1cf64bd8e706bf040fde7621439c871c2f4dbbbc 100644 (file)
@@ -132,11 +132,6 @@ define Build/spw303v-bin
        mv $@.spw303v $@
 endef
 
-define Build/xor-image
-       $(STAGING_DIR_HOST)/bin/xorimage -i $@ -o $@.xor
-       mv $@.xor $@
-endef
-
 define Build/zyxel-bin
        $(STAGING_DIR_HOST)/bin/zyxbcm -i $@ -o $@.zyxel
        mv $@.zyxel $@