ath79: remove generic profiles
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 21 Jan 2021 19:37:55 +0000 (20:37 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 27 Jan 2021 20:31:20 +0000 (21:31 +0100)
On a platform with many very different devices, like found on ath79,
the generic profiles seem like remnants of the past that do not
have a real use anymore.

Remove them to have one thing less to maintain.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Acked-by: Paul Spooren <mail@aparcar.org>
target/linux/ath79/generic/profiles/00-default.mk [deleted file]
target/linux/ath79/mikrotik/profiles/00-default.mk [deleted file]
target/linux/ath79/nand/profiles/00-default.mk [deleted file]
target/linux/ath79/tiny/profiles/00-default.mk [deleted file]

diff --git a/target/linux/ath79/generic/profiles/00-default.mk b/target/linux/ath79/generic/profiles/00-default.mk
deleted file mode 100644 (file)
index 83b39e4..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-       NAME:=Default Profile (all drivers)
-       PRIORITY := 1
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/mikrotik/profiles/00-default.mk b/target/linux/ath79/mikrotik/profiles/00-default.mk
deleted file mode 100644 (file)
index 14712da..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2020 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-       NAME:=Default Profile (all drivers)
-       PACKAGES:= \
-               kmod-usb-ohci kmod-usb2 nand-utils
-       PRIORITY := 1
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/nand/profiles/00-default.mk b/target/linux/ath79/nand/profiles/00-default.mk
deleted file mode 100644 (file)
index 6e61811..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-       NAME:=Default Profile
-       PACKAGES:= \
-               kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
-       PRIORITY := 1
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/ath79/tiny/profiles/00-default.mk b/target/linux/ath79/tiny/profiles/00-default.mk
deleted file mode 100644 (file)
index aa8e119..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-define Profile/Default
-       NAME:=Default Profile (all drivers)
-       PRIORITY := 1
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))