ath79: add support for ALFA Network R36A
authorPiotr Dymacz <pepe2k@gmail.com>
Thu, 2 Jul 2020 05:03:33 +0000 (07:03 +0200)
committerPiotr Dymacz <pepe2k@gmail.com>
Sun, 27 Sep 2020 23:28:37 +0000 (01:28 +0200)
ALFA Network R36A is a successor of the previous model, the R36 (Ralink
RT3050F based). New version is based on Qualcomm/Atheros QCA9531 v2, FCC
ID: 2AB879531.

Support for this device was first introduced in af8f0629df (ar71xx
target). When updating from previous release (and/or ar71xx target),
user should only adjust the WAN LED trigger type (netdev in ar71xx,
switch port in ath79).

Specifications:

- Qualcomm/Atheros QCA9531 v2
- 650/400/200 MHz (CPU/DDR/AHB)
- 128 MB (R36AH/-U2) or 64 MB (R36A) of RAM (DDR2)
- 16 MB of flash (SPI NOR)
- 2x 10/100 Mbps Ethernet
- Passive PoE input support (12~36 V) in RJ45 near DC jack
- 2T2R 2.4 GHz Wi-Fi with Qorvo RFFM8228P FEM
- 2x IPEX/U.FL connectors on PCB
- 1x USB 2.0 Type-A
- 1x USB 2.0 mini Type-B in R36AH-U2 version
- USB power is controlled by GPIO
- 6/7x LED (5/6 of them are driven by GPIO)
- 2x button (reset, wifi/wps)
- external h/w watchdog (EM6324QYSP5B, enabled by default)
- DC jack with lock, for main power input (12 V)
- UART (4-pin, 2.54 mm pitch) header on PCB

Optional/additional features in R36A series (R36A was the first model):
- for R36AH:    USB 2.0 hub*
- for R36AH-U2: USB 2.0 hub*, 1x USB 2.0 mini Type-B, one more LED

*) there are at least three different USB 2.0 hub in R36AH/-U2 variants:
- Terminus-Tech FE 1.1
- Genesys Logic GL852G
- Genesys Logic GL850G (used in latests revision)

Flash instruction:

You can use sysupgrade image directly in vendor firmware which is based
on LEDE/OpenWrt. Alternatively, you can use web recovery mode in U-Boot:

1. Configure PC with static IP 192.168.1.2/24.
2. Connect PC with one of RJ45 ports, press the reset button, power up
   device, wait for first blink of all LEDs (indicates network setup),
   then keep button for 3 following blinks and release it.
3. Open 192.168.1.1 address in your browser and upload sysupgrade image.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
target/linux/ath79/dts/qca9531_alfa-network_r36a.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/image/generic.mk

diff --git a/target/linux/ath79/dts/qca9531_alfa-network_r36a.dts b/target/linux/ath79/dts/qca9531_alfa-network_r36a.dts
new file mode 100644 (file)
index 0000000..18aaa85
--- /dev/null
@@ -0,0 +1,190 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca953x.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "ALFA Network R36A";
+       compatible = "alfa-network,r36a", "qca,qca9531";
+
+       aliases {
+               label-mac-device = &wmac;
+               led-boot = &led_status;
+               led-failsafe = &led_status;
+               led-running = &led_status;
+               led-upgrade = &led_status;
+       };
+
+       gpio-export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               usb-power {
+                       gpio-export,name = "usb-power";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 3 GPIO_ACTIVE_HIGH>;
+               };
+
+               watchdog-enable {
+                       gpio-export,name = "watchdog-enable";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 1 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+
+               rfkill {
+                       label = "rfkill";
+                       linux,code = <KEY_RFKILL>;
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               pinctrl-names = "default";
+               pinctrl-0 = <&enable_gpio4 &enable_gpio16>;
+
+               lan {
+                       label = "r36a:blue:lan";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+
+               led_status: status {
+                       label = "r36a:blue:status";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               usb {
+                       label = "r36a:blue:usb";
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+                       trigger-sources = <&hub_port0>;
+                       linux,default-trigger = "usbport";
+               };
+
+               wan {
+                       label = "r36a:blue:wan";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "r36a:blue:wlan";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+       };
+
+       watchdog {
+               compatible = "linux,wdt-gpio";
+               gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+               hw_algo = "toggle";
+               hw_margin_ms = <25000>;
+               always-running;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&swphy4>;
+       mtd-mac-address = <&art 0x0>;
+};
+
+&eth1 {
+       /* Workaround: keep the Ethernet interfaces order/mapping correct
+        * (GMAC0 -> eth0, GMAC1 -> eth1, same as in old ar71xx target) */
+       compatible = "qca,qca9530-eth", "syscon", "simple-mfd";
+
+       mtd-mac-address = <&art 0x6>;
+};
+
+&pinmux {
+       enable_gpio4: pinmux_enable_gpio4 {
+               pinctrl-single,bits = <0x04 0x0 0xff>;
+       };
+
+       enable_gpio16: pinmux_enable_gpio16 {
+               pinctrl-single,bits = <0x10 0x0 0xff>;
+       };
+};
+
+&spi {
+       status = "okay";
+
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <50000000>;
+               m25p,fast-read;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x060000>;
+                               read-only;
+                       };
+
+                       partition@60000 {
+                               label = "u-boot-env";
+                               reg = <0x060000 0x010000>;
+                       };
+
+                       art: partition@70000 {
+                               label = "art";
+                               reg = <0x070000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@80000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x080000 0xf80000>;
+                       };
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&usb0 {
+       status = "okay";
+
+       #address-cells = <1>;
+       #size-cells = <0>;
+
+       hub_port0: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&usb_phy {
+       status = "okay";
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+};
index 78726afecfd463966ffef3a48d4a6bf495cf9620..6e488949e438dcfc3afc8570c96488914e7a6e8f 100755 (executable)
@@ -17,6 +17,10 @@ alfa-network,ap121fe|\
 avm,fritz450e)
        ucidef_set_led_netdev "lan" "LAN" "$boardname:green:lan" "eth0"
        ;;
+alfa-network,r36a)
+       ucidef_set_led_netdev "lan" "LAN" "$boardname:blue:lan" "eth0"
+       ucidef_set_led_switch "wan" "WAN" "$boardname:blue:wan" "switch0" "0x10"
+       ;;
 avm,fritz1750e)
        ucidef_set_led_netdev "lan" "LAN" "$boardname:green:lan" "eth0"
        ucidef_set_rssimon "wlan1" "200000" "1"
index ab8e24added6d5157e54055dc40899c155ed26d2..d13d714f8854f47ee1520a503851a037337a91a6 100755 (executable)
@@ -402,6 +402,7 @@ ath79_setup_macs()
                ;;
        alfa-network,ap121f|\
        alfa-network,ap121fe|\
+       alfa-network,r36a|\
        engenius,ens202ext-v1)
                label_mac=$(mtd_get_mac_binary art 0x1002)
                ;;
index ce927ecd4f2c3be4358fa8ccd1e4e126a16df75f..605f66f77fcad3d9ee828ac60ef6d8e29873539a 100644 (file)
@@ -237,6 +237,16 @@ define Device/alfa-network_ap121fe
 endef
 TARGET_DEVICES += alfa-network_ap121fe
 
+define Device/alfa-network_r36a
+  SOC := qca9531
+  DEVICE_VENDOR := ALFA Network
+  DEVICE_MODEL := R36A
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
+  IMAGE_SIZE := 15872k
+  SUPPORTED_DEVICES += r36a
+endef
+TARGET_DEVICES += alfa-network_r36a
+
 define Device/allnet_all-wap02860ac
   SOC := qca9558
   DEVICE_VENDOR := ALLNET