x86: move packages selection to profiles
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Mon, 20 Apr 2020 17:46:34 +0000 (19:46 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 20 Apr 2020 17:55:30 +0000 (18:55 +0100)
This can be rather confusing for contributors, since there are three
layers in which they can be added. As for now there are none profiles
other than generic (exception: geos) let's move them to these profiles.
Being here this commit also removes packages in geode profiles already
enabled in kernel config.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
target/linux/x86/64/target.mk
target/linux/x86/geode/target.mk
target/linux/x86/image/64.mk

index 02b6c8debfe14dd4435f5bf024f0532b636cf6f8..ece3d1bc9a16a6818968092d3b19c89ea0d4706a 100644 (file)
@@ -1,7 +1,5 @@
 ARCH:=x86_64
 BOARDNAME:=x86_64
-DEFAULT_PACKAGES += kmod-e1000e kmod-e1000 kmod-r8169 kmod-igb kmod-bnx2 \
-       kmod-forcedeth
 
 define Target/Description
         Build images for 64 bit systems including virtualized guests.
index 04ac926cfd955ac1b3b4c5448ad6fdaa062530de..a64d2baaeec2dbcb66e17dac22553519e3b5ad41 100644 (file)
@@ -1,15 +1,5 @@
 BOARDNAME:=AMD Geode based systems
 FEATURES += pci usb gpio
-DEFAULT_PACKAGES += \
-                       kmod-crypto-hw-geode kmod-crypto-cbc \
-                       kmod-ath5k kmod-ath9k \
-                       kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
-                       kmod-ledtrig-netdev hwclock wpad-basic
-# Geos
-DEFAULT_PACKAGES += \
-               soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
-               hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
-               kmod-usb-ohci-pci kmod-hwmon-lm90
 
 define Target/Description
        Build firmware images for AMD Geode GX/LX based systems (net5501, alix, geos)
index bde76ceba5dd9107100058b5f476fe18cc5ddda4..61e6d408d7ced4c0ab6d4131b4282df4c53c1e4a 100644 (file)
@@ -1,5 +1,7 @@
 define Device/generic
   DEVICE_TITLE := Generic x86/64
+  DEVICE_PACKAGES += kmod-bnx2 kmod-e1000e kmod-e1000 kmod-forcedeth kmod-igb \
+       kmod-r8169
   GRUB2_VARIANT := generic
 endef
 TARGET_DEVICES += generic